Home » Server Options » RAC & Failsafe » Issue with OraInventory location during upgrade (Oracle 10.2.0.3 (RAC))
Issue with OraInventory location during upgrade [message #420849] Wed, 02 September 2009 11:12 Go to next message
divroro12
Messages: 105
Registered: March 2008
Location: Laurel, MD USA
Senior Member
Hi All,

I'm trying to upgrade my RAC database from 10.2.0.3 to 10.2.0.4 & am getting the following message after launching OUI

"Central Inventory '/u01/app/oracle/oraInventory' is on a shared drive. Each node 'lbdbora1, lbdbora2' should have its own central Inventory. Central Inventory cannot be shared, this is not supported".

My central Inventory is definitely not on a shared drive. Each of the nodes has a separate central inventory located on the path shown above.

Can anyone tell me why i'm getting this error message & how it can be corrected?



Thanks,

divroro12
Re: Issue with OraInventory location during upgrade [message #420852 is a reply to message #420849] Wed, 02 September 2009 11:20 Go to previous messageGo to next message
BlackSwan
Messages: 22911
Registered: January 2009
Senior Member
You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/
Go to the URL above click the link "Posting Guidelines"
Go to the section labeled "Practice" & do as directed.

Oracle is correct more often than it is wrong.
Without conclusive proof to the contrary, I'll trust Oracle to better report reality than you.
Re: Issue with OraInventory location during upgrade [message #420857 is a reply to message #420852] Wed, 02 September 2009 11:29 Go to previous messageGo to next message
divroro12
Messages: 105
Registered: March 2008
Location: Laurel, MD USA
Senior Member
BlackSwan,

Can you please tell me where i went wrong with my posting? (this is not the 1st time i'm posting on this forum & i try as much as possible to follow the guidelines).
Your advice will be very much appreciated.

Thanks,

divroro12
Re: Issue with OraInventory location during upgrade [message #420864 is a reply to message #420857] Wed, 02 September 2009 12:52 Go to previous messageGo to next message
divroro12
Messages: 105
Registered: March 2008
Location: Laurel, MD USA
Senior Member
SQL> select * from v$version;

BANNER
----------------------------------------------------------------
Oracle Database 10g Enterprise Edition Release 10.2.0.3.0 - 64bi
PL/SQL Release 10.2.0.3.0 - Production
CORE 10.2.0.3.0 Production
TNS for IBM/AIX RISC System/6000: Version 10.2.0.3.0 - Productio
NLSRTL Version 10.2.0.3.0 - Production
Re: Issue with OraInventory location during upgrade [message #420865 is a reply to message #420849] Wed, 02 September 2009 12:54 Go to previous messageGo to next message
BlackSwan
Messages: 22911
Registered: January 2009
Senior Member
If you know Oracle to be behaving incorrectly, then submit a bug report via MetaLink.
Re: Issue with OraInventory location during upgrade [message #420866 is a reply to message #420849] Wed, 02 September 2009 13:39 Go to previous messageGo to next message
divroro12
Messages: 105
Registered: March 2008
Location: Laurel, MD USA
Senior Member
Thank you

divroro12
Re: Issue with OraInventory location during upgrade [message #420982 is a reply to message #420866] Thu, 03 September 2009 09:54 Go to previous messageGo to next message
babuknb
Messages: 1733
Registered: December 2005
Location: NJ
Senior Member


Hello,

I'm note sure what's your storage. Before raise TAR you may need to check the below links

http://forums.oracle.com/forums/thread.jspa?messageID=3323714

Document Nr: 604513.1

Thanks
Re: Issue with OraInventory location during upgrade [message #420985 is a reply to message #420866] Thu, 03 September 2009 10:02 Go to previous messageGo to next message
divroro12
Messages: 105
Registered: March 2008
Location: Laurel, MD USA
Senior Member
Does anyone have any documentation on how to rebuild the Central Inventory?

- divroro12 -
Re: Issue with OraInventory location during upgrade [message #420986 is a reply to message #420985] Thu, 03 September 2009 10:04 Go to previous messageGo to next message
babuknb
Messages: 1733
Registered: December 2005
Location: NJ
Senior Member


Hello,

Have you checked the above document from metalink ?

- Babu
Re: Issue with OraInventory location during upgrade [message #420997 is a reply to message #420849] Thu, 03 September 2009 11:00 Go to previous messageGo to next message
divroro12
Messages: 105
Registered: March 2008
Location: Laurel, MD USA
Senior Member
I checked this document, but it doesn't apply to me. My OraInventory is not on a shared drive.
Re: Issue with OraInventory location during upgrade [message #421000 is a reply to message #420997] Thu, 03 September 2009 11:10 Go to previous messageGo to next message
babuknb
Messages: 1733
Registered: December 2005
Location: NJ
Senior Member


Okay. Are you sure do you have own inventory on both nodes ?

- Babu
Re: Issue with OraInventory location during upgrade [message #421492 is a reply to message #420849] Tue, 08 September 2009 13:31 Go to previous messageGo to next message
divroro12
Messages: 105
Registered: March 2008
Location: Laurel, MD USA
Senior Member
Node1
------
(oracle@lbdbora1) /home/oracle > cat /etc/oraInst.loc
inventory_loc=/u01/app/oracle/oraInventory
inst_group=dba

Node2:
-------
(oracle@lbdbora2) /sw/Oracle/AIX/oracle_10204/Disk1 > cat /etc/oraInst.loc
inventory_loc=/u01/app/oracle/oraInventory
inst_group=dba
__________________
Regards,

divroro12
Re: Issue with OraInventory location during upgrade [message #421519 is a reply to message #421492] Wed, 09 September 2009 00:17 Go to previous messageGo to next message
babuknb
Messages: 1733
Registered: December 2005
Location: NJ
Senior Member

What about your ORACLE_HOME & ORACLE_CRS_HOME ?? Post the details

Thanks
Re: Issue with OraInventory location during upgrade [message #421787 is a reply to message #420849] Thu, 10 September 2009 10:09 Go to previous messageGo to next message
divroro12
Messages: 105
Registered: March 2008
Location: Laurel, MD USA
Senior Member
Node1
======
(oracle@lbdbora1) /home/oracle > echo $ORACLE_HOME
/u01/app/oracle/product/10.2.0_db
(oracle@lbdbora1) /home/oracle > echo $ORACLE_CRS_HOME
/u01/crs/oracle/product/10.2.0

Node2
======
(oracle@lbdbora2) /home/oracle > echo $ORACLE_HOME
/u01/app/oracle/product/10.2.0_db
(oracle@lbdbora2) /home/oracle > echo $ORACLE_CRS_HOME
/u01/crs/oracle/product/10.2.0

Re: Issue with OraInventory location during upgrade [message #422010 is a reply to message #421787] Sun, 13 September 2009 04:24 Go to previous message
babuknb
Messages: 1733
Registered: December 2005
Location: NJ
Senior Member

>>I checked this document, but it doesn't apply to me. My OraInventory is not on a shared drive.

Quote:
Node1
------
(oracle@lbdbora1) /home/oracle > cat /etc/oraInst.loc
inventory_loc=/u01/app/oracle/oraInventory
inst_group=dba

Node2:
-------
(oracle@lbdbora2) /sw/Oracle/AIX/oracle_10204/Disk1 > cat /etc/oraInst.loc
inventory_loc=/u01/app/oracle/oraInventory
inst_group=dba 


Quote:

Node1
======
(oracle@lbdbora1) /home/oracle > echo $ORACLE_HOME
/u01/app/oracle/product/10.2.0_db
(oracle@lbdbora1) /home/oracle > echo $ORACLE_CRS_HOME
/u01/crs/oracle/product/10.2.0

Node2
======
(oracle@lbdbora2) /home/oracle > echo $ORACLE_HOME
/u01/app/oracle/product/10.2.0_db
(oracle@lbdbora2) /home/oracle > echo $ORACLE_CRS_HOME
/u01/crs/oracle/product/10.2.0



As per your update you have shared inventory.

Before doing patch installation set proper ORACLE_HOME or CRS_HOME

Thanks
Previous Topic: Performance tuning for Failsafe configured databases
Next Topic: cant run dbca , netca,netmgr
Goto Forum:
  


Current Time: Sat Oct 25 08:41:11 CDT 2014

Total time taken to generate the page: 0.09558 seconds