Home » Developer & Programmer » Forms » FRM-40501 and ORA-02014 despite instead of trigger on view (Forms :10.1.2.3; Database: 9.2.0.8; OS Win2K3 EE server)
FRM-40501 and ORA-02014 despite instead of trigger on view [message #418838] Tue, 18 August 2009 13:37 Go to next message
rdesai
Messages: 2
Registered: August 2009
Junior Member
I have a view which gives me a tablular view in a form. This view does use 'group by' function, decode, etc. but I have defined "instead of" trigger for this view for update and insert to perform these actions on the base table. Tested that the update statement on the view at SQL prompt works fine too, i.e., an update statement against view does update the base table with no error. But when edit (update/ insert) is attempted from the form, it gives me FRM-40501 first and when I click 'Display error' from the help menu, it shows the ORA-02014 error. How can I eliminate this errors?

Efforts on research: After quite a bit of search: I have found one post which was mentioning that if "row-lock" mode is set to "none" in form, the "instead of" trigger will take responsibility of locking the record and performing update/insert. But the form has only three mode: 'Automatic', 'immediate', and 'Delayed'. I have tried changing these mode. The 'delayed' mode throws the same errors but just delays. If there is a way to set "row-lock" mode to 'none', it would help but I do not know. Any idea?!!!
Re: FRM-40501 and ORA-02014 despite instead of trigger on view [message #422881 is a reply to message #418838] Mon, 21 September 2009 01:16 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you solved your problem?

Have you played with the 'on-lock' trigger?

Consider moving the 'instead of' code to the form in the 'on-insert' and 'on-update' triggers.

David
icon7.gif  Re: FRM-40501 and ORA-02014 despite instead of trigger on view [message #422984 is a reply to message #422881] Mon, 21 September 2009 10:34 Go to previous message
rdesai
Messages: 2
Registered: August 2009
Junior Member
I have sucessfully implemented 'on-lock' & all DML triggers and had gotten past this error. Everything works!
Previous Topic: Using Menus
Next Topic: infinite loop caused by when-new-item-instance
Goto Forum:
  


Current Time: Wed Sep 28 16:01:51 CDT 2016

Total time taken to generate the page: 0.15079 seconds