Home » Open Source » Programming Interfaces » DBD:Oracle make test failure (Oracle 10.2.0.3 rdbms on Solaris x86 64bit)
DBD:Oracle make test failure [message #417660] Mon, 10 August 2009 18:50 Go to next message
hemloc
Messages: 2
Registered: August 2009
Location: WA
Junior Member
Hello -
Having trouble building DBD::Oracle v.1.23 (w/ DBI v1.609) on a Solaris 10 application server. Sqlplus to the remote database works fine. My TNSNAMES.ora file has worked for other apps on this box so i know its ok. The SQLNET.ora file has the following entry:

NAMES.DIRECTORY_PATH= (TNSNAMES, EZCONNECT)

Here are the env variables:

ORACLE_BASE=/app/oracle
ORACLE_SID=gttmdev
ORA_NLS10=/app/oracle/product/10.2/db/nls/data
ORACLE_HOME=/app/oracle/product/10.2/db
ORACLE_USERID=gttm/gttm@gttmdev
ORAENV_ASK=YES

The problem is running "make test". I get the following error:

$ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t
/*.t
t/01base................# Test loading DBI, DBD::Oracle and version
t/01base................ok
t/10general.............# Test preparsing, Active, NLS_NUMERIC_CHARACTERS, err, ping and OCI version
DBI connect('','gttm/gttm@gttmdev',...) failed: ORA-12154: TNS:could not resolve the connect identifier spe
cified (DBD ERROR: OCIServerAttach) at t/10general.t line 23

If i modify the files in the ./t/ sub-directory (ie, 01general.t, 12impdata.t) and hardcode the "DBI->connect" string with the dsn, user/passwd then it will eventually work. But, it is extremely slow. Does anyone have any ideas? Please let me know if i should be posting this in a different forum.

Thank you
jim



[Updated on: Mon, 10 August 2009 23:22] by Moderator

Report message to a moderator

Re: DBD:Oracle make test failure [message #417674 is a reply to message #417660] Mon, 10 August 2009 23:25 Go to previous messageGo to next message
BlackSwan
Messages: 25035
Registered: January 2009
Location: SoCal
Senior Member
TWO_TASK=<tns_alias>
export TWO_TASK
Re: DBD:Oracle make test failure [message #417800 is a reply to message #417674] Tue, 11 August 2009 10:08 Go to previous message
hemloc
Messages: 2
Registered: August 2009
Location: WA
Junior Member
I forgot to mention that I already had TWO_TASK defined. Sorry about that.
Previous Topic: how do i call oracle stored procedure by using oledb.net
Next Topic: User facing an issue with MS -Access
Goto Forum:
  


Current Time: Sat Dec 03 20:06:30 CST 2016

Total time taken to generate the page: 0.08615 seconds