Home » Developer & Programmer » Forms » Unable to read client image file using webutil (Oracle 10gR2 Webforms, Windows 2003 Server, Oracle 10g Database)
icon9.gif  Unable to read client image file using webutil [message #416974] Wed, 05 August 2009 08:53 Go to next message
vikram_contact
Messages: 19
Registered: August 2008
Junior Member
Hi,
I configured webutils on two servers nad in one server everything is fine, while in the second server while reading a image it does not throw any error but it does not read the image.
All the configuration and settings are same but the database is different(Both are 10g)
I can see the java console and the error there is:

Loading frmwebutil.jar from JAR cache

Loading frmall_jinit.jar from JAR cache

RegisterWebUtil - Loading WebUtil Version 10.1.2.3

Loading jacob.jar from JAR cache

2009-Aug-05 15:39:07.587 ERROR>WUF-131 [CLIENT_IMAGE.WRITE_IMAGE_FILE] Invalid client file name \\lgneltst-nt4020.ikeadt.com\IMAGES$\userimages\10823chair2.JPG. Cannot create client file

------------------
I am able to read the path of the file, the image file is also accessible.

I dont know where the problem is occuring.

Re: Unable to read client image file using webutil [message #417062 is a reply to message #416974] Wed, 05 August 2009 19:44 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Does the AS have the same permissions on the two servers? I think not.

David
Re: Unable to read client image file using webutil [message #417107 is a reply to message #417062] Thu, 06 August 2009 01:40 Go to previous messageGo to next message
vikram_contact
Messages: 19
Registered: August 2008
Junior Member
Hi David,
Thanks for the reply.

If you are talking about the webforms process running in the server then they both run as the same user.

If there is any other place I can check for the permissions please let me know so that I can compare.


Regards,
Vikram.
Re: Unable to read client image file using webutil [message #417108 is a reply to message #417107] Thu, 06 August 2009 01:42 Go to previous message
vikram_contact
Messages: 19
Registered: August 2008
Junior Member

Also I found the following information on metalink, but the solution provided in here also did not work.

-----
Subject: CLIENT_IMAGE.WRITE_IMAGE_FILE Of Webutil 1.0.6 Does Not Work

Applies to: Oracle Forms - Version: 10.1.2 to 10.1.2
This problem can occur on any platform.
This problem is related to Forms 10.1.2 and herein Webutil 1.0.6 Symptoms When trying to use the CLIENT_IMAGE.WRITE_IMAGE_FILE command in the webutil-pll (Webutil: version 1.0.6; jacob version: 1.Cool which is called from a Form e. g. via a button then there is no image file created in the relevant directory of the client and there is also no exception or error message!
It can be observed that two .tmp-files were created, like TLB19D2.tmp and TLB19D1.tmp.
ChangesIt only occurs in Webutil 1.0.6. Older versions of Webutil work fine. CauseThere has been a code error detected in the relevant pll. SolutionChange the code concerning the procedure in the relevant pll that are loaded with Webutil 1.0.6 :

PROCEDURE WRITE_IMAGE_FILE (file_name in VARCHAR2,
file_type in VARCHAR2,
item_id in ITEM,
compression_quality in NUMBER := MINIMIZE_COMPRESSION,
image_depth in NUMBER := ORIGINAL_DEPTH) IS

BEGIN
--hItem := FIND_ITEM(item_name);
if not ID_NULL(item_id) then
CLIENT_IMAGE.WRITE_IMAGE_FILE(file_name, file_type,
get_item_property(item_id, BLOCK_NAME)||'.'||get_item_property (item_id, ITEM_NAME),
compression_quality, image_depth);

end if;

END WRITE_IMAGE_FILE;


This means only one change : if not ID_NULL(hItem) --> if not ID_NULL(item_id)


----
Previous Topic: How to store a file into a table by browsing from the local PC?
Next Topic: How to create Stored Procedure type block in form?
Goto Forum:
  


Current Time: Tue Dec 06 06:09:51 CST 2016

Total time taken to generate the page: 0.09621 seconds