Home » Developer & Programmer » Forms » Forms 10g Default Menu (Developer 10g, Forms, Windows XP)
Forms 10g Default Menu [message #415699] Tue, 28 July 2009 16:19 Go to next message
dwighta
Messages: 3
Registered: July 2009
Location: Seattle
Junior Member
I am migrating Forms from 6i to 10g. Some of my forms open other forms in the same browser window. The default menu when run from the builder includes a window item in the menu. The same form when run on the web does not. All the other menu items are there. How can I keep the window item when run on the web?
Re: Forms 10g Default Menu [message #415709 is a reply to message #415699] Tue, 28 July 2009 20:28 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Are you using the 'smartbar' or your own menu?

David
Re: Forms 10g Default Menu [message #415835 is a reply to message #415699] Wed, 29 July 2009 08:48 Go to previous messageGo to next message
dwighta
Messages: 3
Registered: July 2009
Location: Seattle
Junior Member
I am using DEFAULT&SMARTBAR menu. I tried SMARTBAR alone, but forms could not find the file smartbar. DEFAULT alone works and provides the menu items as text rather than Icons. I have also noticed that sometimes the default menu is active and other times it is not. By active I mean if you click on a menu item, more items scroll down. I have no idea what is causing the menu items to not work.
Re: Forms 10g Default Menu [message #415956 is a reply to message #415835] Wed, 29 July 2009 23:11 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Are you using 'open_form' or 'call_form'? If 'call_form' are you using the 'do_replace' parameter?

David
Re: Forms 10g Default Menu [message #416108 is a reply to message #415956] Thu, 30 July 2009 08:58 Go to previous messageGo to next message
dwighta
Messages: 3
Registered: July 2009
Location: Seattle
Junior Member
Mostly "open_form". Most of the additional windows are not really new forms, but separate canvases in the same form.

When I open the form from the form builder, it is not called from any other form. The Default&smartbar menus are there, with the "Window" item in the Default menu.

Now I open the same form from web tool Oracle has provided, "Run a Form on the Web". I fill in the Form name (I've modified the FORM_PATH variable in default.env), userid, config is default, color scheme blue, other paramters useSDI=yes, Web host is my PC and Web Port is 8889 (I've started the startinst.bat utility). This will open the same form in the browser with a slightly different look than when the form builder opened it. The menu's are now attached to the canvas window (with the builder they were above it) and the "Window" item in the default menu is not there.

I am still waiting on my DBA to install the Application Server software. So, currently this is my only means to see what the forms will look like on the web.
Re: Forms 10g Default Menu [message #416155 is a reply to message #416108] Thu, 30 July 2009 21:07 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have a look at http://www.orafaq.com/forum/m/341417/67467/?srch=magic#msg_341417

Also, search this forum for 'window menu' and 'windows menu'. There are a couple of interesting threads there including http://www.orafaq.com/forum/m/395711/67467/?srch=windows+menu#msg_395711

David
Previous Topic: Internet Explorer Problem in running oracle Forms 10g
Next Topic: Services to be stopped when we install Oracle9i on Windows 2003
Goto Forum:
  


Current Time: Sun Dec 04 06:33:22 CST 2016

Total time taken to generate the page: 0.09896 seconds