Home » Infrastructure » Windows » ODP. NET: error on reconnecting the network cable. (Win XP,.NET framework 2.0,ODP.NET 10.2.0.2.20)
ODP. NET: error on reconnecting the network cable. [message #415292] Mon, 27 July 2009 02:02 Go to next message
rahul71986
Messages: 2
Registered: July 2009
Location: Gurgaon
Junior Member

Hi All,

My problem is:
when ever i disconnect my system from the network and re-connect it. A series of errors come viz.:
1) ORACLE not connected.
2) TNS packet writer problem.

The environment for the application is:
ODP.NET, .Net framework 2.0.

I have a similar application where we are not using ODP.NET. Both the applications have same base version of code being used. There i donot face the problem but with this application i get these errors.

Please help me out.

Any input is highly appreciated.

Regards,
Rahul
Re: ODP. NET: error on reconnecting the network cable. [message #415343 is a reply to message #415292] Mon, 27 July 2009 05:42 Go to previous messageGo to next message
babuknb
Messages: 1725
Registered: December 2005
Location: NJ
Senior Member

Quote:
when ever i disconnect my system from the network and re-connect it. A series of errors come viz.:
1) ORACLE not connected.
2) TNS packet writer problem


Yes you will get this error; because you diconnected your network.

>> There i donot face the problem but with this application i get these errors.


You may need to check your application codes

Thanks
Re: ODP. NET: error on reconnecting the network cable. [message #415345 is a reply to message #415343] Mon, 27 July 2009 05:49 Go to previous messageGo to next message
rahul71986
Messages: 2
Registered: July 2009
Location: Gurgaon
Junior Member

Ofcourse, i disconnected the network but then it was reconnected.
The problem is that this time (after reconnection the problem should not come but it is coming).
Re: ODP. NET: error on reconnecting the network cable. [message #415368 is a reply to message #415345] Mon, 27 July 2009 07:33 Go to previous message
babuknb
Messages: 1725
Registered: December 2005
Location: NJ
Senior Member


>>after reconnection the problem should not come but it is coming

I'm also saying same; It's should comes.

I recommend you may need to check your time out values in your application level.

Thanks
Previous Topic: Ref cursor very slow
Next Topic: Application crash while connecting with db
Goto Forum:
  


Current Time: Wed Aug 20 19:40:14 CDT 2014

Total time taken to generate the page: 0.18888 seconds