Home » RDBMS Server » Backup & Recovery » Incremental backup not marking obsolete files (Oracle 10g)
Incremental backup not marking obsolete files [message #414070] Mon, 20 July 2009 04:57 Go to next message
kahuna0k
Messages: 3
Registered: July 2009
Junior Member
Hello,

I have set up my database to a level 0 backup once a month and a level 1 every other day. The script for the level 0 is

run {
allocate channel oem_backup_disk1 type disk format '/mnt/usb/backup/%U';
backup incremental level 0 cumulative filesperset = 7 as COMPRESSED BACKUPSET tag '%TAG' database include current controlfile;
backup filesperset = 7 as COMPRESSED BACKUPSET tag '%TAG' archivelog all not backed up delete all input;
release channel oem_backup_disk1;
}
allocate channel for maintenance type disk;
delete noprompt obsolete device type disk;
release channel;


and the level 1 one is:

run {
allocate channel oem_backup_disk1 type disk format '/mnt/usb/backup/%U';
backup incremental level 1 cumulative as COMPRESSED BACKUPSET tag '%TAG' database include current controlfile;
recover copy of database;
backup as COMPRESSED BACKUPSET tag '%TAG' archivelog all not backed up delete all input;
release channel oem_backup_disk1;
}
allocate channel for maintenance type disk;
delete noprompt obsolete device type disk;
release channel;


the problem is that although it was working perfectly, suddenly it is not marking old files as obsolete anymore, so the incremental backup does not delete any file, only the controlfile piece. Any clue???

Regards
Re: Incremental backup not marking obsolete files [message #414102 is a reply to message #414070] Mon, 20 July 2009 07:00 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


>>suddenly it is not marking old files as obsolete anymore, so the incremental backup does not delete any file, only the controlfile piece. Any clue???

What's your backup retention period??
Re: Incremental backup not marking obsolete files [message #414110 is a reply to message #414070] Mon, 20 July 2009 07:10 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
What type of backup are you trying to perform? Unless you are trying to perform roll forward image copies, you can remove the 'recover copy of database' portion. Otherwise, you need to modify your script to perform roll forward image copies correctly.

[Updated on: Mon, 20 July 2009 07:11]

Report message to a moderator

Re: Incremental backup not marking obsolete files [message #414245 is a reply to message #414102] Tue, 21 July 2009 02:59 Go to previous messageGo to next message
kahuna0k
Messages: 3
Registered: July 2009
Junior Member
gentlebabu wrote on Mon, 20 July 2009 07:00

>>suddenly it is not marking old files as obsolete anymore, so the incremental backup does not delete any file, only the controlfile piece. Any clue???

What's your backup retention period??



RMAN> show retention policy;

RMAN configuration parameters are:
CONFIGURE RETENTION POLICY TO REDUNDANCY 1; # default




Quote:

What type of backup are you trying to perform? Unless you are trying to perform roll forward image copies, you can remove the 'recover copy of database' portion. Otherwise, you need to modify your script to perform roll forward image copies correctly.



I've reading, and it seems that I could remove the "recover copy of database" portion as I'm not currently making roll forward backups, but my question is still valid, or incremental backup do only work with roll forward?? I suppose that previously to making the new incremental backup the archivelogs are applied so it can delete the old ones. Am I wrong??
Re: Incremental backup not marking obsolete files [message #414265 is a reply to message #414245] Tue, 21 July 2009 04:52 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
If you have been reading...did you read about RMAN Incremental Backups ??
Re: Incremental backup not marking obsolete files [message #414438 is a reply to message #414265] Wed, 22 July 2009 03:10 Go to previous message
kahuna0k
Messages: 3
Registered: July 2009
Junior Member
ebrian wrote on Tue, 21 July 2009 04:52
If you have been reading...did you read about ... ??


Yes, when I wrote I have been reading I tried to put an URL there, but the system won't let me until I post 5 times (I'm really new here), but of course I've read about incremental backups, that's the reason I made that RMAN script, and the problem is that although it was working for months, now, it have stopped marking obsolete files, if I run a crosscheck every file is available, and the only one marked as obsolete is the piece corresponding to the control file. There has not been any changes to the scripts or to the database options, so I have no idea where to look for the problem.

Regards,
Previous Topic: Define a tape backup device
Next Topic: Backup data over 200GB while online
Goto Forum:
  


Current Time: Fri Dec 02 12:46:03 CST 2016

Total time taken to generate the page: 0.32531 seconds