Home » Developer & Programmer » Forms » Run Report 10g from Form 10g (10g)
Run Report 10g from Form 10g [message #413936] Sun, 19 July 2009 06:59 Go to next message
sazzadur
Messages: 9
Registered: January 2009
Location: UK
Junior Member
I am using Form and Report version 10g R2.

I have 2 tables, for example Employee and employee_details. They have common column named empid.
I created a form, named form1, for Employee table and a report, named report1, for Employee_details table.

I want to call report1 from form1 with empid.
Form1 has employee data block.
In Form1, I write the following code in the WHEN-BUTTON-PRESSED trigger:
:GLOBAL.empid:=:EMPLOYEE.empid;
I need to write the code here to run the report.
How can I call or run a report from the form? The report report1 should run with this global variable empid. In report the query should be as follows:
select * from employee_details where empid:=:GLOBAL.empid.

Is it possible to run the report like this way? What is the easiest way to do it?
Re: Run Report 10g from Form 10g [message #413939 is a reply to message #413936] Sun, 19 July 2009 07:58 Go to previous messageGo to next message
saadatahmad
Messages: 452
Registered: March 2005
Location: Germany/Paderborn
Senior Member

hi,
If you search on this forum for your problem, I'm sure you'll find many threads. One of them is here

http://www.orafaq.com/forum/m/412458/67693/#msg_412458

regards,
Saadat Ahmad
Re: Run Report 10g from Form 10g [message #413948 is a reply to message #413939] Sun, 19 July 2009 10:33 Go to previous messageGo to next message
sazzadur
Messages: 9
Registered: January 2009
Location: UK
Junior Member
When I run a report in web from report builder, it shows in the browser as follows:
C:\Temp\docroot\MODULE5006005276.htm.
I never find or get 'http://host:8889/reports/rwservlet/'..
If I want to use web.show_document, how can I find reports service? I am confused.
I installed developer 10g, where I can start Form service. But I never find Report server seperately.
What should I do?
Re: Run Report 10g from Form 10g [message #414635 is a reply to message #413948] Thu, 23 July 2009 01:25 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Do NOT multipost!! See http://www.orafaq.com/forum/mv/msg/147437/413946/67467/

David
Previous Topic: Pass parameters from form to report
Next Topic: ORA-12560 TNS PROTOCAL ADAPTER ERROR
Goto Forum:
  


Current Time: Thu Dec 08 06:20:34 CST 2016

Total time taken to generate the page: 0.09790 seconds