Home » Developer & Programmer » Forms » problem with go_record
problem with go_record [message #413681] Fri, 17 July 2009 00:52 Go to next message
ketki_n
Messages: 8
Registered: July 2009
Junior Member
In my form I am displaying say 50 records.Amongst those 50 records the user has to select any 1 record.For that I have provided a 'SELECT' push boton.Once a user moves cursor to a record and then pushes the 'SELECT' buton that particular record should get higlighted and I want to pass the record value further to another form as parameter.

My Problem is my go_record is not working.
Here is my script.
On 'SELECT' buton i hav put a 'when-buton-pressed' trigger.
In that i hav written:
declare
record_no number(10);
begin
record_no := :system.cursor_record;
go_record(record_no);
end;
Re: problem with go_record [message #413700 is a reply to message #413681] Fri, 17 July 2009 02:58 Go to previous message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Quote:
Once a user moves cursor to a record and then pushes the 'SELECT' button ...

But, there's no need to GO_RECORD because user already IS in that record. All you have to do is to highlight it. Though, you might try to use :SYSTEM.TRIGGER_RECORD instead of :SYSTEM.CURSOR_RECORD.
Previous Topic: dirty record--need to be able to query
Next Topic: Want to create a pll
Goto Forum:
  


Current Time: Fri Dec 09 10:07:31 CST 2016

Total time taken to generate the page: 0.07978 seconds