Home » RDBMS Server » Networking and Gateways » No Successful connection from a TNSPING. (Oracle 9i)
No Successful connection from a TNSPING. [message #412300] Wed, 08 July 2009 10:04 Go to next message
sh014d1054
Messages: 2
Registered: July 2009
Location: Blackburn
Junior Member
Hi,

I have a server running an Oracle 9i database.

I have installed the Oracle 9i Client software onto a client Pc (an IBM laptop). This Pc is on the same network/domain as the database server.

When I try a TNSPING command to the database name I am not getting a successful connection, I get the following message:

Message 3511 not found; No message file for product=NETWORK, facility=TNSM
3512 not found; No message file for product=NETWORK, facility=TNSAttempti
contact (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST =
UB11)(PORT = 1521))) (CONNECT_DATA = (SERVICE_NAME = BarcoDB)))
Message 3509 not found; No message file for product=NETWORK, facility=TNS

Strange thing here is that if I logon to the client Pc as an Administrator of that Pc then I get a successful database connection.
I get the above message only when logged on with a lower level user.

My tnsnames and sqlnet files are ok.

I have given Everyone on the Client Pc full security access to c:\oracle\ora92, and I know that the lower level users can access the tnsnames file (I can brwose and open these files while logged on as the lower level user).

Why should being an Administrator of the Pc make any difference?
Could it be that port 1521 is blocked for the lower level user?
I have added port 1521 into the Firewall exceptions.

Thanks.
Simon.

Re: No Successful connection from a TNSPING. [message #412301 is a reply to message #412300] Wed, 08 July 2009 10:10 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
ORACLE_HOME=
is not defined on client
Re: No Successful connection from a TNSPING. [message #412304 is a reply to message #412301] Wed, 08 July 2009 10:33 Go to previous messageGo to next message
sh014d1054
Messages: 2
Registered: July 2009
Location: Blackburn
Junior Member
Thanks for the reply.

I do believe the ORACLE_HOME is set correclty, especially as I can TNSPING the database successfully, from the client, if logged on as an Administrator?
Re: No Successful connection from a TNSPING. [message #412315 is a reply to message #412304] Wed, 08 July 2009 11:29 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


No need admin access you can connect from any operating system user.

This error looks there may be different oracle version & operating system; I hope your also not able to connect your database.

Thanks
Re: No Successful connection from a TNSPING. [message #412330 is a reply to message #412300] Wed, 08 July 2009 13:07 Go to previous message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
>I do believe the ORACLE_HOME is set correclty
I am certain that you are mistaken.
"Message XXXX not found" occur when ORACLE_HOME is missing or incorrect
Previous Topic: Generic Connectivity Not Working (Oracle -Ms Access)
Next Topic: Help me: ORA-12514
Goto Forum:
  


Current Time: Fri Dec 02 14:11:57 CST 2016

Total time taken to generate the page: 0.20278 seconds