Home » Developer & Programmer » Forms » Webutil 1.0.6 in 10g forms opens blank page. (Oracle10g forms, Windows 2003 Server, Webutil 1.0.6)
icon1.gif  Webutil 1.0.6 in 10g forms opens blank page. [message #412188] Wed, 08 July 2009 03:17 Go to next message
v_contact
Messages: 13
Registered: July 2009
Junior Member
Hi,
I have developed a form which has webutil objects in it, and it is working fine on my local machine. When I deploy my form to my application server it opens up a blank page.
I have configured the webutils in the app server as per the document and made entries into formsweb.cfg regarding frmwebutil.jar,jacob.jar. Does the dev suite need to be installed in the server for the webutils to run properly?

Also I watched my java console as I opened my form and I am pasting the contents below:
-----------------
Loading frmwebutil.jar from JAR cache

Loading jacob.jar from JAR cache

proxyHost=null

proxyPort=0

connectMode=HTTP, native.

Forms Applet version is : 10.1.2.3

Exception occurred during event dispatching:

java.lang.NoSuchMethodError

at oracle.forms.webutil.common.VBeanCommon.init(Unknown Source)

at oracle.forms.handler.UICommon.instantiate(Unknown Source)

at oracle.forms.handler.UICommon.onCreate(Unknown Source)

at oracle.forms.handler.JavaContainer.onCreate(Unknown Source)

at oracle.forms.engine.Runform.onCreateHandler(Unknown Source)

at oracle.forms.engine.Runform.processMessage(Unknown Source)

at oracle.forms.engine.Runform.processSet(Unknown Source)

at oracle.forms.engine.Runform.onMessageReal(Unknown Source)

at oracle.forms.engine.Runform.onMessage(Unknown Source)

at oracle.forms.engine.Runform.processEventEnd(Unknown Source)

at oracle.ewt.lwAWT.LWComponent.redispatchEvent(Unknown Source)

at oracle.ewt.lwAWT.LWComponent.processEvent(Unknown Source)

at java.awt.Component.dispatchEventImpl(Unknown Source)

at java.awt.Container.dispatchEventImpl(Unknown Source)

at java.awt.Component.dispatchEvent(Unknown Source)

at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)

at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)

at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)

at java.awt.Container.dispatchEventImpl(Unknown Source)

at java.awt.Component.dispatchEvent(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)

-----------------

Any help is appreciated.
Re: Webutil 1.0.6 in 10g forms opens blank page. [message #412200 is a reply to message #412188] Wed, 08 July 2009 03:54 Go to previous messageGo to next message
v_contact
Messages: 13
Registered: July 2009
Junior Member
I am also attaching the contents of frmsweb.cfg below...
------------------------------------------------------
# $Id: formsweb.cfg 15-apr-2005.13:17:30 pkuhn Exp $
# formsweb.cfg defines parameter values used by the FormsServlet (frmservlet)
# This section defines the Default settings. Any of them may be overridden in the
# following Named Configuration sections. If they are not overridden, then the
# values here will be used.
# The default settings comprise two types of parameters: System parameters,
# which cannot be overridden in the URL, and User Parameters, which can.
# Parameters which are not marked as System parameters are User parameters.
# SYSTEM PARAMETERS
# -----------------
# These have fixed names and give information required by the Forms
# Servlet in order to function. They cannot be specified in the URL query
# string. But they can be overridden in a named configuration (see below).
# Some parameters specify file names: if the full path is not given,
# they are assumed to be in the same directory as this file. If a path
# is given, then it should be a physical path, not a URL.
# USER PARAMETERS
# ---------------
# These match variables (e.g. %form%) in the baseHTML file. Their values
# may be overridden by specifying them in the URL query string
form=myform&width=700")
# or by overriding them in a specific, named configuration (see below)
[default]
# System parameter: default base HTML file
baseHTML=base.htm
# System parameter: base HTML file for use with JInitiator client
baseHTMLjinitiator=basejini.htm
# System parameter: base HTML file for use with Sun's Java Plug-In
baseHTMLjpi=basejpi.htm
# System parameter: delimiter for parameters in the base HTML files
HTMLdelimiter=%
# System parameter: working directory for Forms runtime processes
# WorkingDirectory defaults to <oracle_home>/forms if unset.
workingDirectory=
# System parameter: file setting environment variables for the Forms runtime processes
envFile=default.env
# Forms runtime argument: whether to escape certain special characters
# in values extracted from the URL for other runtime arguments
escapeparams=true
# Forms runtime argument: which form module to run
form=test.fmx
# Forms runtime argument: database connection details
userid=
# Forms runtime argument: whether to run in debug mode
debug=no
# Forms runtime argument: host for debugging
host=
# Forms runtime argument: port for debugging
port=
# Other Forms runtime arguments: grouped together as one parameter.
# These settings support running and debugging a form from the Builder:
otherparams=buffer_records=%buffer% debug_messages=%debug_messages% array=%array% obr=%obr% query_only=%query_only% quiet=%quiet% render=%render% record=%record% tracegroup=%tracegroup% log=%log% term=%term%
# Sub argument for otherparams
buffer=no
# Sub argument for otherparams
debug_messages=no
# Sub argument for otherparams
array=no
# Sub argument for otherparams
obr=no
# Sub argument for otherparams
query_only=no
# Sub argument for otherparams
quiet=yes
# Sub argument for otherparams
render=no
# Sub argument for otherparams
record=names
# Sub argument for otherparams
tracegroup=
# Sub argument for otherparams
log=
# Sub argument for otherparams
term=
# HTML page title
pageTitle=Oracle Application Server Forms Services
# HTML attributes for the BODY tag
HTMLbodyAttrs=
# HTML to add before the form
HTMLbeforeForm=
# HTML to add after the form
HTMLafterForm=
# Forms applet parameter: URL path to Forms ListenerServlet
serverURL=/forms/lservlet
# Forms applet parameter
codebase=/forms/java
# Forms applet parameter
imageBase=DocumentBase
# Forms applet parameter
width=750
# Forms applet parameter
height=600
# Forms applet parameter
separateFrame=false
splashScreen=
# Forms applet parameter
background=
# Forms applet parameter
lookAndFeel=Oracle
# Forms applet parameter
colorScheme=teal
# Forms applet parameter
logo=
# Forms applet parameter
restrictedURLparams=HTMLbodyAttrs,HTMLbeforeForm,pageTitle,HTMLafterForm,log,allow_debug,allowNewConnections
# Forms applet parameter
formsMessageListener=
# Forms applet parameter
recordFileName=
# Forms applet parameter
serverApp=default
# Forms applet archive setting for JInitiator
archive_jini=frmall_jinit.jar
# Forms applet archive setting for other clients (Sun Java Plugin, Appletviewer, etc)
archive=frmall.jar
# Number of times client should retry if a network failure occurs. You should
# only change this after reading the documentation.
networkRetries=30
# Page displayed to Netscape users to allow them to download Oracle JInitiator.
# Oracle JInitiator is used with Windows clients.
# If you create your own page, you should set this parameter to point to it.
#jinit_download_page=/forms/jinitiator/us/jinit_download.htm
# Parameter related to the version of JInitiator
jinit_classid=clsid:CAFECAFE-0013-0001-0028-ABCDEFABCDEF
# Parameter related to the version of JInitiator
jinit_exename=jinit.exe#Version=1,3,1,28
# Parameter related to the version of JInitiator
jinit_mimetype=application/x-jinit-applet;version=1.3.1.28
# Page displayed to users to allow them to download Sun's Java Plugin.
# Sun's Java Plugin is typically used for non-Windows clients.
# Parameter related to the version of the Java Plugin
jpi_classid=clsid:CAFEEFAC-0014-0002-0006-ABCDEFFEDCBA
# Parameter related to the version of the Java Plugin
# Parameter related to the version of the Java Plugin
jpi_mimetype=application/x-java-applet;jpi-version=1.4.2_06
# EM config parameter
# Set this to "1" to enable Enterprise Manager to track Forms processes
em_mode=0
# Single Sign-On OID configuration parameter
oid_formsid=%OID_FORMSID%
# Single Sign-On OID configuration parameter
oracle_home=C:\oracle\oas_10.1.2\Webforms_10
# Single Sign-On OID configuration parameter
formsid_group_dn=%GROUP_DN%
# Single Sign-On OID configuration parameter: indicates whether we allow
# dynamic resource creation if the resource is not yet created in the OID.
ssoDynamicResourceCreate=true
# Single Sign-On parameter: URL to redirect to if ssoDynamicResourceCreate=false
ssoErrorUrl=
# Single Sign-On parameter: Cancel URL for the dynamic resource creation DAS page.
ssoCancelUrl=
# Single Sign-On parameter: indicates whether the url is protected in which
# case mod_osso will be given control for authentication or continue in
# the FormsServlet if not. It is false by default. Set it to true in an
# application-specific section to enable Single Sign-On for that application.
ssoMode=false
# The parameter allow_debug determines whether debugging is permitted.
# Administrators should set allow_debug to "true" if servlet
# debugging is required, or to provide access to the Forms Trace Xlate utility.
# Otherwise these activities will not be allowed (for security reasons).
allow_debug=false
# Parameter which determines whether new Forms sessions are allowed.
# This is also read by the Forms EM Overview page to show the
# current Forms status.
allowNewConnections=true
# EndUserMonitoring
# EndUserMonitoringEnabled parameter
# Indicates whether EUM/Chronos integration is enabled
EndUserMonitoringEnabled=
# EndUserMonitoringURL
# indicates where to record EUM/Chronos data
EndUserMonitoringURL=
# Example Named Configuration Section
# Example 1: configuration to run forms in a separate browser window with
# "generic" look and feel (include "config=sepwin" in the URL)
# You may define your own specific, named configurations (sets of parameters)
# by adding special sections as illustrated in the following examples.
# Note that you need only specify the parameters you want to change. The
# default values (defined above) will be used for all other parameters.
# Use of a specific configuration can be requested by including the text
# "config=<your_config_name>" in the query string of the URL used to run
# a form. For example, to use the sepwin configuration, your could issue
[sepwin]
separateFrame=True
lookandfeel=Generic
# Example Named Configuration Section
# Example 2: configuration forcing use of the Java Plugin in all cases (even if
# the client browser is on Windows)
[jpi]
baseHTMLJInitiator=basejpi.htm
# Example Named Configuration Section
# Example 3: configuration running the Forms ListenerServlet in debug mode
# (debug messages will be written to the servlet engine's log file).
[debug]
serverURL=/forms/lservlet/debug
# Sample configuration for deploying WebUtil. Note that WebUtil is shipped with
# DS but not AS and is also available for download from OTN.
[webutil]
WebUtilArchive=frmwebutil.jar,jacob.jar
WebUtilLogging=off
WebUtilLoggingDetail=normal
WebUtilErrorMode=Alert
WebUtilDispatchMonitorInterval=5
WebUtilTrustInternal=true
WebUtilMaxTransferSize=16384
baseHTMLjinitiator=webutiljini.htm
baseHTMLjpi=webutiljpi.htm
archive_jini=frmall_jinit.jar
archive=frmall.jar
lookAndFeel=oracle
[pp100]
imageBase=CodeBase
width=1024
height=768
archive_jini=frmall_jinit.jar,pp100/ptag.jar,pp100/uploadclient.jar,pp100/keypressed.jar,pp100/frmwebutil.jar,pp100/jacob.jar
otherparams=jvmcontroller=pp000 buffer_records=yes debug_messages=%debug_messages% array=yes obr=%obr% query_only=%query_only% quiet=%quiet% render=%render% record=%record% tracegroup=%tracegroup% log=%log% term=C:\oracle\oas_10.1.2\Webforms_10\forms\fmrpcweb_utf8.res p_id=%p_id%
lookAndFeel=Oracle
colorScheme=Titanium
form=ptg000
baseHTMLjinitiator=basejini.htm
baseHTMLjpi=basejpi.htm
HTMLbodyAttrs=style="margin-top:0 ; margin-bottom:0; margin-left:0; margin-right:0"
pageTitle=Ptag Plus
separateFrame=false
SplashScreen=ptagsplash.jpg
background=no
logo=no
serverApp=ptag
allow_debug=true
prestartRuntimes=false
prestartInit=5
prestartMin=5
prestartIncremen=5
#prestartTimeout=5
clientDPI=82
userid=userid/password
envFile=c:\ikea\ptagplus\pp100\env\en.env

[Updated on: Fri, 04 March 2011 07:47] by Moderator

Report message to a moderator

Re: Webutil 1.0.6 in 10g forms opens blank page. [message #412215 is a reply to message #412200] Wed, 08 July 2009 04:24 Go to previous messageGo to next message
v_contact
Messages: 13
Registered: July 2009
Junior Member
I made the below changes in the frmsweb.cfg ..

baseHTMLjinitiator=webutiljini.htm
baseHTMLjpi=webutiljpi.htm

and now when the form starts i get the following error in the Java console:

Load: class oracle.forms.webutil.common.RegisterWebUtil not found.

java.lang.ClassNotFoundException: java.io.IOException: open HTTP connection failed.


any help??
icon10.gif  Re: Webutil 1.0.6 in 10g forms opens blank page. [message #412282 is a reply to message #412215] Wed, 08 July 2009 08:28 Go to previous messageGo to next message
v_contact
Messages: 13
Registered: July 2009
Junior Member
I solved the problem...
Actually my OAS was of version 10.1.2.3 and it seems it required a new version of frmwebutl.jar file
I downloaded the latest one as a patch p7384879_10123_GENERIC.zip
and it solved the problem.
icon9.gif  Re: Webutil 1.0.6 in 10g forms opens blank page. [message #412472 is a reply to message #412282] Thu, 09 July 2009 11:25 Go to previous messageGo to next message
v_contact
Messages: 13
Registered: July 2009
Junior Member
I am still facing problems. Now my java console when i try and upload a image looks like:
---------------------
Oracle JInitiator: Version 1.3.1.28
Using JRE version 1.3.1.28-internal Java HotSpot(TM) Client VM
User home directory = \\Itseelm-nt0002\vidy$




----------------------------------------------------
c: clear console window
f: finalize objects on finalization queue
g: garbage collect
h: display this help message
l: dump classloader list
m: print memory usage
q: hide console
s: dump system properties
t: dump thread list
x: clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------

load: class oracle.forms.webutil.common.RegisterWebUtil not found.

java.lang.ClassNotFoundException: java.io.IOException: open HTTP connection failed.

at sun.applet.AppletClassLoader.getBytes(Unknown Source)

at sun.applet.AppletClassLoader.access$100(Unknown Source)

at sun.applet.AppletClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at sun.applet.AppletClassLoader.findClass(Unknown Source)

at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.applet.AppletClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.applet.AppletClassLoader.loadCode(Unknown Source)

at sun.applet.AppletPanel.createApplet(Unknown Source)

at sun.plugin.AppletViewer.createApplet(Unknown Source)

at sun.applet.AppletPanel.runLoader(Unknown Source)

at sun.applet.AppletPanel.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Loading http://dtpseis-nt4040.ikeadt.com:7778/forms/java/frmall_jinit.jar from JAR cache

Loading http://dtpseis-nt4040.ikeadt.com:7778/forms/java/pp100/ptag.jar from JAR cache

Loading http://dtpseis-nt4040.ikeadt.com:7778/forms/java/pp100/uploadclient.jar from JAR cache

Loading http://dtpseis-nt4040.ikeadt.com:7778/forms/java/pp100/keypressed.jar from JAR cache

Loading http://dtpseis-nt4040.ikeadt.com:7778/forms/java/frmwebutil.jar from JAR cache

Loading http://dtpseis-nt4040.ikeadt.com:7778/forms/java/jacob.jar from JAR cache

proxyHost=null

proxyPort=0

connectMode=HTTP, native.

Forms Applet version is : 10.1.2.3

java.lang.StringIndexOutOfBoundsException: String index out of range: 27

at java.lang.String.charAt(Unknown Source)

at org.apache.regexp.StringCharacterIterator.charAt(StringCharacterIterator.java:90)

at org.apache.regexp.RE.matchNodes(RE.java:1161)

at org.apache.regexp.RE.matchNodes(RE.java:1376)

at org.apache.regexp.RE.matchNodes(RE.java:1376)

at org.apache.regexp.RE.matchAt(RE.java:1448)

at org.apache.regexp.RE.match(RE.java:1498)

at org.apache.regexp.RE.match(RE.java:1468)

at org.apache.regexp.RE.match(RE.java:1561)

at oracle.forms.webutil.file.WebUtilFileFilter.accept(Unknown Source)

at javax.swing.JFileChooser.accept(Unknown Source)

at javax.swing.plaf.basic.BasicDirectoryModel$LoadFilesThread.run(Unknown Source)

2009-Jul-09 18:19:20.834 ERROR>WUT-134 [WEBUTIL_CORE.checkJava] frmwebutil.jar not in the Application Server Classpath

---------------

I have double checked that frmwebutil.jar is there in the class path of the environment file.
Also RegisterWebUtil not found is again appearing in the console.

The below are the contents of webutil.cfg file:
-------------
transfer.database.enabled=TRUE
transfer.appsrv.enabled=TRUE
transfer.appsrv.workAreaRoot=C:\Temp
transfer.appsrv.accessControl=TRUE
#List transfer.appsrv.read.<n> directories
transfer.appsrv.read.1=c:\temp
#List transfer.appsrv.write.<n> directories
transfer.appsrv.write.1=\\lgneltst-nt4020.ikeadt.com\IMAGES$\userimages\
transfer.appsrv.write.2=\\dtpseis-nt4040.ikeadt.com\c$\Temp\
---------------------------

I tried the readable funtion and the file was readable.

Please help if anybody has any idea.

icon9.gif  Re: Webutil 1.0.6 in 10g forms opens blank page. [message #412482 is a reply to message #412472] Thu, 09 July 2009 12:14 Go to previous messageGo to next message
v_contact
Messages: 13
Registered: July 2009
Junior Member
I solved the problem. The class path was also read from the jvm.cfg
I added the entries and it read the file from c:\temp from my local machine.

But now the problem is that I want it to be dynamic, like I can upload the image from any path i.e. it should not be restricted by the directory mentioned in transfer.appsrv.read

Is there anyway of doing so or do we have to mention all the paths here??
icon9.gif  Re: Webutil 1.0.6 in 10g forms opens blank page. [message #412489 is a reply to message #412482] Thu, 09 July 2009 12:54 Go to previous messageGo to next message
v_contact
Messages: 13
Registered: July 2009
Junior Member
If I set the transfer.appsrv.accessControl=FALSE it is able to read from all drives and network drives.
But it is not able to read from shared path. The problem is here the desktop is a shared path, its not mapped to any drive.
If I upload from there its throwing :

--

2009-Jul-09 19:53:36.902 ERROR>WUT-129 [WEBUTIL_FILE_TRANSFER.UploadInt] Error in reading client file \Itseelm-nt0002\vidy$\chair2.jpg

----

I am very confused.
Any help??? Sad
Re: Webutil 1.0.6 in 10g forms opens blank page. [message #412871 is a reply to message #412489] Mon, 13 July 2009 02:53 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Thank you for keeping us posted to your progress. I'm sorry but I don't have a configuration similar to yours on which to run tests. Good luck with your problem and please keep telling us who you get on with your configuration.

David
Re: Webutil 1.0.6 in 10g forms opens blank page. [message #412918 is a reply to message #412871] Mon, 13 July 2009 07:12 Go to previous messageGo to next message
v_contact
Messages: 13
Registered: July 2009
Junior Member

I found the problem.
When the forms reads the shared path, it reads as
'\Itseelm-nt0002\vidy$\chair2.jpg' instead of '\\Itseelm-nt0002\vidy$\chair2.jpg'
I manually appended the extra '\' and I am able to read it.

I am still not sure why this is happening but for now its resolved.

Thanks David.


Vikram.
Re: Webutil 1.0.6 in 10g forms opens blank page. [message #447748 is a reply to message #412188] Wed, 17 March 2010 13:42 Go to previous messageGo to next message
TheYanga
Messages: 6
Registered: March 2010
Junior Member

Hello

Where o what is the Note Id on metalink for download p7384879_10123_GENERIC.zip ?

Thanks and Regards.
Re: Webutil 1.0.6 in 10g forms opens blank page. [message #447831 is a reply to message #447748] Thu, 18 March 2010 03:29 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
TheYanga,

is your question related to this topic? What is the question, anyway? I didn't quite get it ... are you asking what is Metalink (now it is called "My Oracle Support"), or where it is, or how to find a note using its ID, or how to download a patch from that site, or ... something different?
Re: Webutil 1.0.6 in 10g forms opens blank page. [message #447946 is a reply to message #447831] Thu, 18 March 2010 11:42 Go to previous messageGo to next message
TheYanga
Messages: 6
Registered: March 2010
Junior Member

Hi

I readed the post from
v_contact
Messages: 13
Registered: July 2009

So my question was where is the note id where I can download the patch. on Oracle Support

Thanks and Regards.

Re: Webutil 1.0.6 in 10g forms opens blank page. [message #447957 is a reply to message #447946] Thu, 18 March 2010 12:45 Go to previous messageGo to next message
joy_division
Messages: 4640
Registered: February 2005
Location: East Coast USA
Senior Member
TheYanga wrote on Thu, 18 March 2010 11:42
Hi
So my question was where is the note id where I can download the patch. on Oracle Support


Yes, https://support.oracle.com

You'll need a login which is available for those with valid support licenses.
icon9.gif  Re: Webutil 1.0.6 in 10g forms opens blank page. [message #497207 is a reply to message #412188] Fri, 04 March 2011 07:43 Go to previous messageGo to next message
vikram_contact
Messages: 19
Registered: August 2008
Junior Member
To moderator: Please could you delete my above post, it violates my company policy and its causing me problems.
I am sorry if there is a delete button with the post but I am unable to find any. Sorry for the inconvinenece.

Best Regards,
Vikram
Re: Webutil 1.0.6 in 10g forms opens blank page. [message #497209 is a reply to message #497207] Fri, 04 March 2011 07:52 Go to previous message
joy_division
Messages: 4640
Registered: February 2005
Location: East Coast USA
Senior Member
I have removed the userid and password. Someone might benefit from the rest of the post.
Previous Topic: help please
Next Topic: 10 g forms to 6i
Goto Forum:
  


Current Time: Sun Dec 04 12:38:55 CST 2016

Total time taken to generate the page: 0.14979 seconds