Home » Developer & Programmer » Forms » subclass info issue (forms 10g)
subclass info issue [message #410866] Tue, 30 June 2009 17:15 Go to next message
nastyjillu
Messages: 211
Registered: February 2009
Senior Member
i had 2 forms. one is tmp.fmb other is wpt.fmb.

i need to have a procedure from tmp.fmb in wpt.fmb.

for this, i opened tmp.fmb in form builder then i opened wpt.fmb in the same builder.

then i created a dummy procedure in program unit in wpt.fmb.

in the property pallette of that procedure i called tmp.fmb as module and required procedure as object.

now i saved. and again if i open the wpt.fmb in form builder without tmp.fmb then it shows the below error at the starting. and also compiles with error saying initial value has to be defined (which doesnt do without subclass info).

error is:

frm-18108 failed to load following objects
source module : tmp.fmb
source object : procedure_name

and the tmp.fmb and wpt.fmb are present in the library and also correct path has been given to my form builder.

what might be the issue?

or else does the form works inspite of these errors ???

thanks jillu

Re: subclass info issue [message #410911 is a reply to message #410866] Wed, 01 July 2009 00:59 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Do you have the name of the directory in the 'Start in' parameter of the shortcut from which you start Forms Builder?

Do you have a 'blank' or 'space' in the name of the directory?

David
Re: subclass info issue [message #411038 is a reply to message #410911] Wed, 01 July 2009 11:40 Go to previous messageGo to next message
nastyjillu
Messages: 211
Registered: February 2009
Senior Member
i have directory defined in the shortcut and there is no space or blank.

is it sufficient if the tmp.fmb is in library folder?? or do i need to have wpt.fmb also ??

as of now i have only tmp.fmb and the pll's in the folder , not wpt.fmb.

beginning i think i told both are in directory.
Re: subclass info issue [message #411088 is a reply to message #411038] Wed, 01 July 2009 19:28 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you tried just clicking and dragging the procedure from one form to the other and then selecting 'subclass'?

David
Re: subclass info issue [message #411224 is a reply to message #411088] Thu, 02 July 2009 09:24 Go to previous messageGo to next message
nastyjillu
Messages: 211
Registered: February 2009
Senior Member
david,
i didnot drag the procedure from tmp form to other form.
let me explain you clearly.

TMP.fmb is in the startin directory.

and other_form.fmb is not in directory.its in share drive.
copy of tmp.fmb is also in share drive.

i opened tmp.fmb in form builder from share drive.also i opened other_form in the same form builder.
then i created a dummy procedure in other_form.fmb. then opened property pallette of that procedure and in the subclass info, i gave module as tmp.fmb and object as the procedure name in tmp.fmb.

then i saved it.

now when i open the other_form.fmb alone in form builder, it gives me error.

do i need to have both other_form and tmp in startin directory ??

or is it sufficient if i have tmp.fmb only ?

and do u want me to drag procedure from tmp to other_form ?? as you were refering.

thanks
jillu
Re: subclass info issue [message #411251 is a reply to message #411224] Thu, 02 July 2009 15:02 Go to previous messageGo to next message
nastyjillu
Messages: 211
Registered: February 2009
Senior Member
i got it david,

i added new procedure in the tmp.fmb form. and subclassed the same in other_form.fmb.

but i didnot put the modified tmp.fmb in the startin direcotory.

hence it says failed to load source object .

am i right ?? or is there any other issue ?
Re: subclass info issue [message #411252 is a reply to message #411251] Thu, 02 July 2009 15:07 Go to previous messageGo to next message
nastyjillu
Messages: 211
Registered: February 2009
Senior Member
David, can you try issue given in below link ?

http://www.orafaq.com/forum/m/409747/138002/#msg_409747

there, master block and detail block are in tab canvases.

defferred=yes for detail block. even though detail block is getting executed when master block gets executed.

there is a pll, in which it says

if master_canvas=detail_canvas then
go_block(detail);
execute_query;


i think as both blocks are in tab pages which are present in one canvas page, the detail block is getting executed.

so, i cant change pll now. what is the method that i can stop particular detail block from using that pll procedure. ?
Re: subclass info issue [message #412124 is a reply to message #411224] Tue, 07 July 2009 20:28 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Do not use two copies of the same form.

David

PS Do not mix information between threads.
Previous Topic: navigation problem during go item
Next Topic: How to validate a text item/display item in Oracle forms 9i?
Goto Forum:
  


Current Time: Sat Dec 03 11:46:22 CST 2016

Total time taken to generate the page: 0.12802 seconds