Home » RDBMS Server » Backup & Recovery » problem running RMAN (Oracle database ,10.2.0,linux)
problem running RMAN [message #410648] Mon, 29 June 2009 08:48 Go to next message
samiraly
Messages: 51
Registered: June 2009
Member

when i try to open rman it gives no thing
[oracle@localhost ~]$ hostname -f
localhost.localdomain
[oracle@localhost ~]$ uname
Linux
[oracle@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.9-42.0.0.0.1.ELsmp #1 SMP Sun Oct 15 14:02:40 PDT 2006 i686 i686 i386 GNU/Linux
[oracle@localhost ~]$ sqlplus / as sysdba

SQL*Plus: Release 10.2.0.1.0 - Production on Sun Jun 28 21:30:01 2009

Copyright (c) 1982, 2005, Oracle.  All rights reserved.


Connected to:
Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - Production
With the Partitioning, OLAP and Data Mining options

SQL> archive log list
Database log mode              Archive Mode
Automatic archival             Enabled
Archive destination            USE_DB_RECOVERY_FILE_DEST
Oldest online log sequence     27
Next log sequence to archive   29
Current log sequence           29
SQL> exit
Disconnected from Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - Production
With the Partitioning, OLAP and Data Mining options
[oracle@localhost ~]$ rman


Please help
Re: problem running RMAN [message #410655 is a reply to message #410648] Mon, 29 June 2009 09:42 Go to previous messageGo to next message
BlackSwan
Messages: 25050
Registered: January 2009
Location: SoCal
Senior Member
In some case & on some systems, the OS has a utility named 'rman' which exists in PATH before Oracle's RMAN.

which rman

post results from above OS command
Re: problem running RMAN [message #410659 is a reply to message #410648] Mon, 29 June 2009 10:07 Go to previous messageGo to next message
samiraly
Messages: 51
Registered: June 2009
Member

there is only on ytility called rman which is oracle rman located on $ORACLE_HOM/bin
when i issue rman command it goes and gives no thing even no error message appears
Re: problem running RMAN [message #410661 is a reply to message #410648] Mon, 29 June 2009 10:11 Go to previous messageGo to next message
BlackSwan
Messages: 25050
Registered: January 2009
Location: SoCal
Senior Member
You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/
Go to the URL above click the link "Posting Guidelines"
Go to the section labeled "Practice" & do as directed.

post results from commands below

env | sort
strace rman | tee /tmp/capture.log

What clues now exist in /tmp/capture.log
Re: problem running RMAN [message #410662 is a reply to message #410659] Mon, 29 June 2009 10:12 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
What is the output of:

find / -name rman
Re: problem running RMAN [message #410671 is a reply to message #410648] Mon, 29 June 2009 11:00 Go to previous messageGo to next message
samiraly
Messages: 51
Registered: June 2009
Member

Hi Eebrian
hre is the output of the command , seems we have another OS utility called rman

[root@localhost oracle]# id
uid=0(root) gid=0(root) groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel)
[root@localhost oracle]# find / -name rman
/usr/X11R6/bin/rman
/u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/oc4j_applications/applications/em/em/database/rman
/u01/app/oracle/product/10.2.0/db_1/oc4j/j2ee/oc4j_applications/applications/em/em/WEB-INF/perl/db/rman
/u01/app/oracle/product/10.2.0/db_1/sysman/admin/scripts/db/rman
/u01/app/oracle/product/10.2.0/db_1/bin/rman
[root@localhost oracle]#


Re: problem running RMAN [message #410673 is a reply to message #410648] Mon, 29 June 2009 11:04 Go to previous messageGo to next message
samiraly
Messages: 51
Registered: June 2009
Member

Hi Black swan thank you for your support
here is the output of the command posted
[oracle@localhost ~]$ id
uid=501(oracle) gid=500(oinstall) groups=500(oinstall),501(dba)
[oracle@localhost ~]$ env |sort
COLORTERM=gnome-terminal
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-JpsarhGcnP
DESKTOP_SESSION=default
DISPLAY=:0.0
G_BROKEN_FILENAMES=1
GDMSESSION=default
GNOME_DESKTOP_SESSION_ID=Default
GNOME_KEYRING_SOCKET=/tmp/keyring-rBjj5M/socket
GTK_RC_FILES=/etc/gtk/gtkrc:/home/oracle/.gtkrc-1.2-gnome2
HISTSIZE=1000
HOME=/home/oracle
HOSTNAME=unknown-00-0c-29-cc-9a-39.lan
INPUTRC=/etc/inputrc
KDEDIR=/usr
LANG=en_US.UTF-8
LESSOPEN=|/usr/bin/lesspipe.sh %s
LOGNAME=oracle
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
MAIL=/var/spool/mail/oracle
ORACLE_HOME=/u01/app/oracle/product/10.2.0/db_1
ORACLE_SID=orcl
PATH=/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/oracle/bin:/u01/app/oracle/product/10.2.0/db_1/bin
PWD=/home/oracle
QTDIR=/usr/lib/qt-3.3
SESSION_MANAGER=local/unknown-00-0c-29-cc-9a-39.lan:/tmp/.ICE-unix/3998
SHELL=/bin/bash
SHLVL=2
SSH_AGENT_PID=4050
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SSH_AUTH_SOCK=/tmp/ssh-HLOuCb3998/agent.3998
TERM=xterm
USER=oracle
_=/usr/bin/env
WINDOWID=37748815
XAUTHORITY=/home/oracle/.Xauthority
[oracle@localhost ~]$


Thank you
Re: problem running RMAN [message #410674 is a reply to message #410648] Mon, 29 June 2009 11:05 Go to previous messageGo to next message
BlackSwan
Messages: 25050
Registered: January 2009
Location: SoCal
Senior Member

In some case & on some systems, the OS has a utility named 'rman' which exists in PATH before Oracle's RMAN.


>there is only on ytility called rman which is oracle rman located on $ORACLE_HOM/bin

>seems we have another OS utility called rman

So make sure Oracle's rman is found before OS's rman

what is result from

which rman
which rman
which rman
Re: problem running RMAN [message #410676 is a reply to message #410648] Mon, 29 June 2009 11:11 Go to previous messageGo to next message
samiraly
Messages: 51
Registered: June 2009
Member

Hi Ebrian / Black swan

from both the output from both command sposted by ebrian and blackswan i figured out that there is another OS utility named rman . i renamed the OS rman file and tried to run rman it do works
Ebrian / Blackswan thank you very much for support and efforts

best regards
Re: problem running RMAN [message #410682 is a reply to message #410676] Mon, 29 June 2009 11:35 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
I wouldn't suggest renaming the O/S version of the rman utility. Simply place $ORACLE_HOME/bin at the start of your PATH environment variable so the Oracle version is the one that it resolves out to.

export PATH=$ORACLE_HOME/bin:$PATH
Re: problem running RMAN [message #410697 is a reply to message #410648] Mon, 29 June 2009 18:04 Go to previous message
samiraly
Messages: 51
Registered: June 2009
Member

Done Ebrian thanks for your support
Previous Topic: Incomplete Recovery
Next Topic: Duplicate: read error on file
Goto Forum:
  


Current Time: Fri Dec 09 17:44:34 CST 2016

Total time taken to generate the page: 0.51988 seconds