Home » Server Options » Data Guard » Data Guard after upgrade to 10g (10.2.0.3)
Data Guard after upgrade to 10g [message #409988] Wed, 24 June 2009 13:13 Go to next message
nateholtrop
Messages: 37
Registered: May 2008
Member
Hello,

I recently upgraded my production environment from 9.2.0.8 to 10.2.0.3. Everything went fine except for data guard. I was following Oracle Doc ID 407040.1 but due to circumstances beyond my control i wasn't able to get the listener up for the standby in time. Now, I am left with wondering how to get my standby up to date with the primary database. I have the database up and it is saying it is 10.2.0.3. However when I attempt to connect to it from my primary system using rman (duplicate db for standby)it is still seeing it as 9.2.0.8. I am baffled by this as the listener is pointing to the right home, and the banner also says 10.2.0.3. Any help would be appreciated. Thanks
Re: Data Guard after upgrade to 10g [message #409990 is a reply to message #409988] Wed, 24 June 2009 13:42 Go to previous messageGo to next message
BlackSwan
Messages: 25037
Registered: January 2009
Location: SoCal
Senior Member
It really is not clear the status of the standby DB.
Do you have both V9 & V10 software trees installed on Standby system?

I am not sure which version of sqlplus should be used, but do the following:

SQL> startup mount
ORACLE instance started.

Total System Global Area  276824064 bytes
Fixed Size		    1266996 bytes
Variable Size		  109054668 bytes
Database Buffers	  159383552 bytes
Redo Buffers		    7118848 bytes
Database mounted.
SQL> select * from v$version;

BANNER
----------------------------------------------------------------
Oracle Database 10g Enterprise Edition Release 10.2.0.4.0 - Prod
PL/SQL Release 10.2.0.4.0 - Production
CORE	10.2.0.4.0	Production
TNS for Linux: Version 10.2.0.4.0 - Production
NLSRTL Version 10.2.0.4.0 - Production


A question is what version is the Standby DB, really & for sure.
Re: Data Guard after upgrade to 10g [message #409991 is a reply to message #409988] Wed, 24 June 2009 13:48 Go to previous messageGo to next message
nateholtrop
Messages: 37
Registered: May 2008
Member
I jumped the gun on giving up...for some reason. My 9.2.0.8 instance was still up. I have no idea why but it was...restoring the db now. Thanks!
Re: Data Guard after upgrade to 10g [message #409992 is a reply to message #409991] Wed, 24 June 2009 14:10 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


>> recently upgraded my production environment from 9.2.0.8 to 10.2.0.3. Everything went fine except for data guard

>>My 9.2.0.8 instance was still up.

You already done V9 to V10 upgrade;

1/ Why still V9 running?
2/ What's your problem in V10 dataguard?
3/ Did you upgraded your V9 standby database to V10?

Thanks
Re: Data Guard after upgrade to 10g [message #410117 is a reply to message #409988] Thu, 25 June 2009 06:45 Go to previous messageGo to next message
nateholtrop
Messages: 37
Registered: May 2008
Member
I didn't know my old 9i instance was running.
My errors now consists of missing config files which are something to the effects of dr1(sid).dat and dr2(sid).dat

Thanks
Re: Data Guard after upgrade to 10g [message #410164 is a reply to message #410117] Thu, 25 June 2009 09:04 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


>>I didn't know my old 9i instance was running

You already done V9 to v10 upgrade; So right your customer using V10 database only not V9; In this case why still V9 running?

Ask to your Database Admin; to clarify the above question.

>>My errors now consists of missing config files which are something to the effects of dr1(sid).dat and dr2(sid).dat

1/ Post your exact database version (4 digit)

2/ Post your error message.

Babu
Re: Data Guard after upgrade to 10g [message #410165 is a reply to message #409988] Thu, 25 June 2009 09:09 Go to previous messageGo to next message
nateholtrop
Messages: 37
Registered: May 2008
Member
I didn't know my 9i instance was running still. I was baffled to see it even up and running. I had shut it down Saturday when I did the upgrade and don't remember turning it back on.

10.2.0.3

DG 2009-06-24-12:51:32 0 2 0 DMON: cannot open configuration file "/oracle10g/oracle/oracle/product/
10.2.0/db_1/dbs/dr2mx1bprd.dat"
DG 2009-06-24-12:51:32 0 2 0 ORA-27037: unable to obtain file status
DG 2009-06-24-12:51:32 0 2 0 HP-UX Error: 2: No such file or directory
DG 2009-06-24-12:51:32 0 2 0 Additional information: 3
DG 2009-06-24-12:51:32 0 2 0 DMON: Error opening /oracle10g/oracle/oracle/product/10.2.0/db_1/dbs/dr
2mx1bprd.dat, error = ORA-16572
DG 2009-06-24-12:51:32 0 2 0 DMON: unable to get FSFO data from "/oracle10g/oracle/oracle/product/10
.2.0/db_1/dbs/dr2mx1bprd.dat"
DG 2009-06-24-12:51:32 0 2 0 status = ORA-16572
DG 2009-06-24-12:51:32 0 2 0 DMON: cannot open configuration file "/oracle10g/oracle/oracle/product/
10.2.0/db_1/dbs/dr1mx1bprd.dat"
DG 2009-06-24-12:51:32 0 2 0 ORA-27037: unable to obtain file status
DG 2009-06-24-12:51:32 0 2 0 HP-UX Error: 2: No such file or directory
DG 2009-06-24-12:51:32 0 2 0 Additional information: 3
DG 2009-06-24-12:51:32 0 2 0 DMON: Error opening /oracle10g/oracle/oracle/product/10.2.0/db_1/dbs/dr
1mx1bprd.dat, error = ORA-16572
DG 2009-06-24-12:51:32 0 2 0 DMON: Establishing /oracle10g/oracle/oracle/product/10.2.0/db_1/dbs/dr1
mx1bprd.dat as the least current file
DG 2009-06-24-12:51:32 0 2 0 DMON: cannot open configuration file "/oracle10g/oracle/oracle/product/
10.2.0/db_1/dbs/dr2mx1bprd.dat"
DG 2009-06-24-12:51:32 0 2 0 ORA-27037: unable to obtain file status
DG 2009-06-24-12:51:32 0 2 0 HP-UX Error: 2: No such file or directory
Re: Data Guard after upgrade to 10g [message #410170 is a reply to message #410165] Thu, 25 June 2009 09:23 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


>>I didn't know my 9i instance was running still. I was baffled to see it even up and running. I had shut it down Saturday when I did the upgrade and don't remember turning it back on.

Please check with your DBA. I think we need to start new topic. Why V9 database running after upgrade V10. How you done database upgrade using manual method? Or DBUA ?

ORA-16572: Data Guard configuration file not found 

Cause: The Data Guard broker configuration file was either unavailable or did not exist.

Action: Verify that the configuration file was successfully created. If the dg_broker_config_file[1|2] parameter was changed, 
ensure the filename on disk and the parameter value match, there is space on the device, and you have the right permissions.



Please read the OraFAQ Forum Guide before posting.
http://www.orafaq.com/forum/t/88153/0/
Re: Data Guard after upgrade to 10g [message #410171 is a reply to message #409988] Thu, 25 June 2009 09:24 Go to previous messageGo to next message
nateholtrop
Messages: 37
Registered: May 2008
Member
Where is this file stored in 9i? I've been looking for it now for awhile and I am not able to find it.
Re: Data Guard after upgrade to 10g [message #410172 is a reply to message #410171] Thu, 25 June 2009 09:32 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


Hello Nateholtrop,

>>Where is this file stored in 9i? I've been looking for it now for awhile and I am not able to find it.

I'm not understand your question; Your asking V9 ORACLE_HOME? Or DataGuard Broker file location?

Thanks
Re: Data Guard after upgrade to 10g [message #410173 is a reply to message #409988] Thu, 25 June 2009 09:35 Go to previous messageGo to next message
nateholtrop
Messages: 37
Registered: May 2008
Member
I am asking where the broker config file is. I inherited this environment so I do not know where the files for data guard specifics are located.

Nate
Re: Data Guard after upgrade to 10g [message #410175 is a reply to message #409988] Thu, 25 June 2009 09:39 Go to previous messageGo to next message
BlackSwan
Messages: 25037
Registered: January 2009
Location: SoCal
Senior Member
>DG 2009-06-24-12:51:32 0 2 0 DMON: cannot open configuration file "/oracle10g/oracle/oracle/product/10.2.0/db_1/dbs/dr2mx1bprd.dat"

Is file above on Primary a text file?


It very well may be new to V10 & did not exist for V9
Re: Data Guard after upgrade to 10g [message #410177 is a reply to message #409988] Thu, 25 June 2009 09:41 Go to previous messageGo to next message
nateholtrop
Messages: 37
Registered: May 2008
Member
That I do not know. I created an SR with Oracle.
Re: Data Guard after upgrade to 10g [message #410179 is a reply to message #410177] Thu, 25 June 2009 09:45 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


Can you try

connect sys user

show parameter dg
Re: Data Guard after upgrade to 10g [message #410188 is a reply to message #409988] Thu, 25 June 2009 10:27 Go to previous messageGo to next message
nateholtrop
Messages: 37
Registered: May 2008
Member
SQL> show parameter dg

NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
dg_broker_config_file1 string /oracle10g/oracle/oracle/produ
ct/10.2.0/db_1/dbs/dr1mx1bprd.
dat
dg_broker_config_file2 string /oracle10g/oracle/oracle/produ
ct/10.2.0/db_1/dbs/dr2mx1bprd.
dat
dg_broker_start boolean TRUE
Re: Data Guard after upgrade to 10g [message #410195 is a reply to message #410188] Thu, 25 June 2009 11:18 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


>>I am asking where the broker config file is. I inherited this environment so I do not know where the files for data guard specifics are located

I hope now you find out file location.

>>DG 2009-06-24-12:51:32 0 2 0 DMON: cannot open configuration file "/oracle10g/oracle/oracle/product/10.2.0/db_1/dbs/dr2mx1bprd.dat"

Why NOT opening this file? Check from OS level.

Thanks
Re: Data Guard after upgrade to 10g [message #410208 is a reply to message #409988] Thu, 25 June 2009 12:18 Go to previous messageGo to next message
nateholtrop
Messages: 37
Registered: May 2008
Member
The files do not exist.
Re: Data Guard after upgrade to 10g [message #410217 is a reply to message #410208] Thu, 25 June 2009 13:22 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


let us wait update from metalink.

Thanks
Re: Data Guard after upgrade to 10g [message #414331 is a reply to message #409988] Tue, 21 July 2009 12:06 Go to previous messageGo to next message
nateholtrop
Messages: 37
Registered: May 2008
Member
They advised me to create a new physical standby.
Re: Data Guard after upgrade to 10g [message #414442 is a reply to message #414331] Wed, 22 July 2009 03:48 Go to previous message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


Then follow with metalink support.

Thanks
Previous Topic: DataGuard
Next Topic: DATAGUARD
Goto Forum:
  


Current Time: Mon Dec 05 09:13:58 CST 2016

Total time taken to generate the page: 0.09476 seconds