Home » Developer & Programmer » Forms » Running Oracle Reports in Forms
Running Oracle Reports in Forms [message #409127] Fri, 19 June 2009 09:13 Go to next message
Unprez
Messages: 9
Registered: February 2009
Junior Member
Hi,

Recieving run-time connection errors, appreciate any help on what I might be missing. Thanks.

Declare
report_id Report_Object;
ReportServerJob VARCHAR2(100);
param_string VARCHAR2(2000);


BEGIN
--attached to form
report_id:=find_report_object('Report63');

SET_REPORT_OBJECT_PROPERTY(report_id,REPORT_COMM_MODE,SYNCHRONOUS);
SET_REPORT_OBJECT_PROPERTY(report_id,REPORT_DESTYPE,CACHE);
SET_REPORT_OBJECT_PROPERTY(report_id,REPORT_SERVER,'user.company.local');

ReportServerJob:=run_report_object(report_id);
Re: Running Oracle Reports in Forms [message #409508 is a reply to message #409127] Mon, 22 June 2009 23:56 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Please read the guidelines concerning posting in this forum. Use 'code' tags and keep your attachments a ssmall as possible. Using 'bmp' is frowned upon. I will find out why the file extension restriction has been lifted.

What version of Forms and Reports are you using? Search this forum for 'run report' and 'web.show_document'.

Can you run the test form?

David
Re: Running Oracle Reports in Forms [message #409675 is a reply to message #409508] Tue, 23 June 2009 07:55 Go to previous messageGo to next message
Unprez
Messages: 9
Registered: February 2009
Junior Member
Sorry about that, I will take note for future reference.

Versions :
Forms [32 Bit] Version 10.1.2.0.2 (Production)
Report Builder 10.1.2.0.2

Using web show command i have the following:

Declare
report_id Report_Object;
ReportServerJob VARCHAR2(100);
param_string    VARCHAR2(2000);
t_name          VARCHAR2(30);
URL 		VARCHAR2(2000);


BEGIN
URL:= 'http://app2006.cmic.company.com:7777/reports/rwservlet?server=app2006prod&report=Z:\cm1001_draft3.RDF&desformat=pdf&destype=cache&userid=xxxx/xxxxx@prod2006
&paramform=no';

WEB.SHOW_DOCUMENT(URL,'_BLANK');

END:


And I get the following message
REP-110: Unable to open file 'cm1001_draft3.RDF'.
REP-1070: Error while opening or saving a document.
REP-0110: Unable to open file 'cm1001_draft3.RDF'.


- I can run the forms and I can also run the report seperately from reports builder but cannot open it from forms.

Thanks for the help,
Asad
Re: Running Oracle Reports in Forms [message #409712 is a reply to message #409127] Tue, 23 June 2009 10:16 Go to previous messageGo to next message
djbabu
Messages: 14
Registered: May 2009
Junior Member
Hi,

Did you got this resolved ?

If not , Please specify the Report name in the property palette of the report object of Forms.

Hope that should fix : "REP-110: Unable to open file ..."

thanks,


Re: Running Oracle Reports in Forms [message #409756 is a reply to message #409712] Tue, 23 June 2009 20:57 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
'app2006.cmic.company.com:7777' is your PC - correct?

Does the URL run if you place it at the browser prompt?

Can you get ANY report to run?

'Z:' is in the 'forms_path' ins't it?

David
Previous Topic: problem for export to excel functionality-unable to compile the form
Next Topic: Migration from Forms 6i to Forms 10g - Data update problem
Goto Forum:
  


Current Time: Sat Dec 10 18:42:34 CST 2016

Total time taken to generate the page: 0.07583 seconds