Home » Developer & Programmer » Reports & Discoverer » REP-0736: There exist uncompiled program unit(s)
REP-0736: There exist uncompiled program unit(s) [message #408896] Thu, 18 June 2009 04:16 Go to next message
rak007
Messages: 107
Registered: October 2006
Location: Mumbai / Pune, India
Senior Member
We are executing a step upgrade from 11.5.5 to R12. There are a few reports which are being migrated from 6i to 10g. One of these reports is causing problems.
The report is compiled fine in the target instance when compiled using report builder. But when we deploy the report on Unix box and run the concurrent program, it errors out with the following error.

REP-0736: There exist uncompiled program unit(s).
REP-1247: Report contains uncompiled PL/SQL. 


What all things we have tried till now

1. Ensured that the report is transferred in BINARY mode
2. Converted to the RDF to REX and back to RDF on unix box. This conversion from REX to RDF failed with the above error on unix box also.
3. Created the REX using report builder and transferred it to the unix box in ASCII mode. There ran the command to convert REX to RDF and it failed saying "Conversion Cancelled"

What may be the issue and how do i sort this out ??
Re: REP-0736: There exist uncompiled program unit(s) [message #408906 is a reply to message #408896] Thu, 18 June 2009 04:48 Go to previous messageGo to next message
vamsi kasina
Messages: 2107
Registered: October 2003
Location: Riyadh, Saudi Arabia
Senior Member
I don't think it is an issue with rdf.
Try to compile the rdf using rwconverter.sh or open using rwbuilder.sh, connect to any database using Ctrl + J and Ctrl + T.
Note down the errors.
It may be referring some package or procedure, which is having issues.

By
Vamsi
Re: REP-0736: There exist uncompiled program unit(s) [message #408916 is a reply to message #408906] Thu, 18 June 2009 05:23 Go to previous message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Also, you'd perhaps want to <Ctrl + Shift + K> (Compile All) before <Ctrl + T>.
Previous Topic: report builder, image issue with PDF output
Next Topic: Help with discoverer parameter default values
Goto Forum:
  


Current Time: Fri Dec 09 05:57:59 CST 2016

Total time taken to generate the page: 0.08972 seconds