Home » Infrastructure » Linux » Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/lib/ (ORACLE 10G 10.2.0 64 BIT ON RHEL 5 x86_64 bit)  () 1 Vote
Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/lib/ [message #408862] Thu, 18 June 2009 02:03 Go to next message
sanjay6713
Messages: 40
Registered: June 2009
Location: INDIA
Member
Hi All.,,

Following is the error i got while installing oracle 10g 64 bit on RHEL 5 x86_64 bit OS.
********************************************************************
Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/lib/ins_net_client.mk'.
**********************************************************************

I have the following packages installed.

######################################################################
[oracle@mail3 ORACLE_INSTALLATION_FILES]$ rpm -q binutils gcc gcc-c++ glibc gnome-libs libstdc++ libstdc++-devel make \
> pdksh sysstat xscreensaver libaio
binutils-2.17.50.0.6-9.el5
gcc-4.1.2-44.el5
gcc-c++-4.1.2-44.el5
glibc-2.5-34
glibc-2.5-34
package gnome-libs is not installed
libstdc++-4.1.2-44.el5
libstdc++-4.1.2-44.el5
libstdc++-devel-4.1.2-44.el5
make-3.80-8
package pdksh is not installed
sysstat-7.0.2-3.el5
package xscreensaver is not installed
libaio-0.3.106-3.2
libaio-0.3.106-3.2
##################################################
Note:
i m using trial version of both OS and Oracle 10g s/w

Attached is the make.log
Please Help me out here.
Thanks in Adv



  • Attachment: make.log
    (Size: 3.78KB, Downloaded 234 times)
Re: Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/ [message #408900 is a reply to message #408862] Thu, 18 June 2009 04:27 Go to previous messageGo to next message
amitzil
Messages: 9
Registered: June 2009
Junior Member
Hi,
Your problem is probably missing RPMs.
Note that there are several RPMs that Oracle requires both the 64-bit version and 32-bit version (such as glibc and glicd-devel).

The full list of required RPMs is:
binutils-2.17.50 (x86_64)
compat-db-4.2.52 (x86_64)
compat-libstdc++-296(i386)
compat-libstdc++-33-3.2.3 (x86_64)
compat-libstdc++-33-3.2.3(i386)
control-center-2.16.0 (x86_64)
gcc-4.1.1 (x86_64)
gcc-c++-4.1.1 (x86_64)
glibc-2.5-12 (x86_64)
glibc-2.5-12 (i686)
glibc-common-2.5-12 (x86_64)
glibc-devel-2.5-12 (x86_64)
glibc-devel-2.5-12(i386)
glibc-headers-2.5-12 (x86_64)
ksh-20060214-1.4 (x86_64)
libaio-0.3.96 (x86_64)
libgcc-4.1.1(i386)
libgcc-4.1.1(x86_64)
libgnome-2.16.0 (x86_64)
libgnomeui-2.16.0 (x86_64)
libgomp-4.1.1 (x86_64)
libstdc++-4.1.1 (x86_64)
libstdc++-devel-4.1.1 (x86_64)
libXp-1.0.0-8 (i386)
make-3.81 (x86_64)
sysstat-7.0.0 (x86_64)

You can check note 421308.1 in metalink for all requirements of 10gR2 on RHEL5 64bit.

Liron Amitzi
Senior DBA consultant

[Updated on: Sun, 21 June 2009 02:36] by Moderator

Report message to a moderator

Re: Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/ [message #409322 is a reply to message #408900] Mon, 22 June 2009 02:56 Go to previous messageGo to next message
sanjay6713
Messages: 40
Registered: June 2009
Location: INDIA
Member
Thanks for the reply.

I tried to install 32-bit versions, but it said "Already higher versions of this package has been Installed".


When i un-install 64 bit ones and try installing 32 bit ones first and then 64 bit packages, Its getting really messed up like linux system hangs and GUI damaged

Please let me know the safest way to install both the bit versions packages.

Thanks in Adv.
Re: Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/ [message #409331 is a reply to message #409322] Mon, 22 June 2009 03:27 Go to previous messageGo to next message
amitzil
Messages: 9
Registered: June 2009
Junior Member
Hi,
I don't remember seeing such problems.
Before you uninstalled the 64-bit version, did you check the entire RPMs required list?

Liron
Re: Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/ [message #409338 is a reply to message #409331] Mon, 22 June 2009 03:41 Go to previous messageGo to next message
sanjay6713
Messages: 40
Registered: June 2009
Location: INDIA
Member
Yes i checked ,,,some of the 32 bit packages were not installed like glibc and glibc devel.
When i tried to install it said "Higher versions already installed"

Now how to go about installing 32 bit ones as its getting a big issue now which is not supposed to be,,,
Re: Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/ [message #409341 is a reply to message #409338] Mon, 22 June 2009 03:51 Go to previous messageGo to next message
amitzil
Messages: 9
Registered: June 2009
Junior Member
Sorry, but I don't know.
You should try to contact sys admin

Liron
Re: Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/ [message #409450 is a reply to message #409341] Mon, 22 June 2009 14:30 Go to previous messageGo to next message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member


Try to use

Quote:
rpm -ivh <<rpm file name>> --aid --force


PS: This is oracle releated to question.

Thanks
Re: Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/ [message #409517 is a reply to message #409450] Tue, 23 June 2009 00:36 Go to previous messageGo to next message
sanjay6713
Messages: 40
Registered: June 2009
Location: INDIA
Member
Hey Thats great,, It wrkd for me,,
Thanks a lot.
I used only "rpm -ivf <<package name>>" to install missing packages from the command promp.

Some packages do net get install when we click that.
So its good procedure to install from cmd promt.


I should thank "Liron Amitzi" for giving me the exact packaghes required. Thanks Liron.


Following is the command to chk the RPM's required for oracle 10g 64 bit on Linux 64 bit OS.

rpm -q binutils compat-db compat-libstdc++-33-3.2.3-61 control-center gcc gcc-c++ glibc glibc-common glibc-devel glibc-headers libaio libgcc libgnome libgnomeui libgomp libstdc++ libstdc++-devel make ksh sysstat libXp

Following is the list of packages erquired as mentioned by Liron in the above posts.

The full list of required RPMs is:
binutils-2.17.50 (x86_64)
compat-db-4.2.52 (x86_64)
compat-libstdc++-296(i386)
compat-libstdc++-33-3.2.3 (x86_64)
compat-libstdc++-33-3.2.3(i386)
control-center-2.16.0 (x86_64)
gcc-4.1.1 (x86_64)
gcc-c++-4.1.1 (x86_64)
glibc-2.5-12 (x86_64)
glibc-2.5-12 (i686)
glibc-common-2.5-12 (x86_64)
glibc-devel-2.5-12 (x86_64)
glibc-devel-2.5-12(i386)
glibc-headers-2.5-12 (x86_64)
ksh-20060214-1.4 (x86_64)
libaio-0.3.96 (x86_64)
libgcc-4.1.1(i386)
libgcc-4.1.1(x86_64)
libgnome-2.16.0 (x86_64)
libgnomeui-2.16.0 (x86_64)
libgomp-4.1.1 (x86_64)
libstdc++-4.1.1 (x86_64)
libstdc++-devel-4.1.1 (x86_64)
libXp-1.0.0-8 (i386)
make-3.81 (x86_64)
sysstat-7.0.0 (x86_64)


So Finally Thanks all for replying and supporting. Smile

Sanjay.S
DBA
Re: Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/ [message #409724 is a reply to message #409517] Tue, 23 June 2009 11:58 Go to previous messageGo to next message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member


Thanks for the feedback.

Babu
Re: Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/ [message #421808 is a reply to message #408862] Thu, 10 September 2009 13:55 Go to previous messageGo to next message
wplsulur
Messages: 1
Registered: September 2009
Junior Member
I Installed Oracle 10g R2 on RHEL 5.4 and came across the same issue. I resolved it by installing the following packages

compat-glibc-2.3.4-2.26:1.i386
compat-glibc-headers-2.3.4-2.26.i386.rpm for
Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)

Exit the installer, reboot the server just in case.

Oracle 10g R2 64 bit is not a complete 64 bit app and looks for 32 bit libraries during the linking process.


Good Luck.



Re: Error in invoking target 'nnfgt.o' of makefile '/home/oracle/oracle/product/10.2.0/db_1/network/ [message #446631 is a reply to message #408862] Tue, 09 March 2010 13:26 Go to previous message
sunnyOrcl
Messages: 1
Registered: March 2010
Junior Member
Hello,

While trying to install Oracle Fusion Middleware products (Identity Management)on RHEL 5.0 I am encountered with the following error

'Error in invoking target 'client_sharedlib' of makefile'

Can someone help me to resolve this issue..

how should I use RPM in linux? any idea?


Thanks,
Sunny
Previous Topic: RHEL 2.1 AS is suitable for Oracle 11g R2
Next Topic: oracleinstallation problem
Goto Forum:
  


Current Time: Sat Apr 19 20:58:53 CDT 2014

Total time taken to generate the page: 0.08482 seconds