Home » Developer & Programmer » Forms » Webutil & Jacob is not working in Browser (Oracle 10G 2R Under Vista)
Webutil & Jacob is not working in Browser [message #406535] Thu, 04 June 2009 08:11 Go to next message
Only-Oracle
Messages: 43
Registered: June 2009
Member
I have a problem in my Forms. First, I was doing Form and I wanted to add picture for item and I want the picture to be saved
in database through pressing on button and a browser open and select the image to be saved in database. and if I want to later on
when I select the item the picture automatically come up with the item_id.

a later on I knew that I need to config the Oracle to Webutil + Jacob and also I knew that the Forms 10G 2R comes with webutil so I just
need to config Jacob in my system and after a long searching on the net and forums and reading I couldn't solve my problems

after following the configuration I reached to point which I stuck in and I don't know how to solve it.
so After assiging the two Jar files in under Dos I couldn't done them in success

here is the way I did:
sign_webutil.bat C:\DevSuiteHome_2\forms\java\frmwebutil.jar
sign_webutil.bat C:\DevSuiteHome_2\forms\java\jacob.jar

I get this error after signing the jar files and that mean it's not configured well from the first time by showing error.
*******************************************
C:\DevSuiteHome_2\forms\webutil>sign_webutil.bat c:\devsuitehome_2\forms\java\ja
cob.jar
Generating a self signing certificate for key=webutil2...
keytool error: java.lang.Exception: Key pair not generated, alias <webutil2> alr
eady exists
.
There were warnings or errors while generating a self signing certificate. Pleas
e review them.
.
Backing up c:\devsuitehome_2\forms\java\jacob.jar as c:\devsuitehome_2\forms\jav
a\jacob.jar.old...
1 file(s) copied.
Signing c:\devsuitehome_2\forms\java\jacob.jar using key=webutil2...
'jarsigner' is not recognized as an internal or external command,
operable program or batch file.
.
There were warnings or errors while signing the jar. Please review them.
*****************************************************

I tried to check some forms in a browser but still I get error asigned from Microsoft Windows like "Oracle Forms Runform has stopped working" and I press on Close the program and another Oracle error come up "FRM-92101:There was a failure in the Forms Server during startup. This could happen due to invalid configuration. Please look into the web-server log file for details.


Systems I'm using might help in identifying and solving the problem I'm facing.
* I'm using Vista Ultimate edition.
*Oracle Database 10G 2R.
*Oracle Developer Suite Forms 10G 2R Version 10.1.2.0.2
* OCJ4 Instance is working well and I can work with any Forms in a browser in best way except when I have Forms that configured to retrieve Image or save Image.
* I tried using webutil Demo and it's not helping me still the problem there because the problem in configuring the Jar files
* I use JInitiator 1.3.1.22 do you think this might cause a problem in Vista so if I use JInitiator 1.3.1.28 will fix the problem?.

Here I'm attaching some picture that I'm facing and some files that I modified, might help in solving my problem.

Hopefully this information can identify my problem. Thank you very much for helping me.
  • Attachment: My files.rar
    (Size: 100.21KB, Downloaded 165 times)
Re: Webutil & Jacob is not working in Browser [message #407407 is a reply to message #406535] Wed, 10 June 2009 02:03 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Search this forum for 'jinitiator vista'. I think that you need to replace the JInitiator version of 'jvm.dll' with the one that exists in the Java folder.

David
Previous Topic: file rtf
Next Topic: Urgent: Export images from Database to OS
Goto Forum:
  


Current Time: Fri Dec 09 17:52:18 CST 2016

Total time taken to generate the page: 0.44389 seconds