Home » Developer & Programmer » Forms » item date format problem (oracle forms 10 & Oracle DB 10g)
icon5.gif  item date format problem [message #406177] Tue, 02 June 2009 12:55 Go to next message
amiserio
Messages: 3
Registered: June 2009
Location: Russia
Junior Member
Greetings to all.
Situation:
I have 2(data1 and data2) data block's, in each of them I have on one item, which are absolutely identical property.

item1 and item 2:
Data type: Date
Format mask: DD.MM.YYYY HH24:MI

i have button button1, and in trigger WHEN_BUTTON_PRESSED i do:
:data2.item2:=:data1.data1;

Problem:
when i enter in item1: 10.06.09 12:23
and pressed button1 i receive in item2: 10.16.09 00:00

Why? And how it to overcome?

[Updated on: Tue, 02 June 2009 13:21]

Report message to a moderator

Re: item date format problem [message #406207 is a reply to message #406177] Tue, 02 June 2009 15:41 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
There's something wrong about your story:
Format mask       : DD.MM.YYYY HH24:MI
i receive in item2: 10.16.09 00:00
I don't know about your country, but there's no month "16" where I live.
Re: item date format problem [message #406218 is a reply to message #406207] Tue, 02 June 2009 22:23 Go to previous messageGo to next message
amiserio
Messages: 3
Registered: June 2009
Location: Russia
Junior Member
Sorry, i receive in item2: 10.06.09 00:00
problem only in time.
Re: item date format problem [message #406232 is a reply to message #406218] Tue, 02 June 2009 23:12 Go to previous messageGo to next message
vamsi kasina
Messages: 2107
Registered: October 2003
Location: Riyadh, Saudi Arabia
Senior Member
Quote:
DD.MM.YYYY HH24:MI
Why year is in two digits (09)?

By
Vamsi
Re: item date format problem [message #406305 is a reply to message #406232] Wed, 03 June 2009 04:15 Go to previous messageGo to next message
amiserio
Messages: 3
Registered: June 2009
Location: Russia
Junior Member
x_x

enter in item1: 10.06.2009 12:23
receive in item2: 10.06.2009 00:00

[Updated on: Wed, 03 June 2009 04:17]

Report message to a moderator

Re: item date format problem [message #406326 is a reply to message #406305] Wed, 03 June 2009 05:41 Go to previous message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
These item's datatype must not be DATE but DATETIME.
Previous Topic: WebUtil features don't work on client
Next Topic: HOW TO INCREMENT SERIAL NUMBER IN INSERT MODE
Goto Forum:
  


Current Time: Fri Dec 09 09:57:28 CST 2016

Total time taken to generate the page: 0.14390 seconds