Home » Developer & Programmer » Reports & Discoverer » button in report (report builder 6I)
button in report [message #406086] Tue, 02 June 2009 03:03 Go to next message
m_najmi
Messages: 4
Registered: April 2009
Junior Member
Hi,I have button on report page and it has pl/sql action behind.
it works when i call report in client.but when i want to run it in application server,it look like same as text!
how can i solve this problem?
Thanx.
Re: button in report [message #406091 is a reply to message #406086] Tue, 02 June 2009 03:22 Go to previous messageGo to next message
alok.singh
Messages: 4
Registered: January 2009
Location: PUNE
Junior Member
1.Change your PL/SQL Code of that button as below:-

procedure CALL_REPORT1ButtonAction is
begin
srw.run_report('report=path of your .RDF eg:-(C:\REPORTS\EMP_REPORT) desname=screen D='||:column_name);
end;

2.In property Pallete change
Button Behaviour=> PL/SQL type

I think it will work.
Re: button in report [message #406239 is a reply to message #406091] Tue, 02 June 2009 23:46 Go to previous message
m_najmi
Messages: 4
Registered: April 2009
Junior Member
Hi again.
I dont want to call report at button action,just i wanna update one of my tables at button pl/sql action.
May you suggest new way,pls?
Be careful,that i can do it at client,but when i run rep at application server ,it look like as text.


good luck.
Previous Topic: how to run the report?
Next Topic: capture the last accumulated column
Goto Forum:
  


Current Time: Wed Dec 07 10:59:06 CST 2016

Total time taken to generate the page: 0.08529 seconds