Home » RDBMS Server » Networking and Gateways » Help me: ORA-12514 (Oracle 10.2.0.1, OS: SuSe 10)
Help me: ORA-12514 [message #405833] Fri, 29 May 2009 17:10 Go to next message
nqtrung
Messages: 25
Registered: April 2007
Junior Member
Hi all
My server have 2 ethernet card and I have created 2 listener for DB server:
- Listener1 is binding on IP1 (10.36.70.xxx), port 1521.
- Listener2 is binding on IP2 (192.168.2.xxx), port 1522.
- Parameter: SERVICE_NAME=world.db1

On client, I have configed tnsnames.ora:

DB_PROD =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = 10.36.70.xxx)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SID = db1)
)
)

DB_DEV =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = 192.168.2.xxx)(PORT = 1522))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = world.db1)
)
)

Then try to connect DB server:
sqlplus user/pass@db_prod ---> OK
sqlplus user/pass@db_dev ---> Error
ORA-12514: TNS:listener does not currently know of service requested in connect descriptor

I don't know why this case I can't use parameter SERVICE_NAME. Can you help me, pls
Re: Help me: ORA-12514 [message #405834 is a reply to message #405833] Fri, 29 May 2009 18:23 Go to previous messageGo to next message
BlackSwan
Messages: 25036
Registered: January 2009
Location: SoCal
Senior Member
using CUT & PASTE issue the following commands

lsnrctl status Listener1
lsnrctl service Listener1
lsnrctl status Listener2
lsnrctl service Listener2
cat $ORACLE_HOME/network/admin/listener.ora

Paste the results back here.
Re: Help me: ORA-12514 [message #405838 is a reply to message #405833] Fri, 29 May 2009 21:40 Go to previous messageGo to next message
nqtrung
Messages: 25
Registered: April 2007
Junior Member
Thanks BlackSwan
I have fixed error, when config listener2 I forget to set GLOBAL_DBNAME to world.db1
Re: Help me: ORA-12514 [message #406017 is a reply to message #405838] Mon, 01 June 2009 11:58 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


Thanks for the feedback.

Babu
Re: Help me: ORA-12514 [message #412880 is a reply to message #406017] Mon, 13 July 2009 03:53 Go to previous message
yassercomputer
Messages: 1
Registered: July 2009
Junior Member
Thank you , solved my problem.
Previous Topic: No Successful connection from a TNSPING.
Next Topic: TNS issue
Goto Forum:
  


Current Time: Sat Dec 03 22:22:00 CST 2016

Total time taken to generate the page: 0.06348 seconds