Home » Developer & Programmer » Forms » sequence problem (Developer 6I Database 10g Window XP)
sequence problem [message #401679] Wed, 06 May 2009 02:26 Go to next message
shahzaib_4vip@hotmail.com
Messages: 376
Registered: December 2008
Location: karachi
Senior Member
i create a sequance

and write tirgger when_new_record instance

Begin
SELECT dept_seq.nextval INTO :TRANS_NO FROM SYS.dual;
SELECT dept_seq.nextval INTO :TRANS FROM SYS.dual;
End;



its working fine but when i press f8 for execute all record

its not executing all record ?


any idea

Shahzaib ismail
Re: sequence problem [message #401699 is a reply to message #401679] Wed, 06 May 2009 03:34 Go to previous messageGo to next message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
What problem are you trying to solve?

WHEN-NEW-RECORD-INSTANCE trigger doesn't fire during query execution.
Re: sequence problem [message #401750 is a reply to message #401679] Wed, 06 May 2009 06:06 Go to previous messageGo to next message
shahzaib_4vip@hotmail.com
Messages: 376
Registered: December 2008
Location: karachi
Senior Member
Thanks your little foot for your reply my problem solved actually i have 2 block one block contain number of record 1 and 2nd block contain 10 no of record i change it and its work fine


Regards


Shahzaib
Re: sequence problem [message #401942 is a reply to message #401750] Thu, 07 May 2009 02:02 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Search this forum for 'sequence'. Your approach is wrong, you need to use 'when-create-new-record'.

David
Previous Topic: CLIENT_GET_FILE_NAME in 10g R3
Next Topic: List Item Problem
Goto Forum:
  


Current Time: Fri Dec 02 13:56:15 CST 2016

Total time taken to generate the page: 0.11915 seconds