Home » Developer & Programmer » Reports & Discoverer » rwrun error - ORA-01012: not logged on (Oracle Reports 10g (10.1.2), AIX 5.3)
rwrun error - ORA-01012: not logged on [message #401526] Tue, 05 May 2009 06:33
Messages: 10
Registered: March 2009
Location: Mumbai
Junior Member

Am using Oracle Reports 10g on AIX 5.3.
We have a report which is executing fine when run from reports builder and even from the IE browser directly on reports server.

However this is failing when executed from AIX using rwrun.sh

The error displayed is
Report Builder: Release - Production on Tue May 5 12:08:23 2009

Copyright (c) 1982, 2005, Oracle. All rights reserved.

REP-0004: Warning: Unable to open user preference file.
REP-1425: 'afterpform': Error running DO_SQL package - 'Error parsing the SQL statement.
ORA-01012: not logged on' .


The report uses a srw.do_sql to insert into a table (name is parameterised ... and hence the do_sql) as below (:pm_tab is the parameterised table named passed from the parameter file)

l_sql := 'insert into my_table select name, rollno, address, '||chr(39)||:pm_srno||chr(39)||' from '||:pm_tab;


I have tried selecting a column from a test table as below .. to check the connection just above do_sql
  select dummy into l_text from dual;
  exception when others then

and that works absolutely fine. It just seems to disconnect from the database when the do_sql is fired.

Please help with the same.
Previous Topic: Customizing PickSlip Reports
Next Topic: Passing Parameter From Form to Report
Goto Forum:

Current Time: Thu Oct 20 17:26:28 CDT 2016

Total time taken to generate the page: 0.12039 seconds