Home » Developer & Programmer » Forms » List Item Problem
List Item Problem [message #399572] Thu, 23 April 2009 01:18 Go to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
Dear All

I have a form contains two list items and their list style is combo box, they are populating properly at run time but when I execute query they are displaying their codes instead of description.

Please suggest me, what should I do?


Regards,
List Item Problem [message #399579 is a reply to message #399572] Thu, 23 April 2009 01:29 Go to previous messageGo to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
Dear All

I have a form contains two list items and their list style is combo box, they are populating properly at run time but when I execute query they are displaying their codes instead of description.

Code and description both fields' data types are varchar2.

Please suggest me, what should I do to show description in my list item when user execute query.


Regards,

[Updated on: Thu, 23 April 2009 01:36]

Report message to a moderator

Re: List Item Problem [message #399592 is a reply to message #399579] Thu, 23 April 2009 02:02 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Make the column width of the code '0' (zero).

David
Re: List Item Problem [message #399598 is a reply to message #399592] Thu, 23 April 2009 02:12 Go to previous messageGo to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
Thanks for the reply but sorry I couldn't understand so would you please tell me clearyly.

I will be very grateful to you for this kind favor you give me.


Regards,
Re: List Item Problem [message #399601 is a reply to message #399598] Thu, 23 April 2009 02:16 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
You have defined a 'record_group' and an LOV. In the record_group' you have selected some columns. I assume one of them is your 'code' field. Then in the LOV you have displayed these columns. Well, change the width of the displayed column to '0' (zero).

David
Re: List Item Problem [message #399602 is a reply to message #399601] Thu, 23 April 2009 02:22 Go to previous messageGo to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
Dear, I didn't define any object_group. I am creating GROUP by query at run time and populating my list furthermore as I wrote in my problem it is a LIST_ITEM not a LOV.
Re: List Item Problem [message #399605 is a reply to message #399602] Thu, 23 April 2009 02:33 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
I never mentioned an 'object_group' and I don't use dynamic groups for exactly the problem you are trying to solve.

David
Re: List Item Problem [message #399613 is a reply to message #399572] Thu, 23 April 2009 02:43 Go to previous messageGo to next message
shahzaib_4vip@hotmail.com
Messages: 376
Registered: December 2008
Location: karachi
Senior Member
send me your FMB file i will correct it and send you again


Shahzaib Ismail
Re: List Item Problem [message #399623 is a reply to message #399605] Thu, 23 April 2009 02:54 Go to previous messageGo to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
sorry, by mistakenly I wrote 'object_group' instead of 'record_group'.

Now, you are saying I have to create a record_group in which I set column width 0 then my problem will resolve.
Re: List Item Problem [message #399645 is a reply to message #399623] Thu, 23 April 2009 05:03 Go to previous messageGo to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
Dear Martin

I tried as you inform me but the problem is still same.
Re: List Item Problem [message #399771 is a reply to message #399645] Thu, 23 April 2009 23:20 Go to previous messageGo to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
Dear Shahzaib

Please find the attached file as you want to correct it.
Re: List Item Problem [message #399798 is a reply to message #399572] Fri, 24 April 2009 02:37 Go to previous messageGo to next message
shahzaib_4vip@hotmail.com
Messages: 376
Registered: December 2008
Location: karachi
Senior Member
Need Export file of your data base

Go in run

write EXP

and make .dmp file and send me


Thanks


Shahzaib
Re: List Item Problem [message #399821 is a reply to message #399798] Fri, 24 April 2009 04:06 Go to previous messageGo to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
Dear Shahzaib

I can not send .dmp file due to the restriction by the group administrator.

Did you check the list item in form?
Re: List Item Problem [message #399827 is a reply to message #399572] Fri, 24 April 2009 04:11 Go to previous messageGo to next message
shahzaib_4vip@hotmail.com
Messages: 376
Registered: December 2008
Location: karachi
Senior Member
Send me at my mail addres


shahzaib_4vip@hotmail.com

your list look like correct but i will like to check it after create your tables

Re: List Item Problem [message #399859 is a reply to message #399572] Fri, 24 April 2009 05:11 Go to previous messageGo to next message
cookiemonster
Messages: 12403
Registered: September 2008
Location: Rainy Manchester
Senior Member
Why don't you just post create table statements for the tables referenced by the form.

A dump is truly unnecessary - and let's be honest, most company's would be VERY unhappy about a full dump of one of their DB's being posted on the internet.
Re: List Item Problem [message #399866 is a reply to message #399572] Fri, 24 April 2009 05:36 Go to previous messageGo to next message
shahzaib_4vip@hotmail.com
Messages: 376
Registered: December 2008
Location: karachi
Senior Member
Absloutly write Cookie monster

i need blank table format if its an important data so don't send i will create table from form



Shahzaib ismail
Re: List Item Problem [message #400031 is a reply to message #399866] Sat, 25 April 2009 02:44 Go to previous messageGo to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
Dear Shahzaib

Did you find any mistake or missing in my form? please try to solve my problem as early as you can.


Regards,
Re: List Item Problem [message #400032 is a reply to message #400031] Sat, 25 April 2009 02:47 Go to previous messageGo to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
isn't there any oracle champion in this group to resolve my problem.


Re: List Item Problem [message #400293 is a reply to message #399572] Mon, 27 April 2009 07:54 Go to previous messageGo to next message
cookiemonster
Messages: 12403
Registered: September 2008
Location: Rainy Manchester
Senior Member
To clarify what's going on:

You've got a record group called rg_orders that contains the following query:
Select com_code, com_id
From customer_order_mast
Where com_cis_id = :ocm_cis_id
And not exists (select 1 from order_confrm_mast, order_confrm_detl 
                where ocm_id = ocd_ocm_id And ocm_cis_id = com_cis_id)
Order by 1


You're then using the following code in a when-list-changed on ocm_list_id to populate the list item ocd_com_id:

Declare
  rn number;
Begin
  rn := populate_group('rg_orders');
  populate_list('ocd_com_id','rg_orders');
End;


This should give you a list item that displays com_code and stores com_id.
Is this what is happening?
And if it isn't can you specify in detail what it is displaying and storing.

By the way - it's always good practice in forms to qualify item names with their conresponding block name.
Re: List Item Problem [message #400373 is a reply to message #400293] Mon, 27 April 2009 23:24 Go to previous messageGo to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
Thanks cookiemonster for the reply.

Dear,

My queries are running successfully and populating list item correctly and also storing data correctly (com_id) but as you know a list item contain a displaying value (for end user) and database value (for storing).

When end user execute form then form should display end user (com_code) instead of stored values (com_id).

My form is simply displaying com_id instead of com_code when user execute records in form.



Re: List Item Problem [message #401635 is a reply to message #400373] Tue, 05 May 2009 20:54 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you solved your problem?

David
Re: List Item Problem [message #401742 is a reply to message #401635] Wed, 06 May 2009 05:47 Go to previous messageGo to next message
snsiddiqui
Messages: 168
Registered: December 2008
Senior Member
Not yet.
Re: List Item Problem [message #401823 is a reply to message #400373] Wed, 06 May 2009 10:05 Go to previous messageGo to next message
klat
Messages: 87
Registered: May 2009
Location: Mumbai
Member

snsiddiqui wrote on Tue, 28 April 2009 09:54
Thanks cookiemonster for the reply.

My form is simply displaying com_id instead of com_code when user execute records in form.




..
and what it is storing??



Re: List Item Problem [message #401948 is a reply to message #401823] Thu, 07 May 2009 02:18 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
If you are storing 'com_id' in the table then to see 'com_code' after retrieval you will need to have a non-database item in your record which you display instead of 'com_id' and populate it in the 'Post-query' trigger.

David
Previous Topic: sequence problem
Next Topic: Date Format change During the Insert
Goto Forum:
  


Current Time: Fri Dec 02 12:42:28 CST 2016

Total time taken to generate the page: 0.09365 seconds