Home » Server Options » RAC & Failsafe » OCFS2 (Oracle 10g + Linux 2 + VM-Ware 5)
OCFS2 [message #398865] Sat, 18 April 2009 13:39 Go to next message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member

Hello Team,

I'm trying to mount disk using OCFS2 in Red Hat linux 4 environment.

I have preperly configured OCFS2 and O2CB. But I'm geeting error message during mount. Please let me know what was the problem.


./fa/6052/0/

Babu
Re: OCFS2 [message #398866 is a reply to message #398865] Sat, 18 April 2009 14:11 Go to previous messageGo to next message
surachart
Messages: 19
Registered: December 2008
Junior Member
First thing... your system is "ELhugemem"

You should install ocfs2-xxxx "ELhugemem" only!

remove packages (2 packages ocfs2-xxxELxx + ocfs2-xxxxELsmpxx)
*** use only ocfs2-xxxxELhugememxxx
+ ocfs2console + ocfs2-tools + ocfs2-tools-devel

and then

try to configure o2bc again ...

http://surachartopun.com/2009/04/ocfs2-share-folders.html

Good Luck
Re: OCFS2 [message #398867 is a reply to message #398866] Sat, 18 April 2009 14:25 Go to previous messageGo to next message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member

Quote:
remove packages (2 packages ocfs2-xxxELxx + ocfs2-xxxxELsmpxx)
*** use only ocfs2-xxxxELhugememxxx
+ ocfs2console + ocfs2-tools + ocfs2-tools-devel


Can you tel me exact package name.. .

I'm using Redhat Enterprise Linux 4 AS (Oracle); By feault packages available; I need those packages as per your instruction ??

Babu
Re: OCFS2 [message #398869 is a reply to message #398867] Sat, 18 April 2009 15:03 Go to previous messageGo to next message
surachart
Messages: 19
Registered: December 2008
Junior Member
not sure... why you yo have
ocfs2-2.6.9-42.0.0.0.1.EL-1.2.3-2 and ocfs2-2.6.9-42.0.0.0.1.ELsmp-1.2.3-2

When you uname -a, that told you should install
ocfs2-2.6.9-42.0.0.0.1.ELhugemem-1.2.3-2 only

So, I think you should uninstall (rpm -e) ocfs2-2.6.9-42.0.0.0.1.EL-1.2.3-2 and ocfs2-2.6.9-42.0.0.0.1.ELsmp-1.2.3-2 packages

and try to configure cluster service again.

that is first solution.

if you still the problem.

you should check status o2bc
/etc/init.d/o2cb status
and check port of heartbeats .. that's binded ...

and last idea... format /dev/sdb again

good luck

Re: OCFS2 [message #398918 is a reply to message #398867] Sun, 19 April 2009 13:31 Go to previous message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member


Hello,

Thanks for your help.

I troubleshoot this problem without removing any packages.

Just tried "mkfs.ocfs2" after everything working fine..

Babu
http://babudba.blogspot.com
Previous Topic: log parallelism in Oracle RAC
Next Topic: OCFS2 related help
Goto Forum:
  


Current Time: Sun Apr 20 14:56:50 CDT 2014

Total time taken to generate the page: 0.09493 seconds