Home » Developer & Programmer » Reports & Discoverer » Lov-restricted report and parameter setting (Forms & Reports 6i)
Lov-restricted report and parameter setting [message #395280] Wed, 01 April 2009 00:50 Go to next message
didiera
Messages: 134
Registered: August 2007
Location: Mauritius
Senior Member
Hello again everyone,

I have a question here regarding report calls, parameter passing from forms and parameter validation (via List of Values in Reports). In my report, I have a parameter whose value is restricted by a LOV based on a query that selects currency codes and a default value ' LOCAL CURR' (note the leading blank space). This report is callable from a form which uses a bunch of Add_Parameter calls to set the required. In one specific case the ' LOCAL CURR' is passed on (written in exactly the same way a in the LOV on the target report). However, when I call the report from the form with the ' LOCAL CURR', it gives an error stating that the restricted param value for currency is not present in the accepted values (oracle error code REP-0788). How could I remedy this please?

regards,
Didier
Re: Lov-restricted report and parameter setting [message #395511 is a reply to message #395280] Wed, 01 April 2009 12:51 Go to previous messageGo to next message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Try to add that value into the report's list of values using UNION, such as
select value_you_currently_select name
from your_table
where some_condition
union all
select ' LOCAL CURR' name
from dual
Doing so, it *would* be part of the LoV.
Re: Lov-restricted report and parameter setting [message #395583 is a reply to message #395511] Wed, 01 April 2009 23:02 Go to previous message
didiera
Messages: 134
Registered: August 2007
Location: Mauritius
Senior Member
Hello and thanksfor your suggestion.

Actually the LOV is query-based and I do have a UNION query to fetch the required including the default value as you suggested. I thought it was that leading blank space so I got rid of it both in the report and forms param definition...now it works fine but I will try your suggestion since my union was not a union all and I didn't give a default field name.

cheers,
Didier
Previous Topic: sql function
Next Topic: Display name of a user who ran the report
Goto Forum:
  


Current Time: Fri Dec 02 23:11:20 CST 2016

Total time taken to generate the page: 0.07202 seconds