Home » Developer & Programmer » Forms » Webutil Problem -Help Required (Forms [32 Bit] Version 9.0.4.0.19 (Production),Oracle Database 10g Express Edition Release 10.2.0.1.0 - Production, Windows XP)
Webutil Problem -Help Required [message #395132] Tue, 31 March 2009 07:32 Go to next message
amanyanye
Messages: 5
Registered: March 2008
Junior Member
I have followed all the steps in configuring webutil as well as the jacob files but I get among other error on the webutil canvas in Developer FRM-13008: Cannot find JavaBean with the name 'oracle.forms.webutil.clientinfo.getclientinfo.'.
I also get the following error in forms runtime 'oracle.forms.webutil.host.Host bean not found.WEBUTIL_HOST.Execute will not work. I'm hosting on local machine through OC4J.
Please help me if you know where i got lost.

Thanks in advance
Re: Webutil Problem -Help Required [message #395140 is a reply to message #395132] Tue, 31 March 2009 08:11 Go to previous messageGo to next message
joy_division
Messages: 4504
Registered: February 2005
Location: East Coast USA
Senior Member
Not quite sure of your environment based on your description, but you cannot test webutil through the local OC4J instance. The FORM must be on an application server.
Re: Webutil Problem -Help Required [message #395166 is a reply to message #395140] Tue, 31 March 2009 09:21 Go to previous messageGo to next message
amanyanye
Messages: 5
Registered: March 2008
Junior Member
I am using OC4J that comes with developer suite to host my application on my laptop where i do my development. I'm not using Application Server. The forms and reports run fine but the problem comes when i try to utilise the webutil functions in such an environment. Could it be that it does not run in such environment? I've got application server at work but most of my developemnt , i prefer off the server. The other thing is even the form itself(on webutil canvas) is failing to find the javabean. Could there be further information you might require so as to be in a position to understand my problem.
regards
Re: Webutil Problem -Help Required [message #395569 is a reply to message #395166] Wed, 01 April 2009 22:41 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Googling 'oracle.forms.webutil.clientinfo.getclientinfo' returned http://forums.oracle.com/forums/thread.jspa?threadID=340792&start=15&tstart=0 and http://www.experts-exchange.com/Database/Oracle/Q_21895236.html (go to the bottom) and http://www.experts-exchange.com/Database/Oracle/Q_21895155.html (go to the bottom).

Do these help?

David
Re: Webutil Problem -Help Required [message #395939 is a reply to message #395569] Fri, 03 April 2009 03:53 Go to previous messageGo to next message
amanyanye
Messages: 5
Registered: March 2008
Junior Member
I managed to connect to the oracle forums solution you recommended. The steps there solved my problem. I was failing to understand the steps of subclassing the olb as well as signing the jar files. Thanks a lot man, Thanks David.

Regards
Re: Webutil Problem -Help Required [message #607467 is a reply to message #395569] Fri, 07 February 2014 00:16 Go to previous message
PareshV
Messages: 4
Registered: October 2005
Junior Member
done..

thanks a lot
Previous Topic: Error FRM-40908 RAM Internal Error
Next Topic: CLOSE ALL FORMS using the WHEN-WINDOW-ACTIVATED trigger
Goto Forum:
  


Current Time: Mon Sep 01 03:25:04 CDT 2014

Total time taken to generate the page: 0.09683 seconds