Home » RDBMS Server » Enterprise Manager » Can't access Database from EM Database Control
Can't access Database from EM Database Control [message #394658] Sun, 29 March 2009 11:13 Go to next message
jcyp_71
Messages: 15
Registered: March 2009
Junior Member
Hello, please your help,

i have installed Oracle 10G software on Windows XP, i've created a Database and configured network services, but when i launch EM database control, it appears a page showing that all services(listener, database....) are up, however i can't access database through corresponding link.
I've checked enterprise manager status (emctl status dbconsole), and it shows that EM is running, so what is the problem or what can i do in this case?

Thanks in advance.
Re: Can't access Database from EM Database Control [message #394702 is a reply to message #394658] Sun, 29 March 2009 19:26 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Are you getting an error message? Have you checked the logs in %ORACLE_HOME%\<hostname_sid>\sysman\log ?
Re: Can't access Database from EM Database Control [message #394720 is a reply to message #394702] Sun, 29 March 2009 22:15 Go to previous messageGo to next message
jcyp_71
Messages: 15
Registered: March 2009
Junior Member
Nope, no one error, all the services seem to be ok (up), the only thing is that when i try to connect through the link Recovery values or something like this (i'm translating from spanish) i get this error:

ORA-00604: error occurred at recursive SQL level 1 y ORA-12705: invalid or unknown NLS parameter value specified

I really haven't checked the logs in %ORACLE_HOME%\<hostname_sid>\sysman\log and i have not the machine available right now. However, i have captured two images, i attach one to this reply, i'm going to attach the other in the next reply.

I would appreciate your comments. Thanks.
Re: Can't access Database from EM Database Control [message #394723 is a reply to message #394720] Sun, 29 March 2009 22:19 Go to previous messageGo to next message
jcyp_71
Messages: 15
Registered: March 2009
Junior Member
Here the other image
Re: Can't access Database from EM Database Control [message #394731 is a reply to message #394723] Sun, 29 March 2009 23:39 Go to previous messageGo to next message
ora_baby
Messages: 89
Registered: May 2008
Member
how you connect to EM?
string of connect (URL)?

see:
db_1\NETWORK\ADMIN \listener.ora
and
tnsnames.ora
and
db_1\install\portlist.ini
Re: Can't access Database from EM Database Control [message #394761 is a reply to message #394731] Mon, 30 March 2009 04:05 Go to previous messageGo to next message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member

ORA-00604: error occurred at recursive SQL level string 
Cause: An error occurred while processing a recursive SQL statement (a statement applying to internal dictionary tables). 
Action: If the situation described in the next error on the stack can be corrected, do so; otherwise contact Oracle Support.  


Babu
Re: Can't access Database from EM Database Control [message #394946 is a reply to message #394723] Mon, 30 March 2009 20:34 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
You could try to recreate the repository with:

emca -config dbcontrol db -repos recreate
Re: Can't access Database from EM Database Control [message #395584 is a reply to message #394946] Wed, 01 April 2009 23:06 Go to previous messageGo to next message
jcyp_71
Messages: 15
Registered: March 2009
Junior Member
Hello, here the solution i found for this issue:

Apparently sometimes there is a conflict between language and territory settings of database and the ones specified in the regedit, so:

1) query nls_database_parameters dictionary view, verify values for language, territory and character set.

2) Set those values in the NLS_LANG key in the regedit (language_territory.characterset).

That worked for my database.
Thanks.
Re: Can't access Database from EM Database Control [message #395646 is a reply to message #395584] Thu, 02 April 2009 02:39 Go to previous message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member

Thanks for the feedback.

Babu
Previous Topic: Error java.lang.Exception
Next Topic: unable to logon through EM
Goto Forum:
  


Current Time: Sun Apr 20 16:06:40 CDT 2014

Total time taken to generate the page: 0.08751 seconds