Home » Developer & Programmer » Forms » form builder doesnt show compilation errors but unix server does. (forms 10g)
form builder doesnt show compilation errors but unix server does. [message #393882] Tue, 24 March 2009 15:20 Go to next message
nastyjillu
Messages: 211
Registered: February 2009
Senior Member
hi all,

i got a strange problem .

form builder doesn't show compilation errors but when i compile in unix server it is not creating .fmx and says compilation errors have occured.

error is given below:

error 306 at line 21,column 5
wrong number or types of arguments in call to 'PRC' .
pl/sql error 0 at line 21, column 5
statement ignored

i have checked that procedure, but its not at all wrong. i checked every field used by procedure, checked datatype of all fields used by procedure. checked number of arguments passed.
everything is perfect.

if at all there is any mistake in datatype or number of arguments, then form builder would have shown errors. but its not doing so.

then what might be the problem???
Re: form builder doesnt show compilation errors but unix server does. [message #393887 is a reply to message #393882] Tue, 24 March 2009 15:38 Go to previous messageGo to next message
nastyjillu
Messages: 211
Registered: February 2009
Senior Member
forgot to tell,

block which calls this procedure is 'WMREV' and its an inherited block.

this procedure is being called in post-query trigger of 'WMREV' block.

to test the form, i made post-query trigger as NULL and commented original code and compiled the form in unix. now its not showing error.

what might be the problem when everything is correct??
Re: form builder doesnt show compilation errors but unix server does. [message #393890 is a reply to message #393882] Tue, 24 March 2009 16:15 Go to previous messageGo to next message
cookiemonster
Messages: 12422
Registered: September 2008
Location: Rainy Manchester
Senior Member
I would assume there's more than one copy of this procedure to be found and form builder is seeing one and unix compile the other.

Is it in the database or a pll?
Re: form builder doesnt show compilation errors but unix server does. [message #393891 is a reply to message #393890] Tue, 24 March 2009 16:47 Go to previous messageGo to next message
nastyjillu
Messages: 211
Registered: February 2009
Senior Member
its a package created in the program unit section of form builder.
Re: form builder doesnt show compilation errors but unix server does. [message #393898 is a reply to message #393882] Tue, 24 March 2009 17:36 Go to previous message
cookiemonster
Messages: 12422
Registered: September 2008
Location: Rainy Manchester
Senior Member
Is form builder seeing a different version of the object you're inheriting the package from to the one unix is seeing?
Previous Topic: CLEAR THE LIST ITEM
Next Topic: Forms Application Closing
Goto Forum:
  


Current Time: Fri Dec 09 15:31:46 CST 2016

Total time taken to generate the page: 0.16568 seconds