Home » Developer & Programmer » Forms » database not updating (oracle 10g)
database not updating [message #392036] Mon, 16 March 2009 02:34 Go to next message
leumas
Messages: 22
Registered: March 2009
Location: philippines
Junior Member
I created a form that has 2 tables the problem is that when i run the form. it updates the first table but the 2nd table remains empty. what could be the possible problems?
Re: database not updating [message #392062 is a reply to message #392036] Mon, 16 March 2009 04:20 Go to previous messageGo to next message
jolly_makkar
Messages: 63
Registered: March 2008
Member
Does the table have relation among them?
Test by saving both blocks manually ...Use push button
Re: database not updating [message #392069 is a reply to message #392036] Mon, 16 March 2009 04:45 Go to previous messageGo to next message
leumas
Messages: 22
Registered: March 2009
Location: philippines
Junior Member
yes. I have checked the relation of the database and I don't see anything wrong with the tables. oracle also does not display any error when saving. It shows that the items where saved and yet the database is empty.
Re: database not updating [message #392071 is a reply to message #392069] Mon, 16 March 2009 04:51 Go to previous messageGo to next message
Littlefoot
Messages: 20896
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Are you working on the same schema in both cases (Forms and SQL*Plus)? I mean, perhaps you have modified a table in one schema using Forms, and viewing what has happened in another schema using SQL*Plus (or another tool) (in another database).

What happens if you execute query in the detail block (leave the master "as is")?
Re: database not updating [message #392074 is a reply to message #392036] Mon, 16 March 2009 05:02 Go to previous messageGo to next message
leumas
Messages: 22
Registered: March 2009
Location: philippines
Junior Member
I checked the schema. I am running the same schema. I'm not sure how to query the detail.
Re: database not updating [message #392075 is a reply to message #392074] Mon, 16 March 2009 05:04 Go to previous messageGo to next message
Littlefoot
Messages: 20896
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Go to the detail block and EXECUTE QUERY.
Re: database not updating [message #392184 is a reply to message #392036] Mon, 16 March 2009 22:57 Go to previous messageGo to next message
leumas
Messages: 22
Registered: March 2009
Location: philippines
Junior Member
nothing happens when query the detail block. the cursor moves to the next item.
Re: database not updating [message #392217 is a reply to message #392184] Tue, 17 March 2009 01:24 Go to previous messageGo to next message
Littlefoot
Messages: 20896
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Executing a query moves focus to the next item?!?

It appears that there's something wrong about your form. Perhaps you should delete it and create a brand new one. Use wizard to help you create both master and detail block, along with the relation between them. By default, Forms will correctly maintain master-detail relationship and make sure that changes you make are saved into the database.

Once you make it work, try to make it fancy (i.e. add your own functionalities).
Re: database not updating [message #392248 is a reply to message #392036] Tue, 17 March 2009 03:12 Go to previous message
leumas
Messages: 22
Registered: March 2009
Location: philippines
Junior Member
thanks.
Previous Topic: Mandatory Field problem
Next Topic: Primary keys, sequenes and blocks
Goto Forum:
  


Current Time: Tue Dec 06 10:03:51 CST 2016

Total time taken to generate the page: 0.05316 seconds