Home » Developer & Programmer » Forms » how to fix the vlaue for current item? (forms 6i)
how to fix the vlaue for current item? [message #391963] Sun, 15 March 2009 04:26 Go to next message
mm_kanish05
Messages: 487
Registered: January 2007
Location: Chennai
Senior Member

Hi
I have code like below, I need to fix the value for current How can i achieve this.
please help me.

Open cur1;
	   Loop
	   	   Fetch cur1 into vcur;
	   	   Exit When cur1%Notfound;	
	   	      Go_block('Data');
	   	      First_Record;	   	     
             For i in (select slcode from rtm_slcode_list order by slcode) Loop
             	   If vcur.slcode = i.slcode Then 
             	   	  For j in (select glcode from rtm_tdsgl_list order by glcode) Loop
             	   	  	if vcur.glcode = j.glcode Then
             	   	  		 << hear want to fix value for currentitem >>
             	   	  	Else
             	   	  		 Next_item;
             	   	  	End if;	 
             	   	  End Loop;
             	   Else
             	   	  Next_Record;
             	   End if;
             End Loop;
	   End Loop;


kanish
Re: how to fix the vlaue for current item? [message #391988 is a reply to message #391963] Sun, 15 March 2009 13:16 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Which item is the "current item"? The first (navigable) one in the current block / record? Something like
:block.your_current_item := some_value;
Re: how to fix the vlaue for current item? [message #392000 is a reply to message #391963] Sun, 15 March 2009 21:53 Go to previous message
mm_kanish05
Messages: 487
Registered: January 2007
Location: Chennai
Senior Member

Thanks for replay littlefoot,

Runtime only i know the current name (:system.current_item), which i want to fix value.

Anyway i done it.

Soluion:

copy(vcur.derval+nvl(:System.Current_value,0),:System.current_item);


Thank again

Previous Topic: Receiving error Frm-40212 on check box fields
Next Topic: cursor is not working ?
Goto Forum:
  


Current Time: Sat Dec 10 06:51:13 CST 2016

Total time taken to generate the page: 0.07911 seconds