Home » SQL & PL/SQL » SQL & PL/SQL » table or view does not exist error while using db links (merged)
table or view does not exist error while using db links (merged) [message #391348] Wed, 11 March 2009 21:36 Go to next message
stuti.raj
Messages: 6
Registered: March 2009
Location: India
Junior Member
Hi,

I've created a proc which uses db links to connect to the databases on different servers.

But when im compiling it getting an error table or view does not exist.

I thought it might be the problem of permissions so checked that also,all necessary permission are granted to the user which is compiling the proc.

Please let me know what could be the possible things that caused this error.

Thanks
Re: table or view does not exist error while using db links [message #391351 is a reply to message #391348] Wed, 11 March 2009 22:01 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/
So we can help you

Privileges acquired via ROLE do not apply within PL/SQL procedures.

Explicit GRANT on accessed object must be done for accessing user.
Re: table or view does not exist error while using db links [message #391352 is a reply to message #391348] Wed, 11 March 2009 22:02 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
do not cross/multi-post
Re: table or view does not exist error while using db links [message #391353 is a reply to message #391351] Wed, 11 March 2009 22:15 Go to previous messageGo to next message
stuti.raj
Messages: 6
Registered: March 2009
Location: India
Junior Member
It got posted twice because of the connection faliure.
Re: table or view does not exist error while using db links [message #391354 is a reply to message #391348] Wed, 11 March 2009 22:17 Go to previous messageGo to next message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
Good Luck with resolving your bug.
Re: table or view does not exist error while using db links [message #391355 is a reply to message #391351] Wed, 11 March 2009 22:25 Go to previous messageGo to next message
stuti.raj
Messages: 6
Registered: March 2009
Location: India
Junior Member
Accessing user have got all the privileges on the accessed objects.
Re: table or view does not exist error while using db links [message #391356 is a reply to message #391348] Wed, 11 March 2009 22:32 Go to previous message
BlackSwan
Messages: 25033
Registered: January 2009
Location: SoCal
Senior Member
>Accessing user have got all the privileges on the accessed objects.
If "user have got all the privileges on the accessed objects",
then no error would result.

You have table & DDL. We don't
You have data & DML. We don't.
You have code. We don't.
You have error message. We don't.

You have ALL the information & can't debug the problem.
Why do you expect others, who have NO details, to answer your mystery?

You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/
Previous Topic: Getting Data From Weak Ref Cursors
Next Topic: Help with Exists or In Statement (Merged again)
Goto Forum:
  


Current Time: Fri Dec 02 23:03:39 CST 2016

Total time taken to generate the page: 0.05880 seconds