Home » SQL & PL/SQL » Client Tools » SQL Developer
SQL Developer [message #390757] Mon, 09 March 2009 11:17 Go to next message
dheuschkel
Messages: 14
Registered: March 2007
Junior Member
Hello orafaq!

I'm working with Oracle 11g. Oracle SQL Developer Version 1.5.3

I tried to compile the following code.

<<my_lable>>
begin
null;
end;

SQL Developer returns an error ORA-00600.
Compiling this under SQLPLUS* the code works properly.

The Question is how does SQL Developer handle with lables?
I couldn't find a hint in the documention.

Thanks in advance for your answer!

Dagmar
Re: SQL Developer [message #390759 is a reply to message #390757] Mon, 09 March 2009 11:20 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ORA-600 is a server problem not a SQL Developer one.
You have to check trace on server and most likely open a SR to Oracle.

Regards
Michel
Re: SQL Developer [message #390769 is a reply to message #390757] Mon, 09 March 2009 12:16 Go to previous messageGo to next message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I don't have SQL Developer, but - what happens if you enclose your PL/SQL block into another BEGIN-END, such as
BEGIN
  <<my_label>>
  BEGIN
    NULL;
  END;
END;

(By the way, your original code works fine in TOAD.)
Re: SQL Developer [message #390774 is a reply to message #390769] Mon, 09 March 2009 12:59 Go to previous messageGo to next message
dheuschkel
Messages: 14
Registered: March 2007
Junior Member
Dear Littlefoot!

I tried the code under SQLPLUS and it did perfectly as well as under TOAD.
IF I enclose the code in enother block, it works.
So te question is, why it doesn't work i the Developer surrounding.

regards Dagmar
Re: SQL Developer [message #390776 is a reply to message #390774] Mon, 09 March 2009 13:16 Go to previous message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Because you encountered a bug in what SQL Developer send to the server.

Regards
Michel
Previous Topic: iSql*Plus
Next Topic: Getting Errror in run to SQL* loader in TOAD
Goto Forum:
  


Current Time: Sat Dec 03 10:08:20 CST 2016

Total time taken to generate the page: 0.04413 seconds