Home » RDBMS Server » Networking and Gateways » got the TNS-03505. but all the configuration is OK, (Oracle 10.2.0 RHEL5)
got the TNS-03505. but all the configuration is OK, [message #389420] Mon, 02 March 2009 00:14 Go to next message
crazyzhou
Messages: 38
Registered: March 2008
Location: china
Member
First allow me to show you the system infomation:

[oracle@crazydba ~]$ hostname
crazydba


SQL> show parameter service_name

NAME                                 TYPE        VALUE
------------------------------------ ----------- ------------------------------
service_names                        string      global_zqh
SQL> 


SQL> show parameter shared_servers

NAME                                 TYPE        VALUE
------------------------------------ ----------- ------------------------------
max_shared_servers                   integer     2
shared_servers 


sqlnet.ora file:
SQLNET.AUTHENTICATION_SERVICES= (NTS)
NAMES.DIRECTORY_PATH= (TNSNAMES,HOSTNAME)
NAMES.DEFAULT_DOMAIN=DB_DOMAIN


tnsnames.ora file:
DEVELOP =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST =crazydba)(PORT = 1521))
    )
    (CONNECT_DATA =
      (SERVICE_NAME =global_zqh)
    )
  )

EXTPROC_CONNECTION_DATA =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
    )
    (CONNECT_DATA =
      (SID = PLSExtProc)
      (PRESENTATION = RO)
    )
  )


listener.ora file :

SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = PLSExtProc)
      (ORACLE_HOME = /u01/app/oracle/product/10.2.0/db_1)
      (PROGRAM = extproc)
    )
  )

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = crazydba)(PORT = 1521))
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC0))
    )
  )



now, the problem is here:

[oracle@crazydba ~]$ tnsping global_zqh

TNS Ping Utility for Linux: Version 10.2.0.1.0 - Production on 02-MAR-2009 01:07:03

Copyright (c) 1997, 2005, Oracle.  All rights reserved.

Used parameter files:
/u01/app/oracle/product/10.2.0/db_1/network/admin/sqlnet.ora

TNS-03505: Failed to resolve name
[oracle@crazydba ~]$



I don't understand what's wrong?

thanks a lot.
Re: got the TNS-03505. but all the configuration is OK, [message #389428 is a reply to message #389420] Mon, 02 March 2009 00:38 Go to previous messageGo to next message
Michel Cadot
Messages: 57606
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Where "global_zqh" entry is in your tnsnames.ora?
Configuration is NOT ok.

Regards
Michel
Re: got the TNS-03505. but all the configuration is OK, [message #389440 is a reply to message #389420] Mon, 02 March 2009 01:55 Go to previous messageGo to next message
crazyzhou
Messages: 38
Registered: March 2008
Location: china
Member
thinks Michel.
If I change the command like following, the problem still there:
[oracle@crazydba ~]$ tnsping develop

TNS Ping Utility for Linux: Version 10.2.0.1.0 - Production on 02-MAR-2009 02:18:17

Copyright (c) 1997, 2005, Oracle.  All rights reserved.

Used parameter files:
/u01/app/oracle/product/10.2.0/db_1/network/admin/sqlnet.ora

TNS-03505: Failed to resolve name


and I started the listener, I got some message :
LSNRCTL> start        
Starting /u01/app/oracle/product/10.2.0/db_1/bin/tnslsnr: please wait...

TNSLSNR for Linux: Version 10.2.0.1.0 - Production
System parameter file is /u01/app/oracle/product/10.2.0/db_1/network/admin/listener.ora
Log messages written to /u01/app/oracle/product/10.2.0/db_1/network/log/listener.log
Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=crazydba)(PORT=1521)))
Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC0)))

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=crazydba)(PORT=1521)))
TNS-12547: TNS:lost contact
 TNS-12560: TNS:protocol adapter error
  TNS-00517: Lost contact
   Linux Error: 104: Connection reset by peer
Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC0)))
TNS-01153: Failed to process string: 
 NL-00313: null pointer or null size


can you tell me more?
thanks.

Re: got the TNS-03505. but all the configuration is OK, [message #389444 is a reply to message #389440] Mon, 02 March 2009 02:14 Go to previous messageGo to next message
Michel Cadot
Messages: 57606
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
NAMES.DEFAULT_DOMAIN=DB_DOMAIN

This is added to the service name you give.
So "tnsping develop" becomes "tnsping develop.DB_DOMAIN" which I bet is not declared in your tnsnames.ora.

Regards
Michel
Re: got the TNS-03505. but all the configuration is OK, [message #389447 is a reply to message #389420] Mon, 02 March 2009 02:30 Go to previous messageGo to next message
crazyzhou
Messages: 38
Registered: March 2008
Location: china
Member
the tnsnames.ora do not declare other names but "DEVELOP, EXTPROC_CONNECTION_DATA". and I have commented this "NAMES.DEFAULT_DOMAIN=DB_DOMAIN" in sqlnet.ora, and
"tnsping develop" is the same problem.
Re: got the TNS-03505. but all the configuration is OK, [message #389450 is a reply to message #389447] Mon, 02 March 2009 02:53 Go to previous message
Michel Cadot
Messages: 57606
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Check if TNS_ADMIN is set.

Regards
Michel

[Updated on: Mon, 02 March 2009 02:56]

Report message to a moderator

Previous Topic: Oracle DB connection to iHistorian
Next Topic: TNS-12547: TNS:lost contact when using Microsoft loopback adapter
Goto Forum:
  


Current Time: Thu Apr 17 13:27:27 CDT 2014

Total time taken to generate the page: 0.06335 seconds