Home » RDBMS Server » Server Utilities » EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i (Developer Suite Form 10g, Oracle Database 11g, Windows2003 Server)
EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388780] Thu, 26 February 2009 03:38 Go to next message
m_golam_hossain
Messages: 86
Registered: August 2008
Location: Uttara, Dhaka, Bangladesh
Member

Hi,

I used to use:
 HOST('exp '||USR||'/'||PWD||'@'||CNSTR||' owner=xdata     grants=y file='||LTRIM(RTRIM(:drive))||
'\OraData\Exp\X'||dt_time||'xdata.dmp     log='||LTRIM(RTRIM(:drive))||'\OraData\Exp\X'||dt_time||'xdata.log') ;  

for Database Backup in Oracle 8i that worked fine. But, the same command is not functioning in Oracle 11g. Can anybody please tell me why?

Regards-

Mohd. Golam Hossain

[Updated on: Thu, 26 February 2009 05:27] by Moderator

Report message to a moderator

Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388793 is a reply to message #388780] Thu, 26 February 2009 04:18 Go to previous messageGo to next message
ThomasG
Messages: 3121
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
Don't report you own messages to get attention.

Also "IS NOT WORKING" is not an Oracle error message.

Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388796 is a reply to message #388793] Thu, 26 February 2009 04:25 Go to previous messageGo to next message
m_golam_hossain
Messages: 86
Registered: August 2008
Location: Uttara, Dhaka, Bangladesh
Member

Ok, I'll not again.

I meant by IS NOT WORKING that no data is exported into the dmp file, log file also empty.

Thank you for your kind attention.

Regards.
Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388798 is a reply to message #388780] Thu, 26 February 2009 04:26 Go to previous messageGo to next message
Michel Cadot
Messages: 59984
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
And export is NOT a backup tool.

Regards
Michel
Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388803 is a reply to message #388798] Thu, 26 February 2009 04:37 Go to previous messageGo to next message
ThomasG
Messages: 3121
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
So step one would be to just output the command in the script, not execute it.

Then run the command by itself, and see what errors it runs into.

Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388812 is a reply to message #388803] Thu, 26 February 2009 05:16 Go to previous messageGo to next message
m_golam_hossain
Messages: 86
Registered: August 2008
Location: Uttara, Dhaka, Bangladesh
Member

Yes, I have tried this. But for no use.

Would you please see the attached files.

Regards.
  • Attachment: TEMP.JPG
    (Size: 33.09KB, Downloaded 235 times)
Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388816 is a reply to message #388812] Thu, 26 February 2009 05:26 Go to previous messageGo to next message
Michel Cadot
Messages: 59984
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Don't post a screen copy, cope and paste it in text format.

Regards
Michel
Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388819 is a reply to message #388816] Thu, 26 February 2009 05:29 Go to previous messageGo to next message
m_golam_hossain
Messages: 86
Registered: August 2008
Location: Uttara, Dhaka, Bangladesh
Member

Thank you for your attention.


D:\>exp bizac/XYZ@GDNMTD owner=BizAc grants=y file=C:\TEMP\TEMP.DMP log=C:\TEMP\TEMP.LOG

Export: Release 9.0.1.5.1 - Production on Thu Feb 26 17:03:46 2009

(c) Copyright 2001 Oracle Corporation.  All rights reserved.


Connected to: Oracle Database 11g Enterprise Edition Release 11.1.0.6.0 - Production
With the Partitioning, OLAP, Data Mining and Real Application Testing options
Export done in WE8MSWIN1252 character set and AL16UTF16 NCHAR character set
D:\>


regards.
Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388820 is a reply to message #388819] Thu, 26 February 2009 05:30 Go to previous messageGo to next message
Michel Cadot
Messages: 59984
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
I doubt that a 9.0 client can connect a 11g server.

Regards
Michel
Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388823 is a reply to message #388820] Thu, 26 February 2009 05:35 Go to previous messageGo to next message
m_golam_hossain
Messages: 86
Registered: August 2008
Location: Uttara, Dhaka, Bangladesh
Member

Yes.

Export: Release 9.0.1.5.1 did not connect to oracle 11g.

But,
Export: Release 11.1.0.6.0 worked fine.

Thank you with best regards.

[Updated on: Thu, 26 February 2009 05:53]

Report message to a moderator

Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388864 is a reply to message #388823] Thu, 26 February 2009 07:50 Go to previous messageGo to next message
shekharnegi12
Messages: 52
Registered: October 2008
Member
Morning Fellas,

Correct me if I'm wrong but don't he need to use the expdp utility for exporting the data.

Thanks,
Shekhar
Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #388875 is a reply to message #388864] Thu, 26 February 2009 08:09 Go to previous messageGo to next message
m_golam_hossain
Messages: 86
Registered: August 2008
Location: Uttara, Dhaka, Bangladesh
Member

It is Ok to use advanced EXPDP. I needed EXP for backward compatibility.

Thanks.
Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #475122 is a reply to message #388780] Mon, 13 September 2010 02:47 Go to previous messageGo to next message
cleany
Messages: 2
Registered: September 2010
Location: Netherlands
Junior Member
I know this is old, but I've got the same problem.

Is there a structural solution for this?

[Updated on: Mon, 13 September 2010 02:47]

Report message to a moderator

Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #475126 is a reply to message #475122] Mon, 13 September 2010 04:00 Go to previous messageGo to next message
ThomasG
Messages: 3121
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
Yes, all solutions to the problems in this thread are already mentionend in this thread. Have you tried them?

Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #475128 is a reply to message #475126] Mon, 13 September 2010 04:03 Go to previous messageGo to next message
cleany
Messages: 2
Registered: September 2010
Location: Netherlands
Junior Member
no, because they're not actual solutions to my problem.

I have a 11g database, the customer has a 9i database, so I have to export my 11g database to 9i. I've got a client to do so, but it halts after the message that my export is done and blah blah without any (error) message.
Re: EXPORT COMMAND IS NOT WORKING IN 11G THAT WOULD IN 8i [message #475133 is a reply to message #475128] Mon, 13 September 2010 04:33 Go to previous message
ThomasG
Messages: 3121
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
Ah, so you have a completely different problem that was never actually mentioned in this thread.

A 9.2.0.8 export client (The LATEST patchset of release 9.2) might work against a 11g database, but only if the 11g database doesn't use any datatypes or other constructs that are not supported by 9i.

Does the ORACLE_HOME of your export client have the latest patchset? Does the 11i instance use any constructs that are not supported by Version 9?
Previous Topic: Trim date characters within sql loader
Next Topic: sqlldr caused error with 00h symbol in source file
Goto Forum:
  


Current Time: Thu Dec 18 13:42:46 CST 2014

Total time taken to generate the page: 0.08760 seconds