Home » Other » General » Query Reporter Initialization error SQL*Net not properly installed... (Query Reporter 2.0.4.180, Oracle 102)
Query Reporter Initialization error SQL*Net not properly installed... [message #387527] Thu, 19 February 2009 15:26 Go to next message
lcphilli
Messages: 6
Registered: February 2009
Junior Member
Just got a new laptop. Installed Query Reporter. Security is good, connections are otherwise being made.
Keep getting this pop-up box error after entering login info:
Initialization error
SQL*Net not properly Installed
OracleHomeKey: SORFWARE\ORACLE
OracleHomeDir:

Had numerous people-who-know-what-they're-doing take a look and can't figure out why I can't connect. Like it's not finding Oracle...?

Any ideas?
Thanks so much!

Lynn
Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387529 is a reply to message #387527] Thu, 19 February 2009 15:37 Go to previous messageGo to next message
Anne Simms
Messages: 163
Registered: May 2002
Location: San Francisco, CA
Senior Member
Hi,

I had this problem before. It depends on what oracle client you are installing. I just removed the oracle client and installed it again. I'm using Oracle 10 g client.

Anne
Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387530 is a reply to message #387529] Thu, 19 February 2009 15:38 Go to previous messageGo to next message
lcphilli
Messages: 6
Registered: February 2009
Junior Member
That was also suggested, but not highly recommended just because of the time factor. Did it take a while to re-install?

Thanks for the quick response.
Lynn
Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387531 is a reply to message #387529] Thu, 19 February 2009 15:40 Go to previous messageGo to next message
Anne Simms
Messages: 163
Registered: May 2002
Location: San Francisco, CA
Senior Member
Another friend of mines recommended the following:

just go windows/start/run regedit HKEY_LOCAL_MACHINE/SOFTWARE
find Oracle entry, check All_Homes and HOME0 two entries inside, correct the path and group names.


Hope this helps!

Anne
Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387533 is a reply to message #387530] Thu, 19 February 2009 15:41 Go to previous messageGo to next message
Anne Simms
Messages: 163
Registered: May 2002
Location: San Francisco, CA
Senior Member
It took me about 30 mins max.

Anne

[Updated on: Thu, 19 February 2009 15:41]

Report message to a moderator

Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387534 is a reply to message #387531] Thu, 19 February 2009 15:45 Go to previous messageGo to next message
lcphilli
Messages: 6
Registered: February 2009
Junior Member
We did not see the HOME0 folder. What's in there, do you know?

Thanks.
Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387535 is a reply to message #387534] Thu, 19 February 2009 15:57 Go to previous messageGo to next message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
Oracle is in there. Probably. Depends on what you called your Oracle Home when you installed Oracle.

You did install Oracle, did you?

The client install takes about 5 minutes. You have a database on a server somewhere?
Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387537 is a reply to message #387535] Thu, 19 February 2009 16:03 Go to previous messageGo to next message
lcphilli
Messages: 6
Registered: February 2009
Junior Member
I personally did not install anything, but Oracle is on my machine and running for other things (Banner). One of our desktop support staff did the imaging.

Anywhere else I can look?
In the ORACLE folder I've got:
ALL_HOMES
ISQLPlus
+JInitiator
+KEY_OraHome102
OLEDB
+Workflow
Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387538 is a reply to message #387537] Thu, 19 February 2009 16:10 Go to previous messageGo to next message
Anne Simms
Messages: 163
Registered: May 2002
Location: San Francisco, CA
Senior Member
Look in the ALL_HOMES as well.

My re-install took up to 30 because I was doing other things, but ThomasG is right it only runs for like 5 mins.

Anne
Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387540 is a reply to message #387538] Thu, 19 February 2009 16:13 Go to previous messageGo to next message
lcphilli
Messages: 6
Registered: February 2009
Junior Member
ALL_HOMES has:
(Default) REG_SZ (value not set)
DEFAULT_HOME REG_SZ OraHome102
HOME_COUNTER REG_SZ 1
LAST_HOME REG_SZ 0
Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387542 is a reply to message #387540] Thu, 19 February 2009 16:42 Go to previous messageGo to next message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
There seems to be definitely stuff missing.

Can you start "sqlplus" from the command line?

If not, the client install is not complete, and the client needs to be (re)installed.
Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387764 is a reply to message #387540] Fri, 20 February 2009 08:51 Go to previous messageGo to next message
Anne Simms
Messages: 163
Registered: May 2002
Location: San Francisco, CA
Senior Member
Here is something else I found in another forum that someone suggested:


We have the same problem for PLSQL Developer. Some old keys these programs try to access are missing from Oracle 10g, so make a reg file like this:

(replace my installation name ORACLE_HOME with yours):
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE
"inst_loc"="C:
Program Files\\Oracle
Inventory"
"API"="D:\\oracle\\product\\10.1.0
db_1"

HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ALL_HOMES
"HOME_COUNTER"="1"
"DEFAULT_HOME"="HOME0"
"LAST_HOME"="0"

HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\ALL_HOMES\ID0
"NAME"="Oracle - ORACLE_HOME"
"PATH"="D:\oracle\product\10.1.0\db_1"
"NLS_LANG"="NA"

HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOME0
"ID"="0"
"ORACLE_GROUP_NAME"="Oracle - ORACLE_HOME"
"ORACLE_HOME_NAME"="ORACLE_HOME"
"ORACLE_HOME"="D:\\oracle\\product\\10.1.0
db_1"

Maybe just check it out and compare to yours.

Anne

[Updated on: Fri, 20 February 2009 10:17] by Moderator

Report message to a moderator

Re: Query Reporter Initialization error SQL*Net not properly installed... [message #387770 is a reply to message #387764] Fri, 20 February 2009 09:06 Go to previous message
lcphilli
Messages: 6
Registered: February 2009
Junior Member
A(nother) desktop support person started looking into this last night. He didn't think a re-install should be necessary. He sent me a link this morning, told me to click on it and I should be good to go(??) He was right Smile

Thanks for all your help. I wouldn't have pursued this any farther if it weren't for your responses. I really appreciate it.

Lynn
Previous Topic: Risks and limitations for testing SQL code
Next Topic: CASE STUDY
Goto Forum:
  


Current Time: Sat Dec 03 08:24:14 CST 2016

Total time taken to generate the page: 0.09945 seconds