Home » RDBMS Server » Enterprise Manager » EM Daemon is not running. (Oracle 10g)
EM Daemon is not running. [message #387225] Wed, 18 February 2009 05:56 Go to next message
ora_2007
Messages: 430
Registered: July 2007
Location: Mumbai
Senior Member
enctl is started but its status shows that EM Daemon is not running.
What does it mean?
And how can i reolve this error.

oracle@srv603484:~> emctl start dbconsole
TZ set to US/Pacific
Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright (c) 1996, 2005 Oracle Corporation.  All rights reserved.
http://srv603484:1158/em/console/aboutApplication
Starting Oracle Enterprise Manager 10g Database Control .... started.
------------------------------------------------------------------
Logs are generated in directory /home/oracle/product/10gR2/srv603484_orcl/sysman/log

oracle@srv603484:~> emctl status dbconsole
TZ set to US/Pacific
Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright (c) 1996, 2005 Oracle Corporation.  All rights reserved.
http://srv603484:1158/em/console/aboutApplication
EM Daemon is not running.
------------------------------------------------------------------
Logs are generated in directory /home/oracle/product/10gR2/srv603484_orcl/sysman/log
oracle@srv603484:~>


Thanks in advance.

[Updated on: Wed, 18 February 2009 06:02]

Report message to a moderator

Re: EM Daemon is not running. [message #402093 is a reply to message #387225] Thu, 07 May 2009 09:43 Go to previous messageGo to next message
mvrk
Messages: 5
Registered: May 2009
Location: Coimbra/Portugal
Junior Member
I've got the same problem in windows.

Enterprise Manager is running, i can access it and login through my browser, but it reports that the agent is not running.

C:\oracle\product\10.2.0\db_1\BIN>emctl status agent

Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright (c) 1996, 2005 Oracle Corporation. All rights reserved.
---------------------------------------------------------------
Agent is Not Running


C:\oracle\product\10.2.0\db_1\BIN>emctl status dbconsole

Oracle Enterprise Manager 10g Database Control Release 10.2.0.1.0
Copyright (c) 1996, 2005 Oracle Corporation. All rights reserved.
ttp://SERVER-HRS.tcare.local:1158/em/console/aboutApplication
EM Daemon is not running.
------------------------------------------------------------------
Logs are generated in directory C:\oracle\product\10.2.0\db_1/SERVER-HRS.tcare.l
ocal_hrs/sysman/log


And check the windows services and the service OracleDBConsolehrs is not running.

I try to start it it gives me error:

C:\oracle\product\10.2.0\db_1\BIN>net start OracleDBConsolehrs

The OracleDBConsolehrs service is starting..
The OracleDBConsolehrs service could not be started.

A service specific error occurred: 1.

More help is available by typing NET HELPMSG 3547.


The service command is C:\oracle\product\10.2.0\db_1\bin\nmesrvc.exe

I tried to run it also and i get this error:

C:\oracle\product\10.2.0\db_1\BIN>nmesrvc.exe
StartServiceCtrlDispatcher failed with err 1063.


In the log OracleDBConsolehrssrvc.log it get this:

-------------- [OracleDBConsolehrs] ------------
EMDROOT=C:\oracle\product\10.2.0\db_1
ORACLE_HOME=C:\oracle\product\10.2.0\db_1
EMDSTATE=C:\oracle\product\10.2.0\db_1\SERVER-HRS.tcare.local_hrs
CONSOLE_CFG=dbconsole
TRACE_LEVEL=16
TIMEOUT=15
05/07/09 13:14:55 Start pending...
05/07/09 13:14:55 Verifying dbconsole is not started already. Command line "C:\oracle\product\10.2.0\db_1\bin\emctl.bat" istatus dbconsole
05/07/09 13:14:58 dbconsole may already be running. termStatus=3


Can someone help please?

[Updated on: Thu, 07 May 2009 09:44]

Report message to a moderator

Re: EM Daemon is not running. [message #402128 is a reply to message #402093] Thu, 07 May 2009 13:25 Go to previous messageGo to next message
babuknb
Messages: 1731
Registered: December 2005
Location: NJ
Senior Member

Quote:
Logs are generated in directory /home/oracle/product/10gR2/srv603484_orcl/sysman/log
oracle@srv603484:~>


Can you check log..

Babu
Re: EM Daemon is not running. [message #583012 is a reply to message #387225] Wed, 24 April 2013 16:38 Go to previous messageGo to next message
its@tdcp.gop.pk
Messages: 2
Registered: April 2013
Location: Lahore, Pakistan
Junior Member

Re: Install Oracle 11gR2 Error?
Posted: Apr 24, 2013 2:20 PM in response to: Junaid in response to: Junaid
em_daemon_is_not_running , agent_is_not_running , em_internal_error , error_database_control , time_zone_problem [Edit]

Click to edit this message... Edit Click to report abuse... Click to reply to this thread Reply
AOA/Hello,

Dear All,

First of all thanks to all of those people who posted solutions in different forums on this issue as this helped me to solve this problem. One more thing, always read documentation and always check log files for error reports as Oracle is not too much interactive.

The Problem " Error Starting Database Control Please execute the following command(s) " faced at the end of installation of Oracle 10g / 11g is caused due to Time Zone Values in different files, tables and services of Oracle. Interestingly, these values do not change automatically with the change in OS time zone and you have to do it manually.

You also have to set some environment variables manually like ORACLE_UNQNAME, ORACLE_SID, ORACLE_HOSTNAME etc.

You also have to set machine name and IP in the hosts file if required so that EM finds the localhost.

127.0.0.1 localhost
127.0.0.1 computer name / hostname

PRAISE ORACLE FOR THIS

Following is the Solution which worked well for me.

Step 1: Go to dbhome > hostname_SID > Sysman > Config > open emd.properties in notepad and set the value agentTZRegion=+05:00 to the value of your timezone and click save. You can also do it using export and time zone reset commands.

Step 2: ALTER DATABASE SET TIME_ZONE='+05:00'; according to your time zone. You can check DB TIME Zone using " select dbtimezone from dual ; ".

Step 3: In step 2 if you get the error "ORA-30079: cannot alter database timezone when database has TIMESTAMP WITH
LOCAL TIME ZONE columns" then please FOLLOW following steps

SQL> select count (*) from dba_tab_columns
2 where data_type like 'TIMESTAMP%WITH LOCAL TIME ZONE' ;

COUNT(*)
1

In this case there is only one table. The owner and name can be determined by:

SQL> select owner, table_name from dba_tab_columns
2 where data_type like 'TIMESTAMP%WITH LOCAL TIME ZONE';

OWNER TABLE_NAME
------------------------------
OE ORDERS

SQL> desc oe.orders ;
Name Null? Type
-------- ORDER_ID NOT NULL NUMBER(12)
ORDER_DATE NOT NULL TIMESTAMP(6) WITH LOCAL TIME ZONE
ORDER_MODE VARCHAR2(Cool
CUSTOMER_ID NOT NULL NUMBER(6)
ORDER_STATUS NUMBER(2)
ORDER_TOTAL NUMBER(8,2)
SALES_REP_ID NUMBER(6)
PROMOTION_ID NUMBER(6)

This oe.orders is just a table in the example schema of OE so this colums can be dropped. So please dont install sample schemas if you dont need them.

SQL> alter table OE.ORDERS drop column ORDER_DATE ;

Table altered.

Now the Time Zone can be altered using above command.

Step 4: Also check the value of " SELECT SESSIONTIMEZONE FROM DUAL; " and if the value differs from os time zone, db time zone , emd.properties / agent time zone then also set it according to your timezone but I believe it always gives the OS time zone.

Step 5: Stop and Restart all Services and check that Oracle DBConsole service is running or not and if not running then start from command prompt " emctl start dbconsole" .

NOW THE ENTERPRISE MANAGER WILL WORK WELL BY THE GRACE OF ALMIGHTY ALLAH.

Regards,

Tauseef Ahmed
IT Specialist, TDCP

Edited by: 1002308 on Apr 24, 2013 2:22 PM
Re: EM Daemon is not running. [message #583032 is a reply to message #583012] Thu, 25 April 2013 00:50 Go to previous messageGo to next message
Littlefoot
Messages: 19687
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I have no idea whether you actually answered the question (as I don't use Enterprise Manager); I hope you did.

However, what a lousy copy/paste from OTN (which, I presume, you composed several hours ago). You could have omitted "Click to edit this message... Edit Click to report abuse... Click to reply to this thread Reply" rubbish.

Finally, thank you for the morning laughs (meaning, the last sentence you posted).
Re: EM Daemon is not running. [message #583067 is a reply to message #583032] Thu, 25 April 2013 05:40 Go to previous messageGo to next message
its@tdcp.gop.pk
Messages: 2
Registered: April 2013
Location: Lahore, Pakistan
Junior Member

Hello,

Its good that this post made you laugh.

Yes I copied it from different posts as all these posts helped me to solve the issue.

So I tried to arrange it, well sometimes when you are tired and do sleepy things, you get such response on forums.

Whatever, thanks for laughing at me.

Regards,

Tauseef Ahmed
Re: EM Daemon is not running. [message #583068 is a reply to message #583067] Thu, 25 April 2013 05:48 Go to previous message
Littlefoot
Messages: 19687
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I'm afraid you misunderstood what I was trying to say.

There's no problem in arranging your own solution based on information you find on the internet. I just said that, when you decided to copy/paste a message from OTN forum, you should have removed irrelevant parts of it. This:
You

Re: Install Oracle 11gR2 Error?
Posted: Apr 24, 2013 2:20 PM in response to: Junaid in response to: Junaid
em_daemon_is_not_running , agent_is_not_running , em_internal_error , error_database_control , time_zone_problem [Edit]

Click to edit this message... Edit Click to report abuse... Click to reply to this thread Reply

Besides, you didn't have to hurry - you could have posted this message, on OraFAQ forum, when you aren't that tired. This discussion is dead for 4 years now (the last message dates in 2009), so I guess that person who opened this topic could wait for another several hours.

Finally, I wasn't laughing at you but the way you ended your message. I'm not saying that this is wrong (or right) - I just found it humorous. No bad intentions from my side.
Previous Topic: OEM 12c - Compare period ADDM non-functional
Next Topic: deinstall issue
Goto Forum:
  


Current Time: Tue Oct 21 22:36:37 CDT 2014

Total time taken to generate the page: 0.08552 seconds