Home » Developer & Programmer » Forms » Deploy Forms 10g Application (merged)
Deploy Forms 10g Application (merged) [message #386036] Thu, 12 February 2009 05:10 Go to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Hi,

I am very new to Oracle 10g Forms and Reports, for learning purpose i have developed one application(Library Manangement System) and i want to make it available for the multiple users, that means my friends in the office wants to access the form, can anybody please let me know how do i deploy it.

These are the following things which i have, I dont have any application server, and i have installed everything in my machine only.

1. Oracle 10g Server ( Tables,Views..)

2. Oracle Forms Developer ( in which i wrote application)

3. I have OC4J ,which i use to run my form in web,

What other things i should need to deploy my application.

I use the following url,
http://ashokbl.cibersite-india.com:8889/forms/frmservlet to access my application, if my friends want to see the same application what do i need to do !

Regards,
Ashoka BL
Re: Deploy Forms 10g Application [message #386501 is a reply to message #386036] Sun, 15 February 2009 22:57 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Email them the link that you have posted and let them run the application via your PC.

David
Re: Deploy Forms 10g Application [message #386602 is a reply to message #386036] Mon, 16 February 2009 04:01 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Hi David,

Thanks for the reply,but its not working...I sent the URL to them, they are getting the blank screen thats it. Does users need to download any softwares( they have Internet Explorer).

Can i open multiple sessions as well ?

Regards,
Ashoka BL
Re: Deploy Forms 10g Application [message #386624 is a reply to message #386036] Mon, 16 February 2009 04:43 Go to previous messageGo to next message
sammydude
Messages: 34
Registered: November 2007
Member
It is possible that the port 8889 is blocked by the firewall in your friend's system.

Try this on the other system which is not opening the link.

Go to Programs = > Control Panel => Windows Firewall
Click Exceptions tab. Click Add Port. Enter any name. Enter port as 8889.
Click OK.
Launch link and check.

Regards,
Sam

[Updated on: Mon, 16 February 2009 04:44]

Report message to a moderator

Re: Deploy Forms 10g Application [message #386628 is a reply to message #386624] Mon, 16 February 2009 04:57 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

HI Sam,

Thanks for the information, but if i copy the URL (application URL->http://ashokbl.cibersite-india.com:8889/forms/frmservlet) and paste it in another browser, it wont work.

Is there any limitations as only one session should run.

I have everything in my own system ( OC4J,forms server,Oracle DB Server)

Regards,
Ashoka BL
Re: Deploy Forms 10g Application [message #386630 is a reply to message #386036] Mon, 16 February 2009 05:10 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Hi,

I was going through the following URL regarding the deployment of Oracle Forms Applications,

http://download.oracle.com/docs/cd/B12166_01/web/B10470_01/basics.htm

Deploying Your Application

To deploy a basic form with the default parameters set up by the installer:

1. Create your application in Forms Developer and save it.

.fmb is a design time file that can only be opened in Forms Developer. .fmx is the runtime file created when you compile the .fmb and is used for Web deployment.

2. Create a configuration section in the Forms Web Configuration page of Oracle Enterprise Manager Application Server Control so that Oracle Application Server Forms Services can access your application module.

I am stuck in the 2nd Point ( i didnt get what does it mean)

Do i need to have Oracle Enterprise manager application Server Control to deploy my application ?

Regards,
Ashoka BL
Re: Deploy Forms 10g Application [message #386632 is a reply to message #386036] Mon, 16 February 2009 05:34 Go to previous messageGo to next message
sammydude
Messages: 34
Registered: November 2007
Member
Yes. To access Oracle Enterprise Manager Application Server Control you can get the link from the following file.

%ORACLE_HOME%\install\setupinfo.txt

Regards,
Sam
Re: Deploy Forms 10g Application [message #386637 is a reply to message #386036] Mon, 16 February 2009 05:50 Go to previous messageGo to next message
sammydude
Messages: 34
Registered: November 2007
Member
I think you haven't installed Oracle Application Server yet.

Get it from the following link

http://www.oracle.com/technology/software/products/ias/htdocs/101202.html

Forms and Reports Services Standalone
http://download.oracle.com/otn/nt/ias/101202/as_windows_x86_forms_reports_101202.zip

Install this and you will get access to the console.

Regards
Sam

Re: Deploy Forms 10g Application [message #386943 is a reply to message #386036] Tue, 17 February 2009 05:44 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Sam,

When i was installing the files which u suggested, i am getting one warning message saying that the components wont be able to install in Windows XP, i have Windows XP Operating system.

Cant i install Oracle Enterprise Manager Application Server Control in Windows XP ?

Regards,
Ashoka BL
Re: Deploy Forms 10g Application [message #386979 is a reply to message #386943] Tue, 17 February 2009 07:58 Go to previous messageGo to next message
sammydude
Messages: 34
Registered: November 2007
Member
Yes. You can install it in Windows XP.

Regards,
Sam
Re: Deploy Forms 10g Application [message #387099 is a reply to message #386036] Tue, 17 February 2009 22:33 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Sam,

I have downloaded "as_windows_x86_forms_reports_101202.zip" from the specified location mentioned by you, when i run the Setup.exe file, it is giving me the following error,

"Oracle Application Server Forms and Reports Services is not certified for production use on Windows XP. After Clicking OK you can continue with this unsupported Installation,or click CANCEL in the main OUI window and end this installation and try it on a supported windows platform"

I have also installed Oracle Application Server Release 2 from "http://www.oracle.com/technology/software/products/ias/htdocs/101202.html". It got installed but when i try to open the Oracle Enterprise Manager->Application Server Control Console, i am not able to find FORMS in there, and also i believe that its not installed properly because the ICONS are not appearing correctly,(for eg..its not showing the correct ICON + for SQLPLUS).

Please help me here !!

I have attached the screenshot of the Application Server Console, may be its useful..

Regards,
Ashoka BL
Re: Deploy Forms 10g Application [message #387105 is a reply to message #386036] Tue, 17 February 2009 23:12 Go to previous messageGo to next message
sammydude
Messages: 34
Registered: November 2007
Member
Hi Ashok,

Some of the Application Server releases do not have forms services component. The install which you have done supports only J2EE components.
That's the reason why I had specifically mentioned the following link

Forms and Reports Services Standalone
http://download.oracle.com/otn/nt/ias/101202/as_windows_x86_forms_reports_101202.zip

There will not be any issues if you install this in Windows XP. It will just show a warning message.
So, go ahead and install the above App Server release. (Btw, before that go to Control Panel => Administrative tools => Services and stop all oracle app service related services and uninstall the existing application server)

Regards,
Sam
Re: Deploy Forms 10g Application [message #387122 is a reply to message #386036] Wed, 18 February 2009 00:17 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Thanks Sam,

I shall deinstall all, and try to reinstall and if i have any errors, then i will post !

Regards,
Ashoka BL
Re: Deploy Forms 10g Application [message #387138 is a reply to message #386036] Wed, 18 February 2009 00:44 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Sam,

I did reinstalled the file that you mentioned, but strangely i am not able to get the correct icons, and some of the files are not installed properly ( but while installing i got only one warning message which i mentioned in my previous posts.

However i am able to login to the enterprise manager console ( Please refer the screenshot). But FORMS is DISABLED(Please refer screenshot attached..).

Since we can attach one file here, i will post one more for the ICONS i was referring...

Regards,
Ashoka BL

Re: Deploy Forms 10g Application [message #387145 is a reply to message #386036] Wed, 18 February 2009 00:57 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Hi Sam,

There was some problem to upload the screenshot so created new.

**************************************************************
Sam,

I did reinstalled the file that you mentioned, but strangely i am not able to get the correct icons, and some of the files are not installed properly ( but while installing i got only one warning message which i mentioned in my previous posts.

However i am able to login to the enterprise manager console but FORMS is DISABLED.

I am not able to attach file here as well.... STRANGE !!!

Regards,
Ashoka BL

**************************************************************
Re: Deploy Forms 10g Application [message #387156 is a reply to message #387145] Wed, 18 February 2009 01:24 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Why can't you attach the file? How did you do that? Did you "Choose" the file in the "File Attachments" section of the post form, "Upload File" and - possibly - "Insert image into message body"?

./fa/5742/0/
Re: Deploy Forms 10g Application (merged) [message #387157 is a reply to message #386036] Wed, 18 February 2009 01:31 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

I just chose BROWSE->Chose my file from desktop and pressed UPLOAD FILE, that's it...

This topic is already have one attachement in my previous posts,,,,is it allowed only 1 to a topic ?

Regards,
Ashoka BL
Re: Deploy Forms 10g Application (merged) [message #387174 is a reply to message #387157] Wed, 18 February 2009 03:06 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
As far as I can tell, no - number of attachments differ per message. Screenshot I attached belongs to some other forum, different from Forms (I have used it already and was too lazy to take another screenshot). Forms forum allows 100 attachments per message, maximum file size is 2MB.
Re: Deploy Forms 10g Application (merged) [message #387179 is a reply to message #386036] Wed, 18 February 2009 03:12 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Sam,

Please find the screenshot attached...

I believe if i wont be able to attach this time,then there must be problem here..because i do BROWSE-->UPLOAD FILE and it will wait for sometime and the file disappear from the textbox

Regards,
Ashoka BL
Re: Deploy Forms 10g Application (merged) [message #388229 is a reply to message #386036] Mon, 23 February 2009 23:35 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Hi,

I am still unable to deploy my Forms application,

Could you please let me know the steps required to Deploy the application.

I have installed the Oracle Application Server EnterPrise Console on my Windows XP machine,

My Previous Message

Quote:

Sam,

I did reinstalled the file that you mentioned, but strangely i am not able to get the correct icons, and some of the files are not installed properly ( but while installing i got only one warning message which i mentioned in my previous posts.

However i am able to login to the enterprise manager console ( Please refer the screenshot). But FORMS is DISABLED(Please refer screenshot attached..).

Since we can attach one file here, i will post one more for the ICONS i was referring...

Regards,
Ashoka BL


  • Attachment: Scren1.PNG
    (Size: 127.68KB, Downloaded 274 times)
Re: Deploy Forms 10g Application (merged) [message #388230 is a reply to message #386036] Mon, 23 February 2009 23:42 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Hi,

Please find one more ScreenShot, which i took from which you can determine about the ICONS i was referring.

./fa/5781/0/

Regards,
Ashoka BL
Bengaluru
  • Attachment: screen2.PNG
    (Size: 49.78KB, Downloaded 3758 times)
Re: Deploy Forms 10g Application (merged) [message #388507 is a reply to message #388230] Wed, 25 February 2009 01:00 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Is the screen shot in the post above on a server or on a PC?

If a PC then get rid of the Application Server and just run the OC4J of the Develoepr Server.

David
Re: Deploy Forms 10g Application (merged) [message #388511 is a reply to message #386036] Wed, 25 February 2009 01:17 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

The screenshot is on a PC, actually i have all the servers(database and Forms) on my PC only, and i want the others to access,

With URL "http://ashokbl.cibersite-india.com:8889/forms/frmservlet" like this, they are unable to access,Thats why i downloaded the Application Server from
http://download.oracle.com/otn/nt/ias/101202/as_windows_x86_forms_reports_101202.zip.

Regards,
Ashoka BL
Bengaluru
Re: Deploy Forms 10g Application (merged) [message #388683 is a reply to message #386036] Wed, 25 February 2009 22:56 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Hi,

Please find the "formsweb.cfg" file below. Please let me know if i need to do any changes here.



Quote:

# $Id: formsweb.cfg 15-apr-2005.13:17:30 pkuhn Exp $
# formsweb.cfg defines parameter values used by the FormsServlet (frmservlet)
# This section defines the Default settings. Any of them may be overridden in the
# following Named Configuration sections. If they are not overridden, then the
# values here will be used.
# The default settings comprise two types of parameters: System parameters,
# which cannot be overridden in the URL, and User Parameters, which can.
# Parameters which are not marked as System parameters are User parameters.
# SYSTEM PARAMETERS
# -----------------
# These have fixed names and give information required by the Forms
# Servlet in order to function. They cannot be specified in the URL query
# string. But they can be overridden in a named configuration (see below).
# Some parameters specify file names: if the full path is not given,
# they are assumed to be in the same directory as this file. If a path
# is given, then it should be a physical path, not a URL.
# USER PARAMETERS
# ---------------
# These match variables (e.g. %form%) in the baseHTML file. Their values
# may be overridden by specifying them in the URL query string
# (e.g. "http://myhost.mydomain.com/forms/frmservlet?form=myform&width=700")
# or by overriding them in a specific, named configuration (see below)
[default]
# System parameter: default base HTML file
baseHTML=base.htm
# System parameter: base HTML file for use with JInitiator client
baseHTMLjinitiator=basejini.htm
# System parameter: base HTML file for use with Sun's Java Plug-In
baseHTMLjpi=basejpi.htm
# System parameter: delimiter for parameters in the base HTML files
HTMLdelimiter=%
# System parameter: working directory for Forms runtime processes
# WorkingDirectory defaults to <oracle_home>/forms if unset.
workingDirectory=
# System parameter: file setting environment variables for the Forms runtime processes
envFile=default.env

# Forms runtime argument: whether to escape certain special characters
# in values extracted from the URL for other runtime arguments
escapeparams=true
# Forms runtime argument: which form module to run
#form=test.fmx
form=lms_temp.fmx
# Forms runtime argument: database connection details
userid=
# Forms runtime argument: whether to run in debug mode
debug=no
# Forms runtime argument: host for debugging
host=
# Forms runtime argument: port for debugging
port=
# Other Forms runtime arguments: grouped together as one parameter.
# These settings support running and debugging a form from the Builder:
otherparams=buffer_records=%buffer% debug_messages=%debug_messages% array=%array% obr=%obr% query_only=%query_only% quiet=%quiet% render=%render% record=%record% tracegroup=%tracegroup% log=%log% term=%term%
# Sub argument for otherparams
buffer=no
# Sub argument for otherparams
debug_messages=no
# Sub argument for otherparams
array=no
# Sub argument for otherparams
obr=no
# Sub argument for otherparams
query_only=no
# Sub argument for otherparams
quiet=yes
# Sub argument for otherparams
render=no
# Sub argument for otherparams
record=
# Sub argument for otherparams
tracegroup=
# Sub argument for otherparams
log=
# Sub argument for otherparams
term=

# HTML page title
pageTitle=Oracle Application Server Forms Services
# HTML attributes for the BODY tag
HTMLbodyAttrs=
# HTML to add before the form
HTMLbeforeForm=
# HTML to add after the form
HTMLafterForm=

# Forms applet parameter: URL path to Forms ListenerServlet
serverURL=/forms/lservlet
# Forms applet parameter
codebase=/forms/java
# Forms applet parameter
imageBase=DocumentBase
# Forms applet parameter
width=750
# Forms applet parameter
height=600
# Forms applet parameter
separateFrame=true
# Forms applet parameter
splashScreen=
# Forms applet parameter
background=
# Forms applet parameter
lookAndFeel=Oracle
# Forms applet parameter
colorScheme=teal
# Forms applet parameter
logo=
# Forms applet parameter
restrictedURLparams=HTMLbodyAttrs,HTMLbeforeForm,pageTitle,HTMLafterForm,log,allow_debug,allowNewConnections
# Forms applet parameter
formsMessageListener=
# Forms applet parameter
recordFileName=
# Forms applet parameter
serverApp=default
# Forms applet archive setting for JInitiator
archive_jini=frmall_jinit.jar
# Forms applet archive setting for other clients (Sun Java Plugin, Appletviewer, etc)
archive=frmall.jar
# Number of times client should retry if a network failure occurs. You should
# only change this after reading the documentation.
networkRetries=0

# Page displayed to Netscape users to allow them to download Oracle JInitiator.
# Oracle JInitiator is used with Windows clients.
# If you create your own page, you should set this parameter to point to it.
jinit_download_page=/forms/jinitiator/us/jinit_download.htm
# Parameter related to the version of JInitiator
jinit_classid=clsid:CAFECAFE-0013-0001-0022-ABCDEFABCDEF
# Parameter related to the version of JInitiator
jinit_exename=jinit.exe#Version=1,3,1,22
# Parameter related to the version of JInitiator
jinit_mimetype=application/x-jinit-applet;version=1.3.1.22

# Page displayed to users to allow them to download Sun's Java Plugin.
# Sun's Java Plugin is typically used for non-Windows clients.
# (NOTE: you should check this page and possibly change the settings)
jpi_download_page=http://java.sun.com/products/archive/j2se/1.4.2_06/index.html
# Parameter related to the version of the Java Plugin
jpi_classid=clsid:CAFEEFAC-0014-0002-0006-ABCDEFFEDCBA
# Parameter related to the version of the Java Plugin
jpi_codebase=http://java.sun.com/products/plugin/autodl/jinstall-1_4_2-windows-i586.cab#Version=1,4,2,06
# Parameter related to the version of the Java Plugin
jpi_mimetype=application/x-java-applet;jpi-version=1.4.2_06
# EM config parameter
# Set this to "1" to enable Enterprise Manager to track Forms processes
em_mode=0

# Single Sign-On OID configuration parameter
oid_formsid=%OID_FORMSID%
# Single Sign-On OID configuration parameter
oracle_home=F:\DevSuiteHome_1
# Single Sign-On OID configuration parameter
formsid_group_dn=%GROUP_DN%
# Single Sign-On OID configuration parameter: indicates whether we allow
# dynamic resource creation if the resource is not yet created in the OID.
ssoDynamicResourceCreate=true
# Single Sign-On parameter: URL to redirect to if ssoDynamicResourceCreate=false
ssoErrorUrl=
# Single Sign-On parameter: Cancel URL for the dynamic resource creation DAS page.
ssoCancelUrl=
# Single Sign-On parameter: indicates whether the url is protected in which
# case mod_osso will be given control for authentication or continue in
# the FormsServlet if not. It is false by default. Set it to true in an
# application-specific section to enable Single Sign-On for that application.
ssoMode=false
# The parameter allow_debug determines whether debugging is permitted.
# Administrators should set allow_debug to "true" if servlet
# debugging is required, or to provide access to the Forms Trace Xlate utility.
# Otherwise these activities will not be allowed (for security reasons).
allow_debug=false
# Parameter which determines whether new Forms sessions are allowed.
# This is also read by the Forms EM Overview page to show the
# current Forms status.
allowNewConnections=true

# EndUserMonitoring

# EndUserMonitoringEnabled parameter
# Indicates whether EUM/Chronos integration is enabled
EndUserMonitoringEnabled=

# EndUserMonitoringURL
# indicates where to record EUM/Chronos data
EndUserMonitoringURL=

# Example Named Configuration Section
# Example 1: configuration to run forms in a separate browser window with
# "generic" look and feel (include "config=sepwin" in the URL)
# You may define your own specific, named configurations (sets of parameters)
# by adding special sections as illustrated in the following examples.
# Note that you need only specify the parameters you want to change. The
# default values (defined above) will be used for all other parameters.
# Use of a specific configuration can be requested by including the text
# "config=<your_config_name>" in the query string of the URL used to run
# a form. For example, to use the sepwin configuration, your could issue
# a URL like "http://myhost.mydomain.com/forms/frmservlet?config=sepwin".
[sepwin]
separateFrame=True
lookandfeel=Generic

# Example Named Configuration Section
# Example 2: configuration forcing use of the Java Plugin in all cases (even if
# the client browser is on Windows)
[jpi]
baseHTMLJInitiator=basejpi.htm

# Example Named Configuration Section
# Example 3: configuration running the Forms ListenerServlet in debug mode
# (debug messages will be written to the servlet engine's log file).
[debug]
serverURL=/forms/lservlet/debug

# Sample configuration for deploying WebUtil. Note that WebUtil is shipped with
# DS but not AS and is also available for download from OTN.
[webutil]
WebUtilArchive=frmwebutil.jar,jacob.jar
WebUtilLogging=off
WebUtilLoggingDetail=normal
WebUtilErrorMode=Alert
WebUtilDispatchMonitorInterval=5
WebUtilTrustInternal=true
WebUtilMaxTransferSize=16384
baseHTMLjinitiator=webutiljini.htm
baseHTMLjpi=webutiljpi.htm
archive_jini=frmall_jinit.jar
archive=frmall.jar
lookAndFeel=oracle





Regards,
Ashoka BL
Bengaluru
Re: Deploy Forms 10g Application (merged) [message #388728 is a reply to message #388683] Thu, 26 February 2009 00:40 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Which 'formsweb.cfg'? The OC4J or AS?

I stand by my recommendation - Get rid of AS and just use DS on your PC.

David
Re: Deploy Forms 10g Application (merged) [message #388732 is a reply to message #386036] Thu, 26 February 2009 00:44 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

This is of OC4J,

Ya i am not at all using AS, but the other people if they want to call my application with the following URL,

http://ashokbl.cibersite-india.com:8889/forms/frmservlet

Are getting the "Page Cannot be displayed" error.

I checked the Ports
Quote:
Go to Programs = > Control Panel => Windows Firewall
Click Exceptions tab. Click Add Port. Enter any name. Enter port as 8889.
Click OK.
Launch link and check.



Even if they are not accessible my application, but i can access from my PC.

Regards,
Ashoka BL
Bengaluru

Re: Deploy Forms 10g Application (merged) [message #388737 is a reply to message #388732] Thu, 26 February 2009 00:55 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have a look at http://www.orafaq.com/forum/m/348802/67467/?srch=proxy+settings+internet+options#msg_348802

As your PC is NOT in the DNS I can only assume that they will have to add your PC to their list of exclusions.

For other people who have had similar problems search this forum for 'proxy settings internet options'.

David
Re: Deploy Forms 10g Application (merged) [message #388742 is a reply to message #386036] Thu, 26 February 2009 01:06 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

David,

I have visited the Link you suggested

Quote:
Under 'tools -> internet options -> Connections, LAN settings' do you still have the proxy turned off and your PCs address in the list of Exceptions?



I dont have anything there, not a single Checkbox is checked.

Quote:

As your PC is NOT in the DNS I can only assume that they will have to add your PC to their list of exclusions.



List of exclusions..Hmm by doing
Quote:

Go to Programs = > Control Panel => Windows Firewall
Click Exceptions tab. Click Add Port. Enter any name. Enter port as 8889.
Click OK.
Launch link and check.

??

Please suggest.

Regards,
Ashoka BL
Bengaluru
Re: Deploy Forms 10g Application (merged) [message #388985 is a reply to message #388742] Thu, 26 February 2009 21:20 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
If I had wanted you to change a port on the firewal I would have asked you to change a port on the firewall.

What I did ask you to do was look at a link in this forum, look at other similar ones, TURN ON YOUR BRAIN, and determine the SINGLE step needed to be performed to get from 'tools -> internet options -> Connections, LAN settings' and 'Exclusions' [my bad, it should be Exceptions but I consider that it is close enough].

Have a look, see if you can find the button to press to get to 'Exceptions' and then add your address to THEIR list.

David
Re: Deploy Forms 10g Application (merged) [message #389076 is a reply to message #388985] Fri, 27 February 2009 03:35 Go to previous messageGo to next message
ashoka_bl
Messages: 398
Registered: November 2006
Location: Bangalore
Senior Member

Hi David,

Thanks for the message,

Well..i did know about Lan Settings in Internet Explorer.

And when i said about this

Quote:

I dont have anything there, not a single Checkbox is checked.

I meant was i dont have anything called EXCEPTIONS here

Well...i have attached a screenshot of what it looks to me !!

Hope it helps.

Regards,
Ashoka BL
Bengaluru
  • Attachment: Screen.PNG
    (Size: 129.47KB, Downloaded 255 times)
Re: Deploy Forms 10g Application (merged) [message #389652 is a reply to message #389076] Tue, 03 March 2009 00:45 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Tick 'Proxy Server' and 'Bypass for local', press 'Advanced' and add your machine to the list.

David
Re: Deploy Forms 10g Application (merged) [message #399227 is a reply to message #389652] Tue, 21 April 2009 03:35 Go to previous messageGo to next message
alithegr8@gmail.com
Messages: 5
Registered: February 2009
Location: Saudi Arabia
Junior Member
Hi David,

I would like to know if Application Server is required to deploy forms on web. I have the same requirement, that is to make an application accessible by other users online.

Please clarify the usage of Application Server for this case.


Thank you.
Re: Deploy Forms 10g Application (merged) [message #399571 is a reply to message #399227] Thu, 23 April 2009 01:14 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
If it is this a production system then use AS, if you just need to run a demonstration for 3 or 4 people then use DS.

David
Re: Deploy Forms 10g Application (merged) [message #450527 is a reply to message #399571] Wed, 07 April 2010 13:18 Go to previous messageGo to next message
swsm1th
Messages: 1
Registered: April 2010
Location: Teacher
Junior Member
I have my APEX server installed and running; I am able to log into the admin window via port 7777. (apex 2.2) That's all I have done, except:

I have a little form built and compiled named "hello_world.fmx" that does about what you'd expect it to do. It runs fine locally.

I want to see apex give me my hello_world form... what do I do now?

In http(colen)//download.oracle.com/docs/cd/B13597_05/bf.904/b10470/basics.htm#i1010814

Under section: 3.2.1 Deploying Your Application

It says: "Create a configuration section in the Forms Web Configuration page of Oracle Enterprise Manager Application Server Control so that Oracle Application Server Forms Services can access your application module."

What is it talking about?

Smith
Re: Deploy Forms 10g Application (merged) [message #451348 is a reply to message #450527] Wed, 14 April 2010 02:25 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
In 'C:\DevSuiteHome_1\forms\server' the file 'formsweb.cfg' contains three sections containing 'Example Named Configuration'. Have a look at these and create a new one for yourself.

See http://www.oracle.com/technology/products/forms/pdf/10g/frm10gnewfeatures.pdf search for 'formsweb.cfg'.

David
Re: Deploy Forms 10g Application (merged) [message #603862 is a reply to message #451348] Fri, 20 December 2013 01:10 Go to previous message
rajamohankumar
Messages: 26
Registered: July 2011
Location: TAMIL NADU
Junior Member
Have you solved this problem?.I too had this problem.And I have been tied up with the last step of deploying.Other users cannot access the form in my network.I have tried all the post and topics about this issue over the web.But nothing helped me out.

Please help me.
Previous Topic: Forms runtime quits when Alt key button is pressed
Next Topic: difference "commit/commit_form"
Goto Forum:
  


Current Time: Fri Dec 09 10:02:00 CST 2016

Total time taken to generate the page: 0.07248 seconds