Home » Server Options » Data Guard » Archive log shipping not happening between Primary and Standby (oracle 10g,linux itanium)
Archive log shipping not happening between Primary and Standby [message #385015] Fri, 06 February 2009 03:10 Go to next message
arunshrish
Messages: 74
Registered: May 2008
Location: Chennai
Member
All,

I am getting this alert ,
Archive log shipping not happening between Primary and Standby of NDBA database. Below are the Thread(s) and Sequence(s) not yet shipped to Standby.


Thread# Sequence#
---------- ----------
2 4995
2 5038
2 5039
2 5094
2 5095
2 5096
1 7492
2 5097
2 5098
1 7493
2 5099
2 5100
1 7494
2 5102
2 5101
2 5103
2 5104
1 7495
2 5105
1 7496
2 5106
1 7497
2 5107
2 5108
2 5109
1 7498
2 5110
1 7499
1 7500
1 7501
2 5111
1 7502
1 7503
2 5112
1 7504
2 5113

36 rows selected.


But if I check archive gap it shows ,

PROCESS STATUS THREAD# GROUP# SEQUENCE#
---------- --------------- ------- ---------------------------------------- ---------
ARCH CLOSING 2 28 5501
ARCH CLOSING 1 22 7887
MRP0 WAIT_FOR_LOG 1 N/A 7888
RFS IDLE 0 N/A 0
RFS IDLE 0 N/A 0
RFS IDLE 2 7 5502
RFS IDLE 1 3 7888

7 rows selected.

SQL>
SQL> select * from v$archive_gap ;

no rows selected

I am not clear why this alert comes eventhough no archivegap is found.Pls help.

Thanks,
Arun
Re: Archive log shipping not happening between Primary and Standby [message #386434 is a reply to message #385015] Sat, 14 February 2009 20:31 Go to previous messageGo to next message
trantuananh24hg
Messages: 668
Registered: January 2007
Location: Ha Noi, Viet Nam
Senior Member
Post some information in alert_log file (I think you've got some error info in it) here.
Re: Archive log shipping not happening between Primary and Standby [message #641098 is a reply to message #385015] Mon, 10 August 2015 09:32 Go to previous messageGo to next message
prashanthgs
Messages: 89
Registered: May 2005
Location: chennai
Member
Hi,

Thanks for your reply. there is no error in the standby alert log. Below is my standby alert log file of the applying node.

####
Reconfiguration complete
Parallel Media Recovery started with 32 slaves
Waiting for all non-current ORLs to be archived...
All non-current ORLs have been archived.
Mon Aug 10 08:30:56 2015
Media Recovery Waiting for thread 1 sequence 1063
#####

Its waiting for thread 1 sequence 1063. If I transfer this manually from primary, it starts applying and then it will wait for next sequence (1064).

Thanks
vel
Re: Archive log shipping not happening between Primary and Standby [message #644654 is a reply to message #641098] Thu, 12 November 2015 00:47 Go to previous message
trantuananh24hg
Messages: 668
Registered: January 2007
Location: Ha Noi, Viet Nam
Senior Member
Waitting a sequence number in Standby means that this is from Primary does not switch to archive log

Use my script to check the log applied in your Standby

Prompt -- Display the log entries in alert log according to Physical Standby Synch
SELECT MESSAGE FROM V$DATAGUARD_STATUS;
Prompt -- Press any key to continue
Pause

Prompt -- Verify background process
SELECT PROCESS, STATUS, THREAD#, SEQUENCE#, BLOCK#, BLOCKS FROM V$MANAGED_STANDBY;
Prompt -- Press any key to continue
Pause

Prompt -- Verify the applied log 

SELECT ARCH.THREAD# "Thread", ARCH.SEQUENCE# "Last Sequence Received", APPL.SEQUENCE# "Last Sequence Applied", (ARCH.SEQUENCE# - APPL.SEQUENCE#) "Difference"
FROM
(SELECT THREAD# ,SEQUENCE# FROM V$ARCHIVED_LOG WHERE (THREAD#,FIRST_TIME ) IN (SELECT THREAD#,MAX(FIRST_TIME) FROM V$ARCHIVED_LOG GROUP BY THREAD#)) ARCH,
(SELECT THREAD# ,SEQUENCE# FROM V$LOG_HISTORY WHERE (THREAD#,FIRST_TIME ) IN (SELECT THREAD#,MAX(FIRST_TIME) FROM V$LOG_HISTORY GROUP BY THREAD#)) APPL
WHERE
ARCH.THREAD# = APPL.THREAD#
ORDER BY 1;
Previous Topic: Introduction & Installation about Data Guard
Next Topic: Client connections slow in failover situation
Goto Forum:
  


Current Time: Sun Dec 04 10:46:07 CST 2016

Total time taken to generate the page: 0.04052 seconds