Home » RDBMS Server » Security » ORA-01017: invalid username/password, depending on db (Oracle 10g)
ORA-01017: invalid username/password, depending on db [message #384256] Tue, 03 February 2009 00:47 Go to next message
filiprus
Messages: 9
Registered: February 2009
Location: Singapore
Junior Member
Hi there,

I've spent a few days looking for an answer on the internet, so although this may seem like a simple query, please do not accuse me of taking the easy way out by posting here.

Apart from the main database "orcl", I've created a second one called "devel". I've also created a user "testusr".

The problem is the following:

sqlplus testusr/testusr@orcl

works fine

sqlplus testusr/testusr@devel

gives me ORA-01017: invalid username/password; logon denied

1) I really don't see any security setting that gives testusr access in particular to devel, and don't see why the credentials would not be the same

2) I don't think the bad login attempt is logged anywhere, excep twhen I turn audit on - which I did - but it still doesn't help me further as it just stores the error code (1017).

SO the question is, why does "sqlplus testusr/testusr@devel" not work?

Your help will be greatly appreciated.

Regards,

FR
Re: ORA-01017: invalid username/password, depending on db [message #384265 is a reply to message #384256] Tue, 03 February 2009 01:03 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Without knowing your setup (that is copy and paste what you did as we can see it) we can't answer.

Regards
Michel
Re: ORA-01017: invalid username/password, depending on db [message #384271 is a reply to message #384265] Tue, 03 February 2009 01:38 Go to previous messageGo to next message
filiprus
Messages: 9
Registered: February 2009
Location: Singapore
Junior Member
Hey Michel,

I don't have my tnsnames and other config files with me right now.

But the bottom line is that with the same user credentials I can login to @orcl, and I can not to @devel (get invalid user/password). Why would there ever be a difference in user access between databases? Where is this controlled or what else could be wrong here?

Thanks,

FR
Re: ORA-01017: invalid username/password, depending on db [message #384278 is a reply to message #384271] Tue, 03 February 2009 01:57 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Same answer, copy and paste what you did.

Regards
Michel
Re: ORA-01017: invalid username/password, depending on db [message #384280 is a reply to message #384278] Tue, 03 February 2009 02:17 Go to previous messageGo to next message
filiprus
Messages: 9
Registered: February 2009
Location: Singapore
Junior Member
What is it that you'd like to know in particular?

I do

sqlplus testusr/testusr@orcl

and get login ok

I do

sqlplus testusr/testusr@devel

and get

gives me ORA-01017: invalid username/password; logon denied
Re: ORA-01017: invalid username/password, depending on db [message #384285 is a reply to message #384280] Tue, 03 February 2009 02:38 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
If I execute the same on my system I get the same error for both statements.

Regards
Michel
Re: ORA-01017: invalid username/password, depending on db [message #384289 is a reply to message #384256] Tue, 03 February 2009 02:59 Go to previous messageGo to next message
filiprus
Messages: 9
Registered: February 2009
Location: Singapore
Junior Member
Ok, thanks Michel.

Can anyone else help with this?

I think I explained the problem quite well. User crednetials work on ORCL database but not on another db - both running on the same server obviously.

From what I understand there is only one user/pass table, which is used for authentications for all databases. In this case something else appears to be different. Any ideas?


Thanks,

FR
Re: ORA-01017: invalid username/password, depending on db [message #384302 is a reply to message #384289] Tue, 03 February 2009 03:23 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
I think I explained the problem quite well.

NO! You MUST copy and paste what you did in order to us to see it and maybe reproduce it.

Hello Doc, I'm sick, it is painful when I put a finger on my belly. What's wrong?

Regards
Michel
Re: ORA-01017: invalid username/password, depending on db [message #384330 is a reply to message #384302] Tue, 03 February 2009 05:58 Go to previous messageGo to next message
filiprus
Messages: 9
Registered: February 2009
Location: Singapore
Junior Member
Michel, if you can't help that's ok, just don't answer any more. Thank You.
Re: ORA-01017: invalid username/password, depending on db [message #384332 is a reply to message #384330] Tue, 03 February 2009 06:03 Go to previous message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
What I am trying to say is with what you posted NOONE can answer.
If you don't want to provide the information necessary to help you, why do you post?

Regards
Michel
Previous Topic: Can we retrieve Password?
Next Topic: problem with auditing
Goto Forum:
  


Current Time: Sat Dec 03 01:15:57 CST 2016

Total time taken to generate the page: 0.28477 seconds