Home » RDBMS Server » Networking and Gateways » sqlnet.recv_timeout parameter (oracle 10.2.0.3 on hp-ux pa-risc 64 bit)
sqlnet.recv_timeout parameter [message #384132] Mon, 02 February 2009 04:43 Go to next message
seema.taunk
Messages: 96
Registered: October 2006
Member
Dear all,

We have set sqlnet.rev_timeout=1800 in our database . But still we are getting inactive sessions which are 3 days old.
Please guide.

Thanks,
Seema
Re: sqlnet.recv_timeout parameter [message #387467 is a reply to message #384132] Thu, 19 February 2009 05:54 Go to previous messageGo to next message
babuknb
Messages: 1729
Registered: December 2005
Location: NJ
Senior Member

Quote:
#sqlnet.connect_timeout = 5
########################
#
#Possible values: 0-any valid positive integer (in seconds)
#Default: 0
#Recommended value: 5 seconds (note: this is highly application dependent)
#
#Purpose: Indicates the time interval within which the database session
# establishment between a client and a server must be completed.
# If the client fails to establish a DB session within the given
# time period, then the server will shut down the connection.
# This can be used to counter Denial of Service attacks in
# which malicious clients may cause numberous servers to be spawn
# without DB sessions being fully established.
#
# A value of 0 turns off the timeout feature. If a spurious
# timeout error occurs (e.g. due to a slow network/system),
# reconfigure this parameter to a larger value.
#



Re: sqlnet.recv_timeout parameter [message #387474 is a reply to message #387467] Thu, 19 February 2009 06:29 Go to previous messageGo to next message
Michel Cadot
Messages: 58954
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
sqlnet.rev_timeout=1800
sqlnet.connect_timeout = 5

Are you sure they are the same one?

Regards
Michel

Re: sqlnet.recv_timeout parameter [message #387475 is a reply to message #384132] Thu, 19 February 2009 06:35 Go to previous messageGo to next message
Michel Cadot
Messages: 58954
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
You can use SQLNET.EXPIRE_TIME parameter.

Regards
Michel
Re: sqlnet.recv_timeout parameter [message #387486 is a reply to message #387475] Thu, 19 February 2009 07:59 Go to previous message
babuknb
Messages: 1729
Registered: December 2005
Location: NJ
Senior Member


Thanks Mr Michel,

Babu
Previous Topic: Extra characters in my column
Next Topic: enable encrypted password on listener.ora
Goto Forum:
  


Current Time: Mon Sep 01 14:48:59 CDT 2014

Total time taken to generate the page: 0.14634 seconds