Home » RDBMS Server » Server Administration » Problem when shutdown improperly (Oracle 10g,10.2.0.1.0 ,Windows Server 2003 enterprise)
icon5.gif  Problem when shutdown improperly [message #383945] Sat, 31 January 2009 23:03 Go to next message
pardxa
Messages: 11
Registered: January 2009
Junior Member
hi,
I have installed oracle 10g on my windows OS,and cut the power off accidently.when I reboot the system,the oracle can't bootup automaticly.If I login into Sqlplus,it will be:
C:\>sqlplus system/mypwd
SQL*Plus: Release 10.2.0.1.0 - Production on 星期日 2月 1 12:59:34 2009
Copyright (c) 1982, 2005, Oracle.  All rights reserved.
ERROR:
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist


so every time i had to do this:
c>sqlplus/nolog
 SQL>conn sys/mypwd as sysdba
 SQL>shutdown abort
 SQL>startup

then the database will work properlly.
How can I recover the oracle and make it boot automaticlly just as before?
Re: Problem when shutdown improperly [message #383949 is a reply to message #383945] Sun, 01 February 2009 00:01 Go to previous messageGo to next message
Michel Cadot
Messages: 64130
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Check the Windows service if it is in automtic startup.
Check registry in HKLM\Software\Oracle if database is set to startup when service starts.

Regards
Michel
Re: Problem when shutdown improperly [message #383953 is a reply to message #383949] Sun, 01 February 2009 00:47 Go to previous messageGo to next message
pardxa
Messages: 11
Registered: January 2009
Junior Member
thank you for reply.I have :
Checked the Windows service and it is in automtic startup.
and
Check registry in HKLM\Software\Oracle ,the database is set to startup when service starts:
Ora_dboracle_autostart is TRUE
I have changed nothing after problem come.
In fact,the oracle service looks start when system boots up,but the problem is still there.I guess the instance is running but database can't be mounted and openned automaticly.some one told me it is because the log files and the data/control files are not synchronized.and i do nothing (never add/update table/records) after the accident.So How can I make them recovered as synchronized?
Re: Problem when shutdown improperly [message #383957 is a reply to message #383953] Sun, 01 February 2009 01:08 Go to previous messageGo to next message
Michel Cadot
Messages: 64130
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
If there was a syncronization problem you could not restart the database anyway but you said:
Quote:
then the database will work properlly

Check alert.log.
Shutdown and restart cleanly the database then the server and see if it happens again.

Regards
Michel
Re: Problem when shutdown improperly [message #383961 is a reply to message #383945] Sun, 01 February 2009 01:34 Go to previous messageGo to next message
pardxa
Messages: 11
Registered: January 2009
Junior Member
I have done the following:
>restart my PC;
>IN CONCOLE WINDOW:c:>sqlplus system/mypwd
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
>IN CONCOL WINDOW:c:>sqlplus sys/mypwd as sysdba
>SQL>shutdown immediate
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
>SQL>shutdown abort
>SQL>startup
>SQL>select * from tab;
---//IT NOW WORKS WELL WHEN TEST
>restart my PC;
>IN CONCOLE WINDOW:c:>sqlplus system/mypwd
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
---//THE PROBLEM IS STILL THERE!!!!

I have checked the alert file,seems nothing wrong?I attached it.
do I have to startup oracle manully?

Re: Problem when shutdown improperly [message #383963 is a reply to message #383961] Sun, 01 February 2009 02:05 Go to previous messageGo to next message
Michel Cadot
Messages: 64130
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Shutdown the database with "shutdown immediate".
Shutdownn the service.
Drop and recreate the sevvice with oradim.
Restart.

Regards
Michel
Re: Problem when shutdown improperly [message #383987 is a reply to message #383963] Sun, 01 February 2009 06:59 Go to previous messageGo to next message
pardxa
Messages: 11
Registered: January 2009
Junior Member
thanks a lot.I had tried several times. but just didn't work:
shutdown immediate first
then
c:>oradim -SHUTDOWN -SID mydb -SYSPWD pardxa -SHUTTYPE srvc -SHUTMODE immediate
c:>oradim -DELETE -SID mydb
c:>oradim -NEW -SID mydb -SYSPWD pard -STARTMODE auto -SRVCSTART system -PFILE C:\oracle\product\10.2.0\admin\mydb\pfile\init.ora.030200902121 -SHUTMODE normal

and restart PC
----------------
the problem is still there!SAME PROBLEM!!
Confused Confused Confused
Re: Problem when shutdown improperly [message #383998 is a reply to message #383987] Sun, 01 February 2009 08:33 Go to previous messageGo to next message
Michel Cadot
Messages: 64130
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
alert.log is for "dboracle", your commands are for "mydb" => wrong service.

Regards
Michel
Re: Problem when shutdown improperly [message #384001 is a reply to message #383945] Sun, 01 February 2009 09:05 Go to previous messageGo to next message
pardxa
Messages: 11
Registered: January 2009
Junior Member
Sorry for not explained clearly.
I installed two oracle 10g(same version) on two virtual machines(Virtual Box)(same OS:windows server 2003 EM R2).they both works well before.But there are some bugs in Virtual Box:if to do something,the windows will be shut down on virtual machines.
so 2 oracle have same Error just as I mentioned above.
on one machine SID is DBORACLE,other is MYDB.
there is no wrong operation.

So any other possibility it would be?
Re: Problem when shutdown improperly [message #384137 is a reply to message #384001] Mon, 02 February 2009 05:14 Go to previous messageGo to next message
halim
Messages: 100
Registered: September 2008
Senior Member

ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist

if this is exist
You can try
1.first shutdown your database
2.then rename the spfile (not readable by db)
3.then startup the database with pfile
4.then create another new spfile

regards
Abdul Halim


Re: Problem when shutdown improperly [message #384155 is a reply to message #384137] Mon, 02 February 2009 06:33 Go to previous messageGo to next message
pardxa
Messages: 11
Registered: January 2009
Junior Member
thank you for the reply.but there are two points I should make clear before test your method:
1>my pfile is in "C:\oracle\product\10.2.0\db_1\database\initmydb.ora" and the contents in it is :
SPFILE='C:\oracle\product\10.2.0\db_1/dbs/spfilemydb.ora'
so if I change the spfilemydb.ora's name,the oracle wouldn't bootup!How can I copy the contents from spfile to pfile?and changed the boot parameter file to pfile?
2>How to create another new spfile?give me more details please.
thanks again.
Re: Problem when shutdown improperly [message #384258 is a reply to message #383945] Tue, 03 February 2009 00:52 Go to previous messageGo to next message
pardxa
Messages: 11
Registered: January 2009
Junior Member
Got an answer to this error,but not a good solution:
1>If you add environment variables:
ORACLE_SID
ORACLE_HOME

2>give a patch of oracle10gR2 10.2.0.2.0.(because my version is 10.2.0.1.0)

the error disapeared!!!
Re: Problem when shutdown improperly [message #384519 is a reply to message #384258] Wed, 04 February 2009 03:18 Go to previous messageGo to next message
halim
Messages: 100
Registered: September 2008
Senior Member



> CREATE pfile=<location_and_pfile_name> FROM spfile <spfile_name> ;

> shutdown immediate

> Rename the spfile name with OS command

> startup pfile=<location_and_pfile_name>;--new pfile

> CREATE spfile FROM pfile=<spfile_name>;

[Updated on: Wed, 04 February 2009 03:23]

Report message to a moderator

Re: Problem when shutdown improperly [message #384682 is a reply to message #384519] Wed, 04 February 2009 19:38 Go to previous messageGo to next message
pardxa
Messages: 11
Registered: January 2009
Junior Member
Doesn't work.I have had give a try.exactly following what you told me.
Thanks any way!
Re: Problem when shutdown improperly [message #384684 is a reply to message #383945] Wed, 04 February 2009 20:33 Go to previous messageGo to next message
BlackSwan
Messages: 25042
Registered: January 2009
Location: SoCal
Senior Member
You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/
So we can help you

>Doesn't work.
100% worthless statement.

My scooter doesn't work.
Tell me how to make my scooter go.


Re: Problem when shutdown improperly [message #384686 is a reply to message #384684] Wed, 04 February 2009 20:53 Go to previous messageGo to next message
pardxa
Messages: 11
Registered: January 2009
Junior Member
BlackSwan wrote on Wed, 04 February 2009 20:33
You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/
So we can help you

>Doesn't work.
100% worthless statement.

My scooter doesn't work.
Tell me how to make my scooter go.




what I mean is his method doesn't work
Re: Problem when shutdown improperly [message #384687 is a reply to message #383945] Wed, 04 February 2009 21:03 Go to previous messageGo to next message
BlackSwan
Messages: 25042
Registered: January 2009
Location: SoCal
Senior Member
Tell me how to make my scooter go & then I'll solve your problem.

You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/
So we can help you

>what I mean is his method doesn't work
claiming "doesn't work" provides NO, NO, NO meaningful or useful information to determine what might be wrong or possible fix.

a gazillion possible causes can be why it "doesn't work".
Since you provide us no useful information, you are free to solve this on your own.

>I installed two oracle 10g(same version) on two virtual machines(Virtual Box)(same OS:windows server 2003 EM R2)
I suspect that the cause is related OS misconfiguration.

[Updated on: Wed, 04 February 2009 21:14]

Report message to a moderator

Re: Problem when shutdown improperly [message #384689 is a reply to message #384687] Wed, 04 February 2009 21:22 Go to previous messageGo to next message
pardxa
Messages: 11
Registered: January 2009
Junior Member
I hate just guess.Is there any log to record the everytime bootup process and results in oracle 10g for windows?So I can make a check.
Re: Problem when shutdown improperly [message #384699 is a reply to message #383945] Wed, 04 February 2009 22:13 Go to previous messageGo to next message
BlackSwan
Messages: 25042
Registered: January 2009
Location: SoCal
Senior Member
>Is there any log to record the everytime bootup process and results in oracle 10g for windows?
it depends upon what you mean by "bootup process".
Re: Problem when shutdown improperly [message #385087 is a reply to message #384689] Fri, 06 February 2009 06:40 Go to previous message
JRowbottom
Messages: 5933
Registered: June 2006
Location: Sunny North Yorkshire, ho...
Senior Member
Try looking at the Event Viewer
(Start > Control Panel > Administrative Tools > Event Viewer)

That provides a lot of useful information about what happens during the boot up process.
Previous Topic: Discrepancy between NLS_RDBMS_VERSION and DBA_REGISTRY (merged)
Next Topic: inactive sessions
Goto Forum:
  


Current Time: Wed Dec 07 07:07:00 CST 2016

Total time taken to generate the page: 0.08719 seconds