Home » RDBMS Server » Server Administration » OPatch error (Oracle 10g R2,Linux AS4)
OPatch error [message #382854] Sun, 25 January 2009 22:03 Go to next message
rsreddy28
Messages: 295
Registered: May 2007
Senior Member
Hello All,

I'm trying to the apply the CPUJAN2009 patches. But when I'm doing that I'm getting error as error code - 73.
I gave as :

"bash-3.00$ ./opatch napply -skip_subset -skip_duplicate
Invoking OPatch 10.2.0.3.0

Oracle interim Patch Installer version 10.2.0.3.0
Copyright (c) 2005, Oracle Corporation. All rights reserved..

Syntax Error... Unrecognized Command or Option: failed to parse arguments "unknown option '-skip_subset'"
Please use the option 'opatch -help' to get correct syntax

OPatch failed with error code 14"

Then I also gave as :

bash-3.00$ ./opatch apply
Invoking OPatch 10.2.0.3.0

Oracle interim Patch Installer version 10.2.0.3.0
Copyright (c) 2005, Oracle Corporation. All rights reserved..


Oracle Home : /opt/oracle/db
Central Inventory : /opt/oracle/oraInventory
from : /etc/oraInst.loc
OPatch version : 10.2.0.3.0
OUI version : 10.2.0.3.0
OUI location : /opt/oracle/db/oui
Log file location : /opt/oracle/db/cfgtoollogs/opatch/opatch2009-01-25_22-51-42PM.log

Failed to load the patch object. Possible causes are:
The specified path is not an interim Patch shiphome
Meta-data files are missing from the patch area
Patch location = /opt/oracle/db/OPatch
Details = PatchObject constructor: Input file "/opt/oracle/db/OPatch/etc/config/actions" or "/opt/oracle/db/OPatch/etc/config/inventory" does not exist.

ApplySession failed: PatchObject constructor: Input file "/opt/oracle/db/OPatch/etc/config/actions" or "/opt/oracle/db/OPatch/etc/config/inventory" does not exist.
System intact, OPatch will not attempt to restore the system

OPatch failed with error code 73
.

I'm in the path :
bash-3.00$ pwd
/opt/oracle/db/OPatch

I also tried to run it from the location outside the OPatch location where I unzipped it
bash-3.00$ pwd
/opt/oracle/db/7592354/7592354,
but still I'm getting as
bash-3.00$ ./opatch napply -skip_subset -skip_duplicate
bash: ./opatch: No such file or directory



Can somebody help me as I'm unable to fix this out.

Regards,
Raj

Re: OPatch error [message #382855 is a reply to message #382854] Sun, 25 January 2009 22:07 Go to previous messageGo to next message
BlackSwan
Messages: 25041
Registered: January 2009
Location: SoCal
Senior Member
>Can somebody help me as I'm unable to fix this out.
Too bad GOOGLE is broken for you.

Results 1 - 10 of about 643 for oracle OPatch failed with error code 73.

Please wait patiently for repairs to be completed.
Additional details will be posted as they become available.
Re: OPatch error [message #382860 is a reply to message #382855] Sun, 25 January 2009 22:53 Go to previous messageGo to next message
rsreddy28
Messages: 295
Registered: May 2007
Senior Member
Hi ,

Now I'm getting a new error as :

$ ./opatch napply -skip_subset -skip_duplicate
Exception in thread "main" java.lang.NoClassDefFoundError: oracle/opatch/OPatch


Please help me out.

Regards,
Raj
Re: OPatch error [message #382873 is a reply to message #382854] Mon, 26 January 2009 00:22 Go to previous messageGo to next message
BlackSwan
Messages: 25041
Registered: January 2009
Location: SoCal
Senior Member
>Please help me out.
You need to be smarter than the software you are (ab)using.
Are you smarter?
Re: OPatch error [message #382897 is a reply to message #382873] Mon, 26 January 2009 03:09 Go to previous messageGo to next message
rsreddy28
Messages: 295
Registered: May 2007
Senior Member
Hi,

I'm doing my patchwork for the first time on a Test box . And I'm just following the metalink doc.

And I have a small doubt , can we run the OPatch utility from the Putty utility . Because I'm running the Opatch from PUTTY.

$ ./opatch napply -skip_subset -skip_duplicate
Exception in thread "main" java.lang.NoClassDefFoundError: oracle/opatch/OPatch

OPatch failed with error code 1

Please help me out.

Regards,
Raj

[Updated on: Mon, 26 January 2009 23:01]

Report message to a moderator

Re: OPatch error [message #383001 is a reply to message #382897] Mon, 26 January 2009 23:40 Go to previous messageGo to next message
rsreddy28
Messages: 295
Registered: May 2007
Senior Member
Hi,

Can we run the Opatch utility from the Putty utility , because I'm running the OPatch from Putty.

$ ./opatch napply -skip_subset -skip_duplicate
Exception in thread "main" java.lang.NoClassDefFoundError: oracle/opatch/OPatch

OPatch failed with error code 1


I'm unable to figure what's the root cause for this problem. I checked google and metalink also , but unable to find out the root cause.
Please help me out.

Regards,
Raj
Re: OPatch error [message #383188 is a reply to message #383001] Tue, 27 January 2009 10:48 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Why are you using napply?
Are you patching multiple homes?
Did you configure your jre/jdk options?
Re: OPatch error [message #384023 is a reply to message #382854] Sun, 01 February 2009 21:38 Go to previous message
naveenmelbourne
Messages: 15
Registered: August 2007
Junior Member
Hi,
Upgrade your OPatch to 10.2.0.4 Version. Its always good to use
the lastes OPatch.
Search the metalink for Latest OPatch version.

Naveen
Previous Topic: table fragmentation
Next Topic: ora errors tables? (merged)
Goto Forum:
  


Current Time: Tue Dec 06 10:46:32 CST 2016

Total time taken to generate the page: 0.06523 seconds