Home » Developer & Programmer » Reports & Discoverer » Issue with Formula Column (11.5.8/Reports Builder)
Issue with Formula Column [message #382066] Tue, 20 January 2009 18:18 Go to next message
Danush
Messages: 8
Registered: December 2008
Junior Member
Hi

I am working on Printed Purchase Order Report. Has got multiple user parameters being passed to it:

- po_num_from
- po_num_to
- Fax/Email

This report when executed, based on the parameter value(Fax/Email), we provide Email or Fax, which will be used by RIGHTFAX to fax or email the PO's.

Now, my issue is, when providing range of PO's(Eg: 1 - 5), report executes successfully and email/fax sent. But the cover page in the fax displays the PO:1 for all the 5 PO's executed and same for the email where the subject says Process PO 1 for all 5 PO's. The attached PO's for email/fax for 5 PO's looks perfect.

It's just the issue with the Email Subject and Fax Cover

For this particular field, I am using a formula column and the issue might be it's executed just once or always picks the first value of the PO range provided.

The second issue is, when we have a single paged PO, output looks great, but when PO has multiple pages, the output fields shifts one line down, spoiling the alignment.

Please provide your thoughts on these issue.

Thank You in advance for all your concern and time.
Re: Issue with Formula Column [message #382092 is a reply to message #382066] Tue, 20 January 2009 23:25 Go to previous messageGo to next message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
How does formula's PL/SQL code look like? Where did you put that column? Is it in a group (I'd say it should be), or is it a report-level formula column?
Re: Issue with Formula Column [message #382248 is a reply to message #382092] Wed, 21 January 2009 08:53 Go to previous message
Danush
Messages: 8
Registered: December 2008
Junior Member
Thank You for the quick response.

The column is in a group.

Since it's a printed purchase order report, here is my expectation:

Example:

Parameters:
PO Ranges: 1-5
Fax/Email: Email

Output:

Since Email selected, PO's will be mailed to the person's email id. Since there are 5 PO's, 5 emails are to be sent out.

Way the output looks now:
- 5 Emails sent out to the email id of the person
- All 5 PO's match looks fine, except the multi-paged PO's alignment starting second page
- Issue is, the subject line for each PO email should say
'PROCESSING PO: 1', 'PROCESSING PO: 2' and so on.

But, it says 'PROCESSING PO: 1' for all the 5 PO's.


Previous Topic: Sub-queries in Discoverer - urgent!
Next Topic: Printed Purchase Order Report
Goto Forum:
  


Current Time: Sat Dec 10 16:47:46 CST 2016

Total time taken to generate the page: 0.09734 seconds