Home » Developer & Programmer » Warehouse Builder » RPE-01012: Cannot deploy to the target location because it is owned by a different runtime platform. (OWB 10.1.0.4.0, Sun Solaris)
RPE-01012: Cannot deploy to the target location because it is owned by a different runtime platform. [message #381050] Thu, 15 January 2009 00:18 Go to next message
madugular
Messages: 3
Registered: February 2008
Location: India
Junior Member
Confused

Hi,

When I am trying to deploy a mapping I am getting below error message.

RPE-01012: Cannot deploy to the target location because it is owned by a different runtime platform.

Based on information from this forum, I ran below query

select wb_rt_platform_repository from dual;

WB_RT_PLATFORM_REPOSITORY
----------------------------------------------------------------------------


This should give the runtime repository owner name. But I am getting null values. Can any one suggest me how to fix this?

owb version is 10.1.0.4.0. This is running on HP-UX vsadbr1 B.11.11 U 9000/800

Thanks and Advance.

Madugular

[Updated on: Thu, 15 January 2009 01:10]

Report message to a moderator

Re: RPE-01012: Cannot deploy to the target location because it is owned by a different runtime platf [message #381241 is a reply to message #381050] Fri, 16 January 2009 00:16 Go to previous messageGo to next message
madugular
Messages: 3
Registered: February 2008
Location: India
Junior Member
HI
I got the fix from oracle metalink site. The data in WB_RT_PLATFORM_PROPERTIES table in target schema were some how deleted.After inserting values into this table the mappings are successfully deployed. Here are the 3 rows

insert into <Target_schema>.WB_RT_PLATFORM_PROPERTIES values
(1,'property.RuntimePlatform.0.version','<owb_version>',0);

insert into <Target_schema>.WB_RT_PLATFORM_PROPERTIES values
(2,'property.RuntimePlatform.0.platform', 'FALSE' , 0);

insert into ODS_SBL_Sprint.WB_RT_PLATFORM_PROPERTIES values (3,'property.RuntimePlatform.0.platform_repository','<runtime_Repository_Owner>',0);
Re: RPE-01012: Cannot deploy to the target location because it is owned by a different runtime platf [message #487413 is a reply to message #381241] Sun, 26 December 2010 22:49 Go to previous message
swift_fahad
Messages: 1
Registered: December 2010
Location: Pakistan
Junior Member
Hi

i have a problem that i have deployed one of my target in runtime repository schema 'RA_USER' then for the purpose of deploying new target. I tried to clear target schema and mistakenly I deleted all the tables from runtime schema.

after that when I tried to deploy new target it is giving

RPE-01012: Cannot deploy to the target location because it is owned by a different runtime platform.

what shuld I do
i think i have also droped some of the table with connection information or so ......

advice... urgently
Previous Topic: Informatica
Next Topic: OWB Error logging in error table for LOB Tables
Goto Forum:
  


Current Time: Sun Dec 04 02:52:48 CST 2016

Total time taken to generate the page: 0.14273 seconds