Home » RDBMS Server » Server Administration » Login Hang (9.2.0.4 (EL 4))
Login Hang [message #378551] Tue, 30 December 2008 23:12 Go to next message
smunir362
Messages: 299
Registered: September 2007
Senior Member
AOA
I want to ask that after some days my database server refuse to login and clients are in hanging position. On inspection I saw that in enterprise manager it indicating for waiting for log switch.
I restart my server then it is ok. I also saw that there are every thing is file.
But what is the problem.(I am using in archivelog mode)
Pls help.
Re: Login Hang [message #378558 is a reply to message #378551] Tue, 30 December 2008 23:37 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
post the relevant contents from alert.<sid>.log file
Re: Login Hang [message #378598 is a reply to message #378551] Wed, 31 December 2008 01:19 Go to previous messageGo to next message
Michel Cadot
Messages: 64153
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Most likely archive log or audit destination is full.

Regards
Michel
Re: Login Hang [message #379104 is a reply to message #378598] Sun, 04 January 2009 22:05 Go to previous messageGo to next message
smunir362
Messages: 299
Registered: September 2007
Senior Member

---------- Alert log file looks like------------
Date
Oracle Instance abc Cannot allocate log,archival required
Date
ARCH: Connecting to console port.....
Thread 1 cannot allocate new log,sequence 1785.
All online log needed archiving.
Current log#2 seq#1784 mem#0 : /data/redo/redo02.log.
Re: Login Hang [message #379119 is a reply to message #379104] Mon, 05 January 2009 00:11 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


1/ Do you have sufficient free space ?? (Archive log destination)

2/ How many users connecting your database ??

3/ Please provide the below details.

Show parameter session

show parameter process


Babu
Re: Login Hang [message #379129 is a reply to message #379104] Mon, 05 January 2009 00:37 Go to previous messageGo to next message
Michel Cadot
Messages: 64153
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Michel Cadot wrote on Wed, 31 December 2008 08:19
Most likely archive log or audit is full.

Regards
Michel


[Updated on: Mon, 05 January 2009 00:38]

Report message to a moderator

Re: Login Hang [message #399591 is a reply to message #379129] Thu, 23 April 2009 02:01 Go to previous messageGo to next message
smunir362
Messages: 299
Registered: September 2007
Senior Member
AOA
I completely check the problem is that at that moment both arc0 abd arc1 background processes are dead and my database is in hanging position saying "waiting for log switch".

Is it a bug in (9.2.0.4) and fixed in later like (9.2.0.Cool

Re: Login Hang [message #399682 is a reply to message #399591] Thu, 23 April 2009 08:17 Go to previous messageGo to next message
joy_division
Messages: 4644
Registered: February 2005
Location: East Coast USA
Senior Member
I think it could also be that you are not actually in archive log more.

Do an archive log list
Re: Login Hang [message #400009 is a reply to message #399682] Sat, 25 April 2009 00:27 Go to previous messageGo to next message
smunir362
Messages: 299
Registered: September 2007
Senior Member
Dear
Database is in archive log mode. Because when restart it database is open normally and work properly and can be list archive log list.
Re: Login Hang [message #400013 is a reply to message #378551] Sat, 25 April 2009 00:39 Go to previous messageGo to next message
BlackSwan
Messages: 25050
Registered: January 2009
Location: SoCal
Senior Member
You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/
Please, please, please Read & Follow Posting Guidelines above.
Go to the section labeled "Practice" & do as directed.

Re: Login Hang [message #400227 is a reply to message #400013] Mon, 27 April 2009 03:56 Go to previous messageGo to next message
smunir362
Messages: 299
Registered: September 2007
Senior Member
ok.
But what is the problem with database.
Re: Login Hang [message #400304 is a reply to message #400009] Mon, 27 April 2009 08:18 Go to previous messageGo to next message
joy_division
Messages: 4644
Registered: February 2005
Location: East Coast USA
Senior Member
smunir362 wrote on Sat, 25 April 2009 01:27
...when restart it database is open normally and work properly and can be list archive log list.



What does that mean?

Looks like you are just ignoring questions. Once again I will ask, then move on. Do an archive log list
Re: Login Hang [message #400541 is a reply to message #400304] Tue, 28 April 2009 12:05 Go to previous messageGo to next message
smunir362
Messages: 299
Registered: September 2007
Senior Member
OK
Wait untill it behave like hanging. I will issue archive log list and place the output.
Re: Login Hang [message #400551 is a reply to message #400541] Tue, 28 April 2009 12:59 Go to previous messageGo to next message
joy_division
Messages: 4644
Registered: February 2005
Location: East Coast USA
Senior Member
No, do it NOW! Jesus Christ, we ask for you do do a simple thing which may give us insight into your problem, but no, you make it difficult. Have fun solving your problem.
Re: Login Hang [message #401731 is a reply to message #400551] Wed, 06 May 2009 04:53 Go to previous messageGo to next message
smunir362
Messages: 299
Registered: September 2007
Senior Member
It shows

mode = archivelog
destination = path
automatic archival = disabled
current = 3242432
next = 324324
Re: Login Hang [message #401732 is a reply to message #401731] Wed, 06 May 2009 04:56 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Quote:
automatic archival = disabled

No kidding!.

[Updated on: Wed, 06 May 2009 04:58]

Report message to a moderator

Re: Login Hang [message #401758 is a reply to message #401731] Wed, 06 May 2009 06:28 Go to previous messageGo to next message
Michel Cadot
Messages: 64153
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
To clear up Mahesh Rajendran's answer: activate it.

Regards
Michel
Re: Login Hang [message #401830 is a reply to message #401758] Wed, 06 May 2009 10:34 Go to previous messageGo to next message
smunir362
Messages: 299
Registered: September 2007
Senior Member
Ok fine.
U mean I have to set automatic_archival = true in my parameter file. Then it will work fine.
Re: Login Hang [message #401832 is a reply to message #401830] Wed, 06 May 2009 10:41 Go to previous message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
>>set automatic_archival = true

Instead of random thoughts and trying to use non-existent parameters, please refer to documentation.

http://download.oracle.com/docs/cd/B10501_01/server.920/a96521/archredo.htm#4751


Previous Topic: migration methods ?
Next Topic: downgrading an upgraded database
Goto Forum:
  


Current Time: Sun Dec 11 07:59:17 CST 2016

Total time taken to generate the page: 0.12183 seconds