Home » RDBMS Server » Server Utilities » Error during import (Oracle 10.2.0.1)
Error during import [message #377481] Tue, 23 December 2008 03:51 Go to next message
hedonist123
Messages: 119
Registered: August 2007
Senior Member
Hi,

Could you tell me whether Oracle 10.2.0.1 client can be used to export from a 11g database and import onto a Oracle 10.2.0.1. database?

When I tried to do the same,

after all the tables have been moved,

this is the error I see in the logs
. exporting synonyms
. exporting views
. exporting stored procedures
ORA-00904: "OLEVEL": invalid identifier
Export terminated unsuccessfully

Could you please help me out?

My colleagues tell me of a matrix which shows compatibility between clients, could you let me know where I could find this matrix?

Thanks,

Sharath
Re: Error during import [message #377488 is a reply to message #377481] Tue, 23 December 2008 04:07 Go to previous messageGo to next message
hedonist123
Messages: 119
Registered: August 2007
Senior Member
Hi,

Update to the below post.

I have found the matrix.

However, it tells me that if you wish to move a schema from
11.1.6.0 to 10.2.0.4, you should use a client of the lower version for export and import which I am doing.

Also, they go further to say that if you wish to move from 11g to 10g, the best client is 10.2.0.4.

Could you please tell me what I am doing wrong?

Thanks,

Sharath
Re: Error during import [message #377493 is a reply to message #377488] Tue, 23 December 2008 04:27 Go to previous messageGo to next message
JRowbottom
Messages: 5933
Registered: June 2006
Location: Sunny North Yorkshire, ho...
Senior Member
Are you doing an whole database export, or an export of an individual schema?
Re: Error during import [message #377543 is a reply to message #377493] Tue, 23 December 2008 07:07 Go to previous message
hedonist123
Messages: 119
Registered: August 2007
Senior Member
I am doing a schema import.

Anyway,

I have found the fix, Seems to be a problem with 10.2.0.4 client,

I was able to successfully export the 11g schema using 10.2.0.1 client after which I successfully imported it onto 10.2.0.4 database.

Metalink has this error documented. Seems to be a result of incorrect patch application. Please have a look at the attached file. The page doesnt allow me to load a htm file, So, I have put the contents in a notepad file.

Perhaps this patch was not present on my Oracle 10.2.0.1 client.

Sharath

[EDITED by LF] I have deleted the attached TXT file as it violates copyright held by Oracle.

@hedonist123, it is NOT allowed to post such a material on the OraFAQ Forum. You might, however, post a LINK to it. Everyone who has access to it will be able to view it.

[Updated on: Tue, 23 December 2008 10:57] by Moderator

Report message to a moderator

Previous Topic: Microsoft Access Data
Next Topic: sqlldr parameters to handle SQL*Loader-500: Unable to open file
Goto Forum:
  


Current Time: Fri Dec 02 16:48:40 CST 2016

Total time taken to generate the page: 0.26915 seconds