Home » RDBMS Server » Backup & Recovery » USERS01.DBF issue ( , Windows 2003 SP2)
USERS01.DBF issue [message #365305] Thu, 11 December 2008 06:25 Go to next message
Messages: 3
Registered: December 2008
Junior Member
Hi all!

First of all I want to say that I know very few things about Oracle, so I'm asking for your help! Although I tried to find out some things by searching here, but time passes and I feel more pressure and thats why I turn to you.

I deleted the file USERS01.DBF - dont ask why.

I restored it from yesterdays Windows backup tape, but nothing. I get message "ORA-01113: file 4 needs media recovery" which file 4 is USERS01.DBF

It seems that the db isnt running on archive mode, so a recover command isnt an option.

But! every day we make an export. So what can I do ?



Re: USERS01.DBF issue [message #365666 is a reply to message #365305] Thu, 11 December 2008 22:09 Go to previous messageGo to next message
Messages: 666
Registered: January 2007
Location: Ha Noi, Viet Nam
Senior Member
You could not restore it from a Window backup program or any backup programs which not be relates or certificated by Oracle.

Unless your database was backed up by RMAN or User_Manage_Backup Oracle's method, you will restore/recovery the datafile 4 named as USERS01.DBF. Otherwise, your database is in archive log mode, and your archive log files were be right, you've got the newest backup, then you may restore/recover it without losing data. Or your database is in No archive log mode, you've got the newest backup, you will restore/recover it with some - little lost data.
Re: USERS01.DBF issue [message #375876 is a reply to message #365666] Mon, 15 December 2008 03:52 Go to previous message
Messages: 3
Registered: December 2008
Junior Member
weeeelll! to update on the story...

I restored the whole oracle folder from a windows backup and it worked fine for me!

Previous Topic: create a database from offline backup
Next Topic: A question about cold backup
Goto Forum:

Current Time: Thu Oct 27 06:02:05 CDT 2016

Total time taken to generate the page: 0.06742 seconds