Home » RDBMS Server » Backup & Recovery » How to Remove Old Tape Backups (Oracle 10g)
icon5.gif  How to Remove Old Tape Backups [message #364922] Wed, 10 December 2008 08:25 Go to next message
SJDewar
Messages: 15
Registered: July 2005
Junior Member
We have an Oracle 10g database, at one point, there was a tape backup device configured and working. This tape device has since been removed, but there are still backups that were done to tape that are in the controlfile. These backups are quite old and rman knows they are obsolete, but it can't delete them, since the tape device (and channel) no longer exists.

I have tried many ways of trying to delete them, but I consistently end up with the same result of:
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of delete command at 09/11/2007 13:10:06
RMAN-06091: no channel allocated for maintenance (of an appropriate type)

I am able to allocate a channel type of disk, but not sbt because it is not there, so I am having trouble getting rid of these entries. Any help is appreciated.

Thanks in advance,

S.

Re: How to Remove Old Tape Backups [message #364931 is a reply to message #364922] Wed, 10 December 2008 08:53 Go to previous message
Michel Cadot
Messages: 64098
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Why don't you post the whole session including all the commands?

Please read OraFAQ Forum Guide, especially "How to format your post?" section.
Make sure that lines of code do not exceed 80 characters when you format.
Indent the code (See SQL Formatter) and use code tags.
Use the "Preview Message" button to verify.

Regards
Michel
Previous Topic: rman restore on windows server
Next Topic: archivelogs older than retention policy don't delete
Goto Forum:
  


Current Time: Fri Dec 02 12:11:20 CST 2016

Total time taken to generate the page: 0.06402 seconds