Home » RDBMS Server » Server Administration » can not change SID (Oracle 10g databse)
can not change SID [message #364511] Mon, 08 December 2008 23:23 Go to next message
meisam
Messages: 14
Registered: August 2008
Location: malaysia
Junior Member
Hi everybody,

I have created a new database using dbca, but the EM is still connecting the previous SID, how can I change my SID?

the other thins is that I am trying to connect to isqlplus, I am getting this error:

ERROR - ORA-12154: TNS: could not resolve the connect identifier specified.

what should write for connect identifier?

thanks
Re: can not change SID [message #364513 is a reply to message #364511] Mon, 08 December 2008 23:32 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ORA-12154: TNS:could not resolve the connect identifier specified
 *Cause:  A connection to a database or other service was requested using
 a connect identifier, and the connect identifier specified could not
 be resolved into a connect descriptor using one of the naming methods
 configured. For example, if the type of connect identifier used was a
 net service name then the net service name could not be found in a
 naming method repository, or the repository could not be
 located or reached.
 *Action:
   - If you are using local naming (TNSNAMES.ORA file):
      - Make sure that "TNSNAMES" is listed as one of the values of the
        NAMES.DIRECTORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA)
      - Verify that a TNSNAMES.ORA file exists and is in the proper
        directory and is accessible.
      - Check that the net service name used as the connect identifier
        exists in the TNSNAMES.ORA file.
      - Make sure there are no syntax errors anywhere in the TNSNAMES.ORA
        file.  Look for unmatched parentheses or stray characters. Errors
        in a TNSNAMES.ORA file may make it unusable.
   - If you are using directory naming:
      - Verify that "LDAP" is listed as one of the values of the
        NAMES.DIRETORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA).
      - Verify that the LDAP directory server is up and that it is
        accessible.
      - Verify that the net service name or database name used as the
        connect identifier is configured in the directory.
      - Verify that the default context being used is correct by
        specifying a fully qualified net service name or a full LDAP DN
        as the connect identifier
   - If you are using easy connect naming:
      - Verify that "EZCONNECT" is listed as one of the values of the
        NAMES.DIRETORY_PATH parameter in the Oracle Net profile
        (SQLNET.ORA).
      - Make sure the host, port and service name specified
        are correct.
      - Try enclosing the connect identifier in quote marks.

   See the Oracle Net Services Administrators Guide or the Oracle
   operating system specific guide for more information on naming.

There is few things to do to change the SID: change ORACLE_SID variable and change init.ora or spfile name and restart. (More if you are on Windows but you didn't say.)

Regards
Michel
Re: can not change SID [message #364515 is a reply to message #364513] Mon, 08 December 2008 23:43 Go to previous messageGo to next message
meisam
Messages: 14
Registered: August 2008
Location: malaysia
Junior Member
Hi,

thank you for the reply, oracle DB is on Red hat. actually my tnsnames.ora is located in $ORACLE_HOME/network/admin/samples/

i have checked the tnsnames.ora, that is set properly. but when i aconnecting to the isqlplus, i dun know what to write for connect identifier.

>>net service name or database name

my database name is moon. i mean what i create with dbca is moon, so my connect identifier is moon ?

regards
Re: can not change SID [message #364529 is a reply to message #364515] Tue, 09 December 2008 00:28 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
$ORACLE_HOME/network/admin/samples/

This is NOT the default location so unless you set TNS_ADMIN variable Oracle does not read it.

Regards
Michel
Re: can not change SID [message #364556 is a reply to message #364529] Tue, 09 December 2008 01:23 Go to previous messageGo to next message
meisam
Messages: 14
Registered: August 2008
Location: malaysia
Junior Member
hi,

can you help me to tell me how to set this to the right location? I am REALLY confused.

when i open this page: http://192.168.0.175:5560/isqlplus

i have to enter 3 things,
user name: will be my database user name = moon
password: the one i set in dbca config while creating db
connect identifier: i enter database name = moon

i receive this:

ERROR - ORA-12154: TNS: could not resolve the connect identifier specified.

then you are telling me my tnsnames.ora is not in the right location.

could you please give me some steps if possible?

really appreciae it.
Re: can not change SID [message #364559 is a reply to message #364556] Tue, 09 December 2008 01:34 Go to previous message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Default location is $ORACLE_HOME/network/admin

Please have a look at Database Net Services Reference

Regards
Michel
Previous Topic: creating database with 8K block size in oracle 9i - ORA-00058
Next Topic: Trace file name
Goto Forum:
  


Current Time: Sun Dec 04 16:36:24 CST 2016

Total time taken to generate the page: 0.13616 seconds